cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2154
Views
5
Helpful
4
Replies

ASA 5510 Routing

zheepern0826
Level 1
Level 1

Hi Guys,

I just got a ASA 5510 and have some problem during setup.
Below is my sample diagram:

PC(10.126.183.225) ----- ASA e0/0 (10.126.183.228/29) ---- ASA e0/1 (172.16.0.1/24) ---- PC(172.16.0.50)

Both pc can ping to the gateway interface at ASA but they are unable to ping to each other.
Below is my config.

FW1# sh run
: Saved
:
ASA Version 8.2(5)13
!
hostname FW1
domain-name test.sg
enable password 9jNfZuG3TC5tCVH0 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
description WAN_Interface
nameif WAN
security-level 0
ip address 10.126.183.228 255.255.255.248
!
interface Ethernet0/1
description LAN_Interface
nameif LAN
security-level 0
ip address 172.16.0.1 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif Mgmt
security-level 0
ip address 192.168.1.1 255.255.255.0
!
banner motd "Test."
ftp mode passive
clock timezone SGP 8
dns server-group DefaultDNS
domain-name test.sg
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
pager lines 24
logging enable
logging timestamp
logging standby
logging buffer-size 65536
logging console critical
logging buffered informational
logging trap informational
logging history informational
logging asdm informational
logging facility 17
mtu WAN 1500
mtu LAN 1500
mtu Mgmt 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any WAN
icmp permit any echo WAN
icmp permit any LAN
icmp permit any echo LAN
asdm image disk0:/asdm-645-206.bin
no asdm history enable
arp timeout 14400
route WAN 0.0.0.0 0.0.0.0 10.126.183.225 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication serial console LOCAL
http server enable
http server session-timeout 5
http 192.168.1.0 255.255.255.0 Mgmt
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 15
ssh version 2
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 216.239.35.4
webvpn
username admin password e1z89R3cZe9Kt6Ib encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:5be53063e364c0996b7c846a0907d315
: end
FW1#

When i check the route, routing is exist but both PC unable to ping.
FW1# sh route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 129.126.183.225 to network 0.0.0.0

C 172.31.0.0 255.255.255.0 is directly connected, LAN
C 129.126.183.224 255.255.255.248 is directly connected, WAN
S* 0.0.0.0 0.0.0.0 [1/0] via 129.126.183.225, WAN
FW1#

Possible to advise what i have missed out ?

1 Accepted Solution

Accepted Solutions

instead of ip, allow icmp on your access list as its different

Please remember to rate useful posts, by clicking on the stars below.

View solution in original post

4 Replies 4

cmgossett1983
Level 1
Level 1

You need NAT rules between the two interfaces as they have the same security level.  If one interface had a higher security level than the other, you would also need to add an access-list and an access-group applying it to allow the traffic from the lower security level interface.

Hi, 

Thanks for reply. I also read that during google search and i have configure the security level, access list and assign to the interface. 

 

interface Ethernet0/0

description WAN_Interface

nameif WAN

security-level 0

ip address 129.126.183.228 255.255.255.248

interface Ethernet0/1

description LAN_Interface

nameif LAN

security-level 100

ip address 172.31.0.1 255.255.255.0

access-list WAN_access_in extended permit ip any any log

access-list LAN_access_in extended permit ip any any log

access-group WAN_access_in in interface WAN

access-group LAN_access_in in interface LAN

 

However, both pc still cannot ping to each other.

instead of ip, allow icmp on your access list as its different

Please remember to rate useful posts, by clicking on the stars below.

Hi Dennis, 

 

I have create a object group with icmp services and include in the acl.

 

object-group service PING
service-object ip
service-object icmp
service-object icmp echo
service-object icmp echo-reply
service-object icmp traceroute

 

access-list WAN_access_in extended permit object-group PING any any log
access-list LAN_access_in extended permit object-group PING any any log

 

access-group WAN_access_in in interface WAN
access-group WAN_access_in out interface WAN
access-group LAN_access_in in interface LAN
access-group LAN_access_in out interface LAN

 

***EDITED*****

 

I  able to ping from both PC now.  

Thank you very much 

 

 

 

Review Cisco Networking products for a $25 gift card