Showing results for 
Search instead for 
Did you mean: 


Clock-Signal Repair Pictures ISR4300, ASA, ISR4400


We have many devices affected by the clock-signal issues.

Cisco does replace the units with repaired/fixed ones.

I have received some ISR4321 routers with the fix applied (pictures attached).

The Cisco provided fix is of - well - mediocre quality (loose solder joints etc..) but works.

I am an EE engineer and am able to fix other routers of my customers as well (attached a picture of one of my fixes).

Spot the difference :)

Is there anyone which has received fixed ASA5506, ASA5508 and ISR4331 routers?

Please post pictures of your fix (hi-res if possible)

I ask because I would like to fix them as well (some of my customers) and avoid configuration, license etc. migration.

I am aware that I might void Ciscos warranty by this act of evil :)

Best regards,



ISR4351 and ASA5506 are still on my list. No RMA received yet.


I do not want to know Ciscos backlog.... must be huge


Does anyone have any idea what the voltage should be on the "151" 150Ohm 0604/0402 resistor should be? Others have mentioned 1% tolerance, just curious what voltage rating, ie. 5v?





I used the following in size 0603 and have installed these in several units now. Four were already bricked, and these brought them back to life. Once installed I checked resistance using the corresponding points on the board and they all came back at a solid 150.0 Ohms. Prior to installation the reading from these same points is around 74 Kohms. 


Range of thick film surface mount resistors manufactured by YAGEO including 0603, 0805, 1206 packages. Available in a wide variety of values offering a precise 1% tolerance. 

  • Packs of 100
  • Supplied on cut tape packaging
  • Excellent solderability
  • Power: 0603=0.1W, 0805=0.15W, 1206=0.25W
  • Maximum voltage: 0603=75V, 0805=150V, 1206=200V
  • 0603 dimensions: 1.6 x 0.8 x 0.45mm (L x W x H)
  • 0805 dimensions: 2.0 x 1.25 x 0.5mm (L x W x H)
  • 1206 dimensions: 3.1 x 1.6 x 0.55mm (L x W x H)



Howdy! You mention Ohm readings, on which side? Toward CPU or away?


Also, did you ever work in a 5508?




The ohm reading is across the added resistor.

Yes, I worked on ASA5508 as well and applied the fix successfully.




Thanks for the update, I had assumed the reading was across the resistor, but curious as to why it was going from a modestly high reading to a lower one when presumably the 3.3v is patched to the LPC? Without the patch I can't see where they would have had any connectivity at all (as I understand it the LPC1:0 are both outbound 25Mhz signals?)


Also, do you have any pics of the fix or even a method to find the LPC's on the 5508? Just use a scope to look for the 25Mhz signal? It's a lot of pins and of course I don't have a layout of the PCB.





Did you ever get an ISR4351? Cannot find a picture with the mod applied to that model.


Sorry, I never had an ISR4351 in my hand.

If anyone has a repaired previously affected model, please let us know.




Any chance you could give me a hint as to where the LPC is on the 5508? I've scoped all the north resistors and can't find a clock on any of them. I've attached a photo of the area where the LPC should be. Only place I remotely found a clock I've circled. I don't want to just willy-nilly run a 3.2 to it and potentially break a working unit (it's a v01 in my lab).





Any news on 5508?
I’ve one I would try to fix but I didn’t understand what exactly I’ve to do on this mobo.
Can you please give us more details?

I never heard anything back. I have  a 5508 that works but would rather it didn't break if possible. Was thinking of pulling up the resistor I'd pointed out in the photo but never got confirmation and don't want to break the unit (I don't see a clean clock on that resistor).


I haven't probed the underside of the mobo for a clock, thinking I must be missing something as it was mentioned previously that the 5508 "has the same pinout" as the 5506?



I have a non working 5508 V02. Has anyone repaired one? Reading the thread it seemed like no one has worked out the specifics?


Didn't have any luck finding any pictures of a 4351 repair so I went through the process of testing a pull-up resistor against all the existing resistors one by one. Eventually found R108 to be the one - brought a non-working system back to life.


It is located on the top side of the motherboard, under the processor heatsink.




Colin, please post a picture of 4351 after repair too.  Thanks.




is it possible to use a round carbon metal film or a round metal film resistor instead of a surface mount?

I need a temporary fix to get back my config file.



Content for Community-Ad