- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-09-2015 12:03 AM - edited 03-11-2019 10:54 PM
I have an ASA 5510 configured to manage 7 VLANs, some of these VLANs need access to the internet, others don't. One of these VLANs is a management VLAN and it needs internet access. The ASA is trunked to switch, which has different ports activated for the different VLANs.
So far, I am unable to get the Data VLAN to access the internet and would like some help with my config, please see below:
:
ASA Version 9.1(6)
!
!
interface Ethernet0/0
description Trunk Port for all VLANS
no nameif
no security-level
no ip address
!
interface Ethernet0/0.200
vlan 200
nameif Data
security-level 100
ip address 172.16.0.1 255.255.255.0
!
interface Ethernet0/0.300
vlan 300
nameif UAT_DMZ
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/0.400
vlan 400
nameif UAT_SECURE
security-level 100
ip address 10.135.17.1 255.255.255.0
!
interface Ethernet0/0.500
vlan 500
nameif UAT_INTCON
security-level 100
ip address 172.30.50.1 255.255.255.0
!
interface Ethernet0/0.601
vlan 601
nameif PROD_DMZ
security-level 100
ip address 192.168.255.1 255.255.255.0
!
interface Ethernet0/0.602
vlan 602
nameif PROD_SECURE
security-level 100
ip address 10.149.57.1 255.255.255.0
!
interface Ethernet0/0.603
vlan 603
nameif PROD_INTCON
security-level 100
ip address 172.19.205.1 255.255.255.0
!
interface Ethernet0/1
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
nameif Outside
security-level 0
ip address x.x.x.2 255.255.255.248
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
!
boot system disk0:/asa916-k8.bin
ftp mode passive
clock timezone WAT 1
dns domain-lookup Data
dns domain-lookup UAT_DMZ
dns domain-lookup UAT_SECURE
dns domain-lookup UAT_INTCON
dns domain-lookup PROD_DMZ
dns domain-lookup PROD_SECURE
dns domain-lookup PROD_INTCON
dns domain-lookup Outside
dns server-group DefaultDNS
name-server 8.8.8.8
name-server 41.75.80.84
name-server 4.2.2.1
name-server 4.2.2.2
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network UAT_INTCON-nw
subnet 172.30.50.0 255.255.255.0
object network UAT_DMZ-nw
subnet 192.168.100.0 255.255.255.0
object network UAT_SECURE-nw
subnet 10.135.17.0 255.255.255.0
object network PROD_DMZ-nw
subnet 192.168.255.0 255.255.255.0
object network PROD_INTCON-nw
subnet 172.19.205.0 255.255.255.0
object network PROD_SECURE-nw
subnet 10.149.57.0 255.255.255.0
object network AnyNetwork
subnet 0.0.0.0 0.0.0.0
description Any network
object network Data-nw
subnet 172.16.0.0 255.255.255.0
object-group network UAT-nw
description UAT
network-object object UAT_DMZ-nw
network-object object UAT_INTCON-nw
network-object object UAT_SECURE-nw
object-group icmp-type ICMP-ALLOWED
icmp-object echo-reply
icmp-object time-exceeded
object-group protocol DM_INLINE_PROTOCOL_1
protocol-object ip
protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_2
protocol-object ip
protocol-object tcp
access-list Inside_access_in extended permit object-group DM_INLINE_PROTOCOL_2 object Data-nw any4
access-list Outside_access_in extended permit icmp any4 any4 object-group ICMP-ALLOWED
access-list Outside_access_in extended permit tcp any4 eq ssh any4 eq ssh
access-list Data_access_out extended permit object-group DM_INLINE_PROTOCOL_1 172.16.0.0 255.255.255.0 any4
pager lines 24
logging enable
logging asdm informational
mtu Data 1500
mtu UAT_DMZ 1500
mtu UAT_SECURE 1500
mtu UAT_INTCON 1500
mtu PROD_DMZ 1500
mtu PROD_SECURE 1500
mtu PROD_INTCON 1500
mtu Outside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-733.bin
asdm history enable
arp timeout 14400
no arp permit-nonconnected
access-group Inside_access_in in interface Data
access-group Data_access_out out interface Data
access-group Outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 x.x.x.1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username femiagboade password 8X0YakmhG.ZUnPIp encrypted
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:dbbbb3db4af994e19705573ddf4930a3
: end
Been on this for a while and would greatly appreciate any help I can get to get this to work.
Solved! Go to Solution.
- Labels:
-
NGFW Firewalls
Accepted Solutions

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-09-2015 03:14 AM
Hi,
I think the most important to get working would be the connectivity from the Workstations in the VLAN to the ASA interface.
Once , you get that working you just need to configure the NAT statement for going out to the internet:-
Object network obj-0.0.0.0
subnet 0 0
nat (management,outside) dynamic interface
You need to do the same for the other interfaces.
Thanks and Regards,
Vibhor Amrodia

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-09-2015 03:14 AM
Hi,
I think the most important to get working would be the connectivity from the Workstations in the VLAN to the ASA interface.
Once , you get that working you just need to configure the NAT statement for going out to the internet:-
Object network obj-0.0.0.0
subnet 0 0
nat (management,outside) dynamic interface
You need to do the same for the other interfaces.
Thanks and Regards,
Vibhor Amrodia
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-09-2015 09:16 AM
Hello Vibhor,
Do these commands work on this version of IOS as this was the challenge i had with some of the commands i am used to?
I can confirm that the workstations in the VLANs can reach the ASA.
So after these nat commands, nothing else is needed? No access lists?
Regards,
Femi

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-09-2015 09:46 PM
Hi,
Yes this command will work on the ASA code that you are running.
No , access list is required as the traffic is going from the Higher to Lower Security which is allowed by default.
Thanks and Regards,
Vibhor Amrodia
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-10-2015 10:11 AM
Hi Vibhor,
Thanks for the pointer, it helped me figure out where i went off with my config as well.
Cheers.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-11-2015 02:07 AM
NAT (PAT) configuration for internet access has been not configured.
is enough create some object for any subnet that you wanna internet access, and configure nat (dynamic) on this object.
I would not proceed to configure any object like the example above, (subnet 0.0.0.0)
put i'd like to proceed with specific subnet configuration.
Regards
