08-09-2024 09:04 AM
Dears,
Can someone please help me with the problem below:
Physical Connectivity:
Cisco-RTR (eth0/1) SVI --->Trunk (eth0/0) L3-Switch (eth0/1) ---> (eth0) CiscoASA
Router:
interface Ethernet0/1.2
encapsulation dot1Q 2
ip address 192.168.1.2 255.255.255.0
end
!
interface Ethernet0/1
no ip address
end
-----
Switch:
interface Ethernet0/0
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
end
!
interface Ethernet0/1
switchport access vlan 2
switchport mode access
end
!
show vlan brief
VLAN Name Satus Ports
2 VLAN0002 active Et0/1
-----
CiscoASA
interface ethernet0
no shutdown
!
interface ethernet0.1
vlan 2
no shutdown
!
Context P1
allocate-interface ethernet0.2 IN_P1
!
changeto context P1
!
interface IN_P1
nameif inside
security-level 100
ip add 192.168.1.1 255.255.255.0
Router# ping 192.168.1.1
.....
I am sitting on Router trying to ping interface (IN_P1) it's not working. When am connecting direct cables I mean Cisco ASA with Router it works but having a Core L3 Switch in between is creating a problem even though nothing is misconfigured, am I missing something?
Appreciate your assistance.
Solved! Go to Solution.
08-09-2024 09:33 AM
interface Ethernet0/0
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
end
!
interface Ethernet0/1
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
Friend since you use subinterface you need to make SW interface as trunk not as access
MHM
08-09-2024 09:24 AM
Hi @JunaidM
Switch usually does not required "switchport trunk encapsulation dot1q"
Could you remove it and test?
08-09-2024 09:33 AM
interface Ethernet0/0
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
end
!
interface Ethernet0/1
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
Friend since you use subinterface you need to make SW interface as trunk not as access
MHM
08-09-2024 09:39 AM
@MHM Cisco World thank you so much, I was struggling since last night, my mistake, is there any document from specifically for this I can read why it should be a trunk port?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide