04-16-2014 12:26 PM - edited 03-11-2019 09:05 PM
Hi all. I am trying to open port 1194(openvpn) and forward it to the server I have on the inside. I've followed several different sites that had both ASDM or CLI instructions but to no avail. Would someone be able to suggest what I need to add? I cleared out the work I had done before so you won't see that in the config below. The OpenVPN server is running at 192.168.11.250. Thank you for any assistance you can provide.
: Saved
:
ASA Version 9.1(5)
!
hostname genericasa
domain-name generic.com
enable password
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd
names
name 192.168.3.0 RemoteOffice
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.11.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 111.222.333.444 255.255.255.0
!
boot system disk0:/asa915-k8.bin
boot system disk0:/asa914-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name generic.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj-192.168.11.0
subnet 192.168.11.0 255.255.255.0
object network RemoteOffice
subnet 192.168.3.0 255.255.255.0
object network obj_any
subnet 0.0.0.0 0.0.0.0
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list outside_1_cryptomap extended permit ip 192.168.11.0 255.255.255.0 object RemoteOffice
access-list inside_nat0_outbound extended permit ip 192.168.11.0 255.255.255.0 object RemoteOffice
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-716.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,any) source static obj-192.168.11.0 obj-192.168.11.0 destination static RemoteOffice RemoteOffice no-proxy-arp route-lookup
!
object network obj_any
nat (inside,outside) dynamic interface
route outside 0.0.0.0 0.0.0.0 111.222.333.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.11.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 444.333.222.111
crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.11.0 255.255.255.0 inside
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.11.0 255.255.255.0 inside
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.11.100-192.168.11.200 inside
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
dhcpd enable inside
!
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group 444.333.222.111 type ipsec-l2l
tunnel-group 444.333.222.111 ipsec-attributes
ikev1 pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:
: end
asdm image disk0:/asdm-716.bin
asdm location RemoteOffice 255.255.255.0 inside
no asdm history enable
Solved! Go to Solution.
04-16-2014 02:54 PM
object network open-vpn
host 192.168.11.250
nat (inside,outside) static interface service udp 1194 1194
access-list outside_access_in extended permit udp any host 192.168.11.250 eq 1194
access-group outside_access_in in interface outside
Did your configuration look anything like the above? If so it should have worked. Did you use packet tracer to see where it was failing?
04-16-2014 02:54 PM
object network open-vpn
host 192.168.11.250
nat (inside,outside) static interface service udp 1194 1194
access-list outside_access_in extended permit udp any host 192.168.11.250 eq 1194
access-group outside_access_in in interface outside
Did your configuration look anything like the above? If so it should have worked. Did you use packet tracer to see where it was failing?
04-16-2014 03:49 PM
Thank you! I can't recall if that was what I had before since I had tried so many options and was also being pulled in 10 directions at the same time. I ran those entries you provided and I'm in business! Thank you for taking the time!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide