cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco Wants your Feedback on the Catalyst 9500!

365
Views
0
Helpful
1
Comments
caiharve
Cisco Employee

Review the Cisco Catalyst 9500 Series Switches on TrustRadius and receive a $25 gift card! 

1.jpg

1 Comment

My cisco switches Model - C9500-16X

Cisco IOS XE Software,

Version 16.12.03a

Cisco IOS Software [Gibraltar],

Catalyst L3 Switch Software (CAT9K_IOSXE)

 

I have two core switches in my network, the primary is active  & the secondary acts as a backup.

Configured Protocol - STP, VRRP, DHCP Pool.

 

Problem Description:

VLAN 1 - DHCP discovery take place through for Vlan1 from core 1 switch i.e. (Primary switch)

VLAN 2 - DHCP discovery take place through for Vlan 2 from both switches

i.e. For the VLAN 1 - The user will get an IP address from the DHCP pool released from the core 1 switch only, But in the case of VLAN 2 - The user will get an IP address from the DHCP pool released from both switches (core1 & core2) due to that IP address conflict issue are seen.

 

Kindly advise me why the VLAN 2 DHCP discovery loading is seen from both switches & network diagram revised.JPGhelp to resolve the issue of VLAN 2.

 

Core 1 configuration as below :

ip dhcp pool user
network 172.16.0.0 255.255.248.0
dns-server XXXXXXX
default-router 172.16.0.2
domain-name XXXXXXXX
lease infinite
!
ip dhcp pool guest
network 10.128.0.0 255.255.254.0
default-router 10.128.0.1
dns-server XXXXXX
domain-name XXXXXX
lease infinite

 

spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-2 priority 24576
memory free low-watermark processor 134344

 

interface Vlan1
ip address 172.16.0.2 255.255.248.0
vrrp 2 address-family ipv4
priority 110
preempt delay minimum 60
track 100 decrement 10
address 172.16.0.1 primary
exit-vrrp
!
interface Vlan2
ip address 10.128.0.1 255.255.254.0
vrrp 3 address-family ipv4
priority 125
preempt delay minimum 60
track 150 decrement 10
address 10.128.0.3 primary
exit-vrrp

 

Core 2 configuration done as below 

ip dhcp pool user
network 172.16.0.0 255.255.248.0
default-router 172.16.0.3
dns-server XXXXXXX
domain-name XXXXXX
lease infinite
!
ip dhcp pool guest
network 10.128.0.0 255.255.254.0
default-router 10.128.0.2
dns-server XXXXXX
domain-name XXXXXX
lease infinite
!

spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-2 priority 28672
memory free low-watermark processor 134356

 

interface Vlan1
ip address 172.16.0.3 255.255.248.0
vrrp 2 address-family ipv4
priority 105
preempt delay minimum 60
track 100 decrement 10
address 172.16.0.1 primary
exit-vrrp
!
interface Vlan2
ip address 10.128.0.2 255.255.254.0
vrrp 3 address-family ipv4
priority 120
preempt delay minimum 60
track 150 decrement 10
address 10.128.0.3 primary
exit-vrrp