cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Setting up an ISR Router for BT Fibre / Infinity ADSL Without Using the Business Hub

1963
Views
5
Helpful
0
Comments
Cisco Employee

A friend of mine recently asked me to assist them with configuring a Cisco ISR router for BT Infinity / Fibre. I decided to share the configuration for others to leverage.

 

Please note this configuration is far from complete and represents a real bare bones configuration without additional security and device hardening present. It is not in anyway a recommended configuration but can be used as a test / baseline.

 

Router: 2900 (2911)

IOS: 15.1(4)M4

ADSL  card:

NAME: "ADSL/VDSL over POTS supporting ADSL1, ADSL2, ADSL2+ and VDSL2 on Slot 0 SubSlot 1", DESCR: "ADSL/VDSL over POTS supporting ADSL1, ADSL2, ADSL2+ and VDSL2"

PID: EHWIC-VA-DSL-A   

 

Running configuration, with usernames / passwords omitted:

 

Building configuration...

 

Current configuration : 2979 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

!

!

!

!

!

aaa session-id common

!

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.10

ip dhcp excluded-address 192.168.1.200 192.168.1.254

!

ip dhcp pool DHCP Pool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

 dns-server 62.6.40.178 8.8.8.8

 lease 30

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

!

crypto pki token default removal timeout 0

!

!

redundancy

!

!

controller VDSL 0/1/0

!

ip ssh version 2

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/1/0

no ip address

shutdown

no atm ilmi-keepalive

!

interface Ethernet0/1/0

no ip address

!

interface Ethernet0/1/0.101

encapsulation dot1Q 101

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Dialer1

mtu 1492

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer idle-timeout 0

dialer-group 1

keepalive 30

ppp authentication pap chap ms-chap callin

ppp chap hostname XXXXX@XXXXX

ppp chap password 7 XXXXXXXX

ppp pap sent-username XXXX@XXXX password 7 XXXXXXXXXX

ppp ipcp dns request

ppp ipcp route default

ppp ipcp address accept

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 remark Internet access

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

control-plane

!

!

!

line con 0

exec-timeout 5 0

password 7 <removed>

logging synchronous

line vty 0 4

password 7 <removed>

transport input ssh

!

scheduler allocate 20000 1000

end

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards