cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

IPv6 - InterVlan Routing

21355
Views
0
Helpful
1
Comments

     

    Introduction

    IPv6 host residing in different VLANS communicate via L3 device to route between the VLANS. The solution known as Intervlan Routing or Router on stick, a very well known solution of IPv4. This document is focussed on configuring IPv6 intervlan routing.

    Prerequisite

    • IPv6 Addressing Scheme
    • Intervlan Routing
    • Understaning of Trunk ports

    Background

    Router R1 is connected to a layer2 switch via interface Gig0/0. The Switch interface Fa0/0 is configured as a trunk port to carry data of VLANs 10 and 20. The router interface has two sub-interface Gig0/0.10 and Gig0/0.20 interacting in vlan 10 and 20 respectively. Further there are two hosts, Client1 and Client20 in different sub-net. By default, host of different VLAN do not interact, they need a Layer 3 device to route inbetween. As host, we are using two routers configured with a static routing.

    Topology Diagram

    Topology.bmp

    Configuration

    Interface Configuration

    Interface Config.bmp

    Complete Configuration

     

    R1L2-SwitchClient10Client20

    hostname R1

    ip cef

    ipv6 unicast-routing

    !

    interface GigabitEthernet0/0

    no ip address

    duplex auto

    speed auto

    media-type rj45

    ipv6 enable

    !

    interface GigabitEthernet0/0.10

    encapsulation dot1Q 10

    ipv6 address 2012:10:10:10::1/64

    ipv6 enable

    !

    interface GigabitEthernet0/0.20

    encapsulation dot1Q 20

    ipv6 address 2012:20:20:20::1/64

    ipv6 enable

    !

    end

    hostname L2-Switch

    !

    interface FastEthernet0/1

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan 10,20

    switchport mode trunk

    !

    interface FastEthernet0/2

    switchport access vlan 10

    switchport mode access

    !

    interface FastEthernet0/3

    switchport access vlan 20

    switchport mode access

    !

    end

    Client10

    !

    interface GigabitEthernet0/0

    no ip address

    duplex auto

    speed auto

    media-type rj45

    ipv6 address 2012:10:10:10::2/64

    ipv6 enable

    !

    ipv6 route ::/0 2012:10:10:10::1

    !

    end

    hostname Client20

    !

    interface FastEthernet0/0

    no ip address

    duplex auto

    speed auto

    ipv6 address 2012:20:20:20::2/64

    ipv6 enable

    !

    ipv6 route ::/0 2012:20:20:20::1

    !

    end

     

     

    Verification Commands

    Output.bmp

    Note: Client20 from Vlan 20 is able to ping Client10 of VLAN 10.

    References

    Cisco Support: IPv6

    IPv6 Frequently Asked Questions

    Comments
    Community Member

    I Can't access the document! Please provide the link to download the document. Thanks