02-20-2024 11:40 AM
Hello guys, I am Alex and I am working on my school leaving project from Networking. I have chosen the IaaS as my topic which I have regretted a few times because I personally found the understanding of all the VXLAN and EVPN, etc. stuff pretty hard it took me about two-three months to really kinda get into the depths of it in the way of understanding it. I am configuring it in GNS3, so I thought that maybe one of you might have ever done
something like that before. So I might need some help with MPLS (MPLS VPN or MPLS L3 VPN). The main point is, here, that I would love to know how to successfully configure the MPLS I mentioned so that both PODs can communicate - PING each other, regarding the same Tenant. I have two tenants (tenant-1 and tenant-2) I have attached the topology overview. I need to configure the MPLS between PODs and also make sure and configure that Tenants can access both PODs and only their respective VLANs.
After trying to configure the MPLS at least a dozen times, it never worked for me the way I thought it would or the way I hoped for, including all the VXLAN and EVPN and Multi-Tenancy stuff. So maybe a little help would be greatly appreciated.
I hope it can be understood somehow, I know it is not perfect work, yet, so any catch-ups on what can be done better, just feel free to note, I will really be grateful for that.
LEAFs are Titanium 7300 Nexus-OS MLSWs and SPINEs are Nexus-OS 9300 v 9.3.4 MLSWs
Here is the topology:
The topology in GNS3
Here is the CONFIG part of all my devices, as you can see in the topology, the names might be not so precise but they should suit enough.
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
CONFIG
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
SITE-POD-01
iBGP - ASN - 65001
VLAN 10 - vrf tenant-1 member vni 10010
VLAN 11 - vrf tenant-1
ip add 192.168.11.0 /24
VLAN 12 - vrf tenant-1
ip add 192.168.12.0 /24
VLAN 20 vrf tenant-2 member vni 20020
VLAN 21 - vrf tenant-2
ip add 192.168.21.0 /24
VLAN 22 - vrf tenant-2
ip add 192.168.22.0 /24
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
DO APPLY TO ALL DEVICES!
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
system jumbomtu 9216
_____________________________
LEAFs
license grace-period
feature privilege
feature telnet
feature vrrp
feature ospf
feature bgp
feature pim
feature private-vlan
feature interface-vlan
feature vn-segment-vlan-based
feature glbp
feature dhcp
feature tunnel
feature vpc
feature lldp
feature vtp
feature bfd
feature nv overlay
feature vni
install feature-set fabric
install feature-set fabricpath
feature-set fabric
feature-set fabricpath
feature fabric forwarding
nv overlay evpn
_______________________________
SPINEs
feature-set mpls
feature privilege
feature telnet
feature vrrp
feature tacacs+
nv overlay evpn
feature ospf
feature bgp
feature pim
feature eigrp
feature isis
feature fabric forwarding
feature private-vlan
feature port-security
feature interface-vlan
feature vn-segment-vlan-based
feature dhcp
feature vpc
feature lldp
feature vtp
feature bfd
feature nv overlay
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
SPINE-01-POD-01
hostname SPINE-01-POD-01
int loo 0
ip add 1.1.1.1/32
int loo 1
ip add 1.1.1.10/32
int loo 100
ip add 1.1.1.100/32
int loo 254
ip add 10.254.254.254/32
int eth1/1
ip add 172.16.1.1 255.255.255.252
int eth1/2
ip add 172.16.2.1 255.255.255.252
int eth1/10
Linka k LEAF-10
ip add 10.1.10.1 255.255.255.252
int eth1/20
Linka k LEAF-20
ip add 10.1.20.1 255.255.255.252
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.1.1.1
log-adjacency-changes detail
int eth 1/10
description Linka k LEAF-10-POD-01
mtu 9216
no switchport
ip add 10.1.10.1 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 1/20
description Linka k LEAF-20-POD-01
mtu 9216
no switchport
ip add 10.1.20.1 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback pre OSPF RID
ip add 1.1.1.1/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback pre VTEP PIP
ip add 1.1.1.10/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback pre PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
ip pim anycast-rp 10.254.254.254 1.1.1.1
ip pim anycast-rp 10.254.254.254 1.1.2.1
router bgp 65001
router-id 1.1.1.1
neighbor 1.1.10.2
remote-as 65001
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 1.1.20.2
remote-as 65001
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
—-------------------------------------------------------------------
evpn multisite border-gateway 100
delay-restore time 30
interface e1/1
description Linka k PE-1-WAN-ISP-I
mtu 9216
ip add 172.16.1.1 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
interface e1/2
description Linka k PE-2-WAN-ISP-II
mtu 9216
ip add 172.16.2.1 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
int e1/30
description Linka k SPINE-02-POD-01
mtu 9216
ip add 172.17.1.1/30 tag 54321
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
evpn multisite fabric-tracking
int loopback 100
description Loopback pre VTEP
ip add 1.1.1.100/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
route-map SITE-REDIST-DIRECT-CONN permit 100
match tag 54321
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
multisite border-gateway interface loopback 100
member vni 10011
multisite ingress-replication
mcast-group 239.0.0.11
suppress-arp
member vni 10012
multisite ingress-replication
mcast-group 239.0.0.12
suppress-arp
member vni 20021
multisite ingress-replication
mcast-group 239.0.0.21
suppress-arp
member vni 20022
multisite ingress-replication
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
router bgp 65001
address-family ipv4 unicast
redistribute direct route-map SITE-REDIST-DIRECT-CONN
maximum-paths 4
neighbor 1.1.2.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.1.200.100 ( PE-1 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 1.1.200.200 ( PE-2 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 172.16.1.2
remote-as 65535
update-source eth1/1
address-family ipv4 unicast
neighbor 172.16.2.2
remote-as 65535
update-source eth1/2
address-family ipv4 unicast
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
SPINE-02-POD-01
hostname SPINE-02-POD-01
int loo 0
ip add 1.1.2.1/32
int loo 1
ip add 1.1.2.10/32
int loo 100
ip add 1.1.2.100/32
int loo 254
ip add 10.254.254.254/32
int eth1/1
ip add 172.16.1.5 255.255.255.252
int eth1/2
ip add 172.16.2.5 255.255.255.252
int eth1/10
ip add 10.2.10.1 255.255.255.252
int eth1/20
ip add 10.2.20.1 255.255.255.252
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.1.2.1
log-adjacency-changes detail
int eth 1/10
description Linka k LEAF-10-POD-01
mtu 9216
ip add 10.2.10.1 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 1/20
description Linka k LEAF-20-POD-01
mtu 9216
ip add 10.2.20.1 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback pre OSPF RID
ip add 1.1.2.1/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback pre VTEP PIP
ip add 1.1.2.10/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback pre PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
ip pim anycast-rp 10.254.254.254 1.1.1.1
ip pim anycast-rp 10.254.254.254 1.1.2.1
router bgp 65001
router-id 1.1.2.1
neighbor 1.2.10.2
remote-as 65001
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 1.2.20.2
remote-as 65001
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
—---------------------------------------------------------------------------
evpn multisite border-gateway 100
delay-restore time 30
interface e1/1
description Linka k PE-1-WAN-ISP-I
mtu 9216
ip add 172.16.1.5 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
interface e1/2
description Linka k PE-2-WAN-ISP-II
mtu 9216
ip add 172.16.2.5 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
int e1/30
description Linka k SPINE-01-POD-01
mtu 9216
ip add 172.17.1.2/30 tag 54321
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
evpn multisite fabric-tracking
int loopback 100
description Loopback pre VTEP
ip add 1.1.2.100/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
route-map SITE-REDIST-DIRECT-CONN permit 100
match tag 54321
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
multisite border-gateway interface loopback 100
member vni 10011
multisite ingress-replication
mcast-group 239.0.0.11
suppress-arp
member vni 10012
multisite ingress-replication
mcast-group 239.0.0.12
suppress-arp
member vni 20021
multisite ingress-replication
mcast-group 239.0.0.21
suppress-arp
member vni 20022
multisite ingress-replication
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
router bgp 65001
address-family ipv4 unicast
redistribute direct route-map SITE-REDIST-DIRECT-CONN
maximum-paths 4
neighbor 1.1.1.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.1.200.100 ( PE-1 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 1.1.200.200 ( PE-2 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 172.16.1.6
remote-as 65535
update-source eth1/1
address-family ipv4 unicast
neighbor 172.16.2.6
remote-as 65535
update-source eth1/2
address-family ipv4 unicast
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
LEAF-10
hostname LEAF-10-POD-01
int loo 0
ip add 1.1.10.1/32
int loo 1
ip add 1.1.10.10/32
int loo 100
ip add 1.1.10.100/32
int loo 254
ip add 10.254.254.254/32
int eth2/1
ip add 10.1.10.2 255.255.255.252
int eth2/2
ip add 10.2.10.2 255.255.255.252
int vlan 11
ip add 192.168.11.1 255.255.255.0
int vlan 12
ip add 192.168.12.1 255.255.255.0
int vlan 21
ip add 192.168.21.1 255.255.255.0
int vlan 22
ip add 192.168.22.1 255.255.255.0
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.1.10.1
log-adjacency-changes detail
int eth 2/1
description Linka k SPINE-01-POD-01
mtu 9216
ip add 10.1.10.2 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 2/2
description Linka k SPINE-02-POD-01
mtu 9216
ip add 10.2.10.2 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback pre OSPF RID
ip add 1.1.10.1/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback pre VTEP PIP
ip add 1.1.10.10/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback for PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
fabric forwarding anycast-gateway-mac eeee.eeee.eeee
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 11
no shut
vrf member tenant-1
ip add 192.168.11.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 12
no shut
vrf member tenant-1
ip add 192.168.12.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int vlan 21
no shut
vrf member tenant-2
ip add 192.168.21.1/24 tag 202122
fabric forwarding mode anycast-gateway
int vlan 22
no shut
vrf member tenant-2
ip add 192.168.22.1/24 tag 202122
fabric forwarding mode anycast-gateway
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
member vni 10011
mcast-group 239.0.0.11
suppress-arp
member vni 10012
mcast-group 239.0.0.12
suppress-arp
member vni 20021
mcast-group 239.0.0.21
suppress-arp
member vni 20022
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
route-map FABRIC_REDIST_SUBNET_TEN-1 permit 10
match tag 101112
route-map FABRIC_REDIST_SUBNET_TEN-2 permit 20
match tag 202122
router bgp 65001
router-id 1.1.10.1
neighbor 1.1.1.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.1.2.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-1
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-1
maximum-paths ibgp 4
vrf tenant-2
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-2
maximum-paths ibgp 4
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
LEAF-20
hostname LEAF-20-POD-01
int loo 0
ip add 1.1.20.1/32
int loo 1
ip add 1.1.20.10/32
int loo 100
ip add 1.1.20.100/32
int loo 254
ip add 10.254.254.254/32
int eth2/1
ip add 10.1.20.2 255.255.255.252
int eth2/2
ip add 10.2.20.2 255.255.255.252
int vlan 11
ip add 192.168.11.1 255.255.255.0
int vlan 12
ip add 192.168.12.1 255.255.255.0
int vlan 21
ip add 192.168.21.1 255.255.255.0
int vlan 22
ip add 192.168.22.1 255.255.255.0
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.1.20.1
log-adjacency-changes detail
int eth 2/1
description Linka k SPINE-01-POD-01
mtu 9216
ip add 10.1.20.2 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 2/2
description Linka k SPINE-02-POD-01
mtu 9216
ip add 10.2.20.2 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback pre OSPF RID
ip add 1.1.20.1/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback pre VTEP PIP
ip add 1.1.20.10/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback pre PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
fabric forwarding anycast-gateway-mac eeee.eeee.eeee
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 11
no shut
vrf member tenant-1
ip add 192.168.11.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 12
no shut
vrf member tenant-1
ip add 192.168.12.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int vlan 21
no shut
vrf member tenant-2
ip add 192.168.21.1/24 tag 202122
fabric forwarding mode anycast-gateway
int vlan 22
no shut
vrf member tenant-2
ip add 192.168.22.1/24 tag 202122
fabric forwarding mode anycast-gateway
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
member vni 10011
mcast-group 239.0.0.11
suppress-arp
member vni 10012
mcast-group 239.0.0.12
suppress-arp
member vni 20021
mcast-group 239.0.0.21
suppress-arp
member vni 20022
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
route-map FABRIC_REDIST_SUBNET_TEN-1 permit 10
match tag 101112
route-map FABRIC_REDIST_SUBNET_TEN-2 permit 20
match tag 202122
router bgp 65001
router-id 1.1.20.1
neighbor 1.1.1.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.1.2.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-1
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-1
maximum-paths ibgp 4
vrf tenant-2
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-2
maximum-paths ibgp 4
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
SITE-POD-02
iBGP - ASN - 65002
VLAN 10 - vrf tenant-1 member vni 10010
VLAN 11 - vrf tenant-1
ip add 192.168.11.0 /24
VLAN 12 - vrf tenant-1
ip add 192.168.12.0 /24
VLAN 20 vrf tenant-2 member vni 20020
VLAN 21 - vrf tenant-2
ip add 192.168.21.0 /24
VLAN 22 - vrf tenant-2
ip add 192.168.22.0 /24
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
DO APPLY TO ALL DEVICES!
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
system jumbomtu 9216
license grace-period
feature privilege
feature telnet
feature vrrp
feature tacacs+
feature ospf
feature bgp
feature ospfv3
feature pim
feature eigrp
feature isis
feature private-vlan
feature interface-vlan
feature vn-segment-vlan-based
feature netflow
feature hsrp
feature glbp
feature dhcp
feature tunnel
feature vpc
feature lldp
feature vtp
feature bfd
feature wccp
feature evc
feature evmed
feature nv overlay
feature nxapi
feature msrp
feature vni
install feature-set fabric
install feature-set fabricpath
feature-set fabric
feature-set fabricpath
feature fabric forwarding
nv overlay evpn
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
—-----------------------------------------------------------------------------------------------
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
SPINE-01-POD-02
hostname SPINE-01-POD-02
int loo 0
ip add 1.2.1.1/32
int loo 1
ip add 1.2.1.10/32
int loo 100
ip add 1.2.1.100/32
int loo 254
ip add 10.254.254.254/32
int eth1/1
ip add 172.18.1.1 255.255.255.252
int eth1/2
ip add 172.18.2.1 255.255.255.252
int eth1/10
Linka k LEAF-10
ip add 10.1.10.5 255.255.255.252
int eth1/20
Linka k LEAF-20
ip add 10.1.20.5 255.255.255.252
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.2.1.1
log-adjacency-changes detail
int eth 1/10
description Link to LEAF-10
mtu 9216
ip add 10.1.10.5 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 1/20
description Link to LEAF-20
mtu 9216
ip add 10.1.20.5 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback for OSPF RID
ip add 1.2.1.1/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback for VTEP PIP
ip add 1.2.1.10/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback for PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
ip pim anycast-rp 10.254.254.254 1.2.1.1
ip pim anycast-rp 10.254.254.254 1.2.2.1
router bgp 65002
router-id 1.2.1.1
neighbor 1.2.10.1
remote-as 65002
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 1.2.20.1
remote-as 65002
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
—--------------------------------------------------------------------------
evpn multisite border-gateway 200
delay-restore time 30
interface e1/1
description Linka k PE-1-WAN-ISP-I
mtu 9216
ip add 172.18.1.1 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
interface e1/2
description Linka k PE-2-WAN-ISP-II
mtu 9216
ip add 172.18.2.1 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
int e1/30
description Linka k SPINE-02
mtu 9216
ip add 172.17.2.1/30 tag 54321
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
evpn multisite fabric-tracking
int loopback 100
description Loopback pre VTEP
ip add 1.2.1.100/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
route-map SITE-REDIST-DIRECT-CONN permit 100
match tag 54321
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
multisite border-gateway interface loopback 100
member vni 10011
multisite ingress-replication
mcast-group 239.0.0.11
suppress-arp
member vni 10012
multisite ingress-replication
mcast-group 239.0.0.12
suppress-arp
member vni 20021
multisite ingress-replication
mcast-group 239.0.0.21
suppress-arp
member vni 20022
multisite ingress-replication
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
router bgp 65002
address-family ipv4 unicast
redistribute direct route-map SITE-REDIST-DIRECT-CONN
maximum-paths 4
neighbor 1.2.2.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.2.200.100 ( PE-3 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 1.2.200.200 ( PE-4 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 172.18.1.2
remote-as 65535
update-source eth1/1
address-family ipv4 unicast
neighbor 172.18.2.2
remote-as 65535
update-source eth1/2
address-family ipv4 unicast
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
SPINE-02-POD-02
hostname SPINE-02-POD-02
int loo 0
ip add 1.2.2.1/32
int loo 1
ip add 1.2.2.10/32
int loo 100
ip add 1.2.2.100/32
int loo 254
ip add 10.254.254.254/32
int eth1/1
ip add 172.18.1.5 255.255.255.252
int eth1/2
ip add 172.18.2.5 255.255.255.252
int eth1/10
Linka k LEAF-10
ip add 10.2.10.5 255.255.255.252
int eth1/20
Linka k LEAF-20
ip add 10.2.20.5 255.255.255.252
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.2.2.1
log-adjacency-changes detail
int eth 1/10
description Link to LEAF-10
mtu 9216
ip add 10.2.10.5 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 1/20
description Link to LEAF-20
mtu 9216
ip add 10.2.20.5 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback for OSPF RID
ip add 1.2.2.1/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback for VTEP PIP
ip add 1.2.2.10/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback for PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
ip pim anycast-rp 10.254.254.254 1.2.1.1
ip pim anycast-rp 10.254.254.254 1.2.2.1
router bgp 65002
router-id 1.2.2.1
neighbor 1.2.10.1
remote-as 65002
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 1.2.20.1
remote-as 65002
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
—---------------------------------------------------------------------------------
evpn multisite border-gateway 200
delay-restore time 30
interface e1/1
description Linka k PE-1-WAN-ISP-I
mtu 9216
ip add 172.18.1.5 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
interface e1/2
description Linka k PE-2-WAN-ISP-II
mtu 9216
ip add 172.18.2.5 255.255.255.252 tag 54321
no shutdown
evpn multisite dci-tracking
int e1/30
description Linka k SPINE-02
mtu 9216
ip add 172.17.2.2/30 tag 54321
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
evpn multisite fabric-tracking
int loopback 100
description Loopback pre VTEP
ip add 1.2.2.100/32 tag 54321
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
route-map SITE-REDIST-DIRECT-CONN permit 100
match tag 54321
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
multisite border-gateway interface loopback 100
member vni 10011
multisite ingress-replication
mcast-group 239.0.0.11
suppress-arp
member vni 10012
multisite ingress-replication
mcast-group 239.0.0.12
suppress-arp
member vni 20021
multisite ingress-replication
mcast-group 239.0.0.21
suppress-arp
member vni 20022
multisite ingress-replication
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
router bgp 65002
address-family ipv4 unicast
redistribute direct route-map SITE-REDIST-DIRECT-CONN
maximum-paths 4
neighbor 1.2.1.1
remote-as 65001
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.2.200.100 ( PE-3 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 1.2.200.200 ( PE-4 )
remote-as 65535
update-source loopback 0
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 172.18.1.6
remote-as 65535
update-source eth1/1
address-family ipv4 unicast
neighbor 172.18.2.6
remote-as 65535
update-source eth1/2
address-family ipv4 unicast
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
LEAF-10-POD-02
hostname LEAF-10-POD-02
int loo 0
ip add 1.2.10.1/32
int loo 1
ip add 1.2.10.10/32
int loo 100
ip add 1.2.10.100/32
int loo 254
ip add 10.254.254.254/32
int eth2/1
ip add 10.1.10.6 255.255.255.252
int eth2/2
ip add 10.2.10.6 255.255.255.252
int vlan 11
ip add 192.168.11.254 255.255.255.0
int vlan 12
ip add 192.168.12.254 255.255.255.0
int vlan 21
ip add 192.168.21.254 255.255.255.0
int vlan 22
ip add 192.168.22.254 255.255.255.0
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.2.10.1
log-adjacency-changes detail
int eth 2/1
description Link to SPINE-1
mtu 9216
ip add 10.1.10.6 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 2/2
description Link to SPINE-2
mtu 9216
ip add 10.2.10.6 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback for OSPF RID
ip add 1.2.10.1/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback for VTEP PIP
ip add 1.2.10.10/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback for PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
fabric forwarding anycast-gateway-mac eeee.eeee.eeee
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 11
no shut
vrf member tenant-1
ip add 192.168.11.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 12
no shut
vrf member tenant-1
ip add 192.168.12.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int vlan 21
no shut
vrf member tenant-2
ip add 192.168.21.1/24 tag 202122
fabric forwarding mode anycast-gateway
int vlan 22
no shut
vrf member tenant-2
ip add 192.168.22.1/24 tag 202122
fabric forwarding mode anycast-gateway
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
member vni 10011
mcast-group 239.0.0.11
suppress-arp
member vni 10012
mcast-group 239.0.0.12
suppress-arp
member vni 20021
mcast-group 239.0.0.21
suppress-arp
member vni 20022
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
route-map FABRIC_REDIST_SUBNET_TEN-1 permit 10
match tag 101112
route-map FABRIC_REDIST_SUBNET_TEN-2 permit 20
match tag 202122
router bgp 65002
router-id 1.2.10.1
neighbor 1.2.1.1
remote-as 65002
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.2.2.1
remote-as 65002
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-1
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-1
maximum-paths ibgp 4
vrf tenant-2
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-2
maximum-paths ibgp 4
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
LEAF-20-POD-02
hostname LEAF-20-POD-02
int loo 0
ip add 1.2.20.1/32
int loo 1
ip add 1.2.20.10/32
int loo 100
ip add 1.2.20.100/32
int loo 254
ip add 10.254.254.254/32
int eth2/1
ip add 10.1.20.6 255.255.255.252
int eth2/2
ip add 10.2.20.6 255.255.255.252
int vlan 11
ip add 192.168.11.254 255.255.255.0
int vlan 12
ip add 192.168.12.254 255.255.255.0
int vlan 21
ip add 192.168.21.254 255.255.255.0
int vlan 22
ip add 192.168.22.254 255.255.255.0
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
router ospf 110
router-id 1.2.20.1
log-adjacency-changes detail
int eth 2/1
description Link to SPINE-1
mtu 9216
ip add 10.1.20.6 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int eth 2/2
description Link to SPINE-2
mtu 9216
ip add 10.2.20.6 255.255.255.252
ip ospf network point-to-point
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
no shutdown
int loopback 0
description Loopback for OSPF RID
ip add 1.2.20.1/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 1
description Loopback for VTEP PIP
ip add 1.2.20.10/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
int loopback 254
description Loopback for PIM
ip add 10.254.254.254/32
ip router ospf 110 area 0.0.0.0
ip pim sparse-mode
ip pim rp-address 10.254.254.254 group-list 239.239.239.0 /24
vlan 10
name tenant-1
vn-segment 10010
vlan 20
name tenant-2
vn-segment 20020
vlan 11
vn-segment 10011
vlan 12
vn-segment 10012
vlan 21
vn-segment 20021
vlan 22
vn-segment 20022
vrf context tenant-1
vni 10010
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
vrf context tenant-2
vni 20020
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
fabric forwarding anycast-gateway-mac eeee.eeee.eeee
int vlan 10
description tenant-1-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-1
ip forward
int vlan 11
no shut
vrf member tenant-1
ip add 192.168.11.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 12
no shut
vrf member tenant-1
ip add 192.168.12.1/24 tag 101112
fabric forwarding mode anycast-gateway
int vlan 20
description tenant-2-VRF-VLAN
no shutdown
mtu 9216
vrf member tenant-2
ip forward
int vlan 21
no shut
vrf member tenant-2
ip add 192.168.21.1/24 tag 202122
fabric forwarding mode anycast-gateway
int vlan 22
no shut
vrf member tenant-2
ip add 192.168.22.1/24 tag 202122
fabric forwarding mode anycast-gateway
int nve 1
no shut
host-reachability protocol bgp
source-interface loopback 1
member vni 10011
mcast-group 239.0.0.11
suppress-arp
member vni 10012
mcast-group 239.0.0.12
suppress-arp
member vni 20021
mcast-group 239.0.0.21
suppress-arp
member vni 20022
mcast-group 239.0.0.22
suppress-arp
member vni 10010 associate-vrf
member vni 20020 associate-vrf
route-map FABRIC_REDIST_SUBNET_TEN-1 permit 10
match tag 101112
route-map FABRIC_REDIST_SUBNET_TEN-2 permit 20
match tag 202122
router bgp 65002
router-id 1.2.20.1
neighbor 1.2.1.1
remote-as 65002
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
neighbor 1.2.2.1
remote-as 65002
update-source loopback 0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-1
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-1
maximum-paths ibgp 4
vrf tenant-2
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map FABRIC_REDIST_SUBNET_TEN-2
maximum-paths ibgp 4
evpn
vni 10011 l2
rd auto
route-target import auto
route-target export auto
vni 10012 l2
rd auto
route-target import auto
route-target export auto
vni 20021 l2
rd auto
route-target import auto
route-target export auto
vni 20022 l2
rd auto
route-target import auto
route-target export auto
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTE-SERVER-01
hostname RS-1-P/C-EDGE-WAN
system jumbomtu 9216
feature ospf
feature bgp
feature mpls
feature lldp
int gig1/0
description Linka k SPINE-01-BGW-POD-01
mtu 9216
ip add 172.16.1.2 255.255.255.252
no shutdown
int gig2/0
description Linka k SPINE-02-BGW-POD-01
mtu 9216
ip add 172.16.1.6 255.255.255.252
no shutdown
int gig3/0
description Linka k R-WAN-TEN-1
mtu 9216
ip add 157.127.81.2 255.255.255.252
no shutdown
int serial6/1
ip add 172.16.61.1 255.255.255.252
ip router isis
int serial6/2
ip add 172.16.62.1 255.255.255.252
ip router isis
int serial6/3
ip add 172.16.63.1 255.255.255.252
ip router isis
int serial6/4
ip add 172.16.64.1 255.255.255.252
ip router isis
int loopback 0
ip add 71.100.100.1/32
route-map NEXT-HOP-UNCHANGED permit 100
set ip next-hop unchanged
router isis
net 49.0001.0000.0000.000a.00
router bgp 65100
address-family ipv4 unicast
network 71.100.100.1/32
address-family l2vpn evpn
retain route-target all
neighbor 1.1.1.1
remote-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.1.2.1
remtoe-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.1.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.2.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 172.16.1.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.1.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.18.1.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.1.5
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.5
remote-as 65002
address-family ipv4 unicast
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTE-SERVER-02
hostname RS-2-P/C-EDGE-WAN
system jumbomtu 9216
feature ospf
feature bgp
feature mpls
feature lldp
int gig1/0
description Linka k SPINE-01-BGW-POD-01
mtu 9216
ip add 172.16.2.2 255.255.255.252
no shutdown
int gig2/0
description Linka k SPINE-02-BGW-POD-01
mtu 9216
ip add 172.16.2.6 255.255.255.252
no shutdown
int serial6/1
ip add 172.16.61.5 255.255.252
ip router isis
int serial6/2
ip add 172.16.62.2 255.255.255.252
ip router isis
int serial6/3
ip add 172.16.63.5 255.255.255.252
ip router isis
int serial6/6
ip add 172.16.66.1 255.255.255.252
ip router isis
int loopback 0
ip add 71.100.100.2/32
route-map NEXT-HOP-UNCHANGED permit 100
set ip next-hop unchanged
router isis
net 49.0001.0000.0000.000b.00
router bgp 65100
address-family ipv4 unicast
network 71.100.100.2/32
address-family l2vpn evpn
retain route-target all
neighbor 1.1.1.1
remote-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.1.2.1
remtoe-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.1.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.2.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 172.16.1.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.1.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.18.1.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.1.5
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.5
remote-as 65002
address-family ipv4 unicast
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTE-SERVER-03
hostname RS-3-P/C-EDGE-WAN
system jumbomtu 9216
feature ospf
feature bgp
feature mpls
feature lldp
int gig1/0
description Linka k SPINE-01-BGW-POD-02
mtu 9216
ip add 172.18.1.2 255.255.255.252
no shutdown
int gig2/0
description Linka k SPINE-02-BGW-POD-02
mtu 9216
ip add 172.18.1.6 255.255.255.252
no shutdown
int serial6/1
ip add 172.16.61.6 255.255.255.252
ip router isis
int serial6/2
ip add 172.16.62.5 255.255.255.252
ip router isis
int serial6/3
ip add 172.16.63.2 255.255.255.252
ip router isis
int serial6/7
ip add 172.16.67.1 255.255.255.252
ip router isis
int loopback 0
ip add 71.100.100.3/32
route-map NEXT-HOP-UNCHANGED permit 100
set ip next-hop unchanged
router isis
net 49.0001.0000.0000.000c.00
router bgp 65100
address-family ipv4 unicast
network 71.100.100.3/32
address-family l2vpn evpn
retain route-target all
neighbor 1.1.1.1
remote-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.1.2.1
remtoe-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.1.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.2.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 172.16.1.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.1.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.18.1.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.1.5
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.5
remote-as 65002
address-family ipv4 unicast
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTE-SERVER-04
hostname RS-4-P/C-EDGE-WAN
feature ospf
feature bgp
feature mpls
feature lldp
system jumbomtu 9216
int gig1/0
description Linka k SPINE-01-BGW-POD-02
mtu 9216
ip add 172.18.2.2 255.255.255.252
no shutdown
int gig2/0
description Linka k SPINE-02-BGW-POD-02
mtu 9216
ip add 172.18.2.6 255.255.255.252
no shutdown
int gig3/0
description Linka k R-WAN-TEN-2
mtu 9216
ip add 143.28.160.2 255.255.255.252
no shutdown
int serial6/1
ip add 172.16.61.2 255.255.255.252
router isis
int serial6/2
ip add 172.16.62.6 255.255.255.252
router isis
int serial6/3
ip add 172.16.63.6 255.255.255.252
router isis
int serial6/5
ip add 172.16.65.1 255.255.255.252
router isis
int loopback 0
ip add 71.100.100.4/32
route-map NEXT-HOP-UNCHANGED permit 100
set ip next-hop unchanged
router isis
net 49.0001.0000.0000.000d.00
router bgp 65100
address-family ipv4 unicast
network 71.100.100.4/32
address-family l2vpn evpn
retain route-target all
neighbor 1.1.1.1
remote-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.1.2.1
remtoe-as 65001
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.1.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 1.2.2.1
remtoe-as 65002
update-source loopback0
ebgp-multihop 5
peer-type fabric-external
address-family l2vpn evpn
send-community
send-community extended
route-map NEXT-HOP-UNCHANGED out
rewrite-evpn-rt-asn
neighbor 172.16.1.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.1.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.1
remote-as 65001
address-family ipv4 unicast
neighbor 172.16.2.5
remote-as 65001
address-family ipv4 unicast
neighbor 172.18.1.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.1.5
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.1
remote-as 65002
address-family ipv4 unicast
neighbor 172.18.2.5
remote-as 65002
address-family ipv4 unicast
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTER-WAN-CEN-05
hostname R-5-WAN-CEN
feature ospf
feature bgp
feature mpls
feature lldp
system jumbomtu 9216
int serial6/4
ip add 172.16.64.2 255.255.255.252
ip router isis
int serial6/5
ip add 172.16.65.2 255.255.255.252
ip router isis
int serial6/6
ip add 172.16.66.2 255.255.255.252
ip router isis
int serial6/7
ip add 172.16.67.2 255.255.255.252
ip router isis
router isis
net 49.0001.0000.0000.000e.00
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTER-TEN-1
hostname R-WAN-TEN-1
int gig3/0
ip add 157.127.81.1 255.255.255.252
mtu 9216
no shutdown
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ROUTER-TEN-2
hostname R-WAN-TEN-2
int gig3/0
ip add 143.28.160.1 255.255.255.252
mtu 9216
no shutdown
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ THE END
/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide