cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
739
Views
5
Helpful
4
Replies
Highlighted
Cisco Employee

Error: External error in the NED implementation for device mydevice: not implemented

Hello Experts,

 

Ubuntu 18.04.1 LTS

NSO 4.4.1

 

admin@ncs# show packages package package-version
           PACKAGE  
NAME       VERSION  
--------------------
cisco-ios  3.0.0.1  

admin@ncs#


admin@ncs# devices device mydevice live-status commands version          
Error: External error in the NED implementation for device mydevice: not implemented
admin@ncs#

 

Kindly help me how to fix this issue. Or if there is anything missing.

 

Thank you.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Error: External error in the NED implementation for device mydevice: not implemented

Is that the NED version prepackaged with NSO?

As far as I'm aware, it is only intended to support the examples in the examples directory of your installation dir, and not much more than that.

I'd suggest you install the latest NED (should be 6.3.1) and retry.

 

Yftach

View solution in original post

4 REPLIES 4
Highlighted
Cisco Employee

Re: Error: External error in the NED implementation for device mydevice: not implemented

What kind of device are you trying this against?

 

-Dan

Highlighted
Cisco Employee

Re: Error: External error in the NED implementation for device mydevice: not implemented

C7200

Highlighted
Cisco Employee

Re: Error: External error in the NED implementation for device mydevice: not implemented

Is that the NED version prepackaged with NSO?

As far as I'm aware, it is only intended to support the examples in the examples directory of your installation dir, and not much more than that.

I'd suggest you install the latest NED (should be 6.3.1) and retry.

 

Yftach

View solution in original post

Highlighted
Cisco Employee

Re: Error: External error in the NED implementation for device mydevice: not implemented

Thank you! Yes, you are correct, I did install the latest one and it worked.

Best Regards