cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
547
Views
1
Helpful
3
Replies

NSO 4.x support Java 8 ?

previousqna
Level 5
Level 5

My customer has flagged Java 7 as an issue (vulnerability and end-of-life) and want to upgrade Java to version 8.

The latest documentation on pre-requisites merely indicated the minimum version required:

Before installing NSO, ensure that a Java JDK-6.0 or higher is installed. When JDK is properly installed the command java -version should indicate a java version of “1.6” or higher.  

Does that constitute Cisco Tail-f BU approval for Java 8 support with NSO 4.1.1 ? Additionally, what is potential impact to the Device NEDs and Service packages we’ve built for the customer. Please advise.

We’re using ALU, Cisco IOSXR and HA NEDs for this engagement.

1 Accepted Solution

Accepted Solutions

The old thread still holds.

Anything higher that 1.6 will work.

All NSO related and released java code is compiled with 1.6 binary compatibility so the will work running higher versions JVMs out of the box.

View solution in original post

3 Replies 3

previousqna
Level 5
Level 5

Java 6 or higher” was the last I’ve seen, there was a thread about this last year, find it here.

The old thread still holds.

Anything higher that 1.6 will work.

All NSO related and released java code is compiled with 1.6 binary compatibility so the will work running higher versions JVMs out of the box.

We were using 7 for a long time. This week upgraded to 8 because of tls and see no problems.