cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Packages reload "Internal error recompile needed"

RichardD2
Beginner
Beginner

I built two new package of type template. Edited the yang file and make clean all completed with no issues for both packages

Issuing the packages reload command I get:

>>> System upgrade is starting.
>>> Sessions in configure mode must exit to operational mode.
>>> No configuration changes can be performed until upgrade has completed.
>>> System upgrade has been cancelled.
Error: Internal error: {failed,
                    {recompile_needed,
                        "./state/packages-in-use/1/my-package/load-dir/my-package.fxs"}}

I deleted the packages/mypackage directory and then NSO repeats the above error, with the same error for the only remaining package.

Any thoughts on what could cause this? Oh and its version 5.3.0.1 btw. Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

It does work, and I use that all the time. The problem is that NSO only accepts FXS files compiled with the right version of the compiler (actually, it is compatible between minor releases) so you have to make sure that if you run say 4.7 you have to build your fxs files for 4.7. It is easy to source the wrong ncsrc before building and then you see a problem like what you see – usually it is enough to source the right one and then make clean and build again.

View solution in original post

4 REPLIES 4

vleijon
Cisco Employee
Cisco Employee
Do you have more than one version of NSO installed? It might be that the fxs is compiled with another NSO version.

Hi Vleijon, 

Yes I do have a few versions installed. I understood this not to be an issue if I kept them in separate directories.

The idea was to be able to spin up netsim's for different routers and test the services I have written against the different versions of NSO. 

Thanks

It does work, and I use that all the time. The problem is that NSO only accepts FXS files compiled with the right version of the compiler (actually, it is compatible between minor releases) so you have to make sure that if you run say 4.7 you have to build your fxs files for 4.7. It is easy to source the wrong ncsrc before building and then you see a problem like what you see – usually it is enough to source the right one and then make clean and build again.