cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

744
Views
5
Helpful
4
Replies
erdemk
Beginner

sync-from doesn't work from upper-nso with , nso-5.3

Dear NSO Community,

 

I need help on the following, if possible..

I have setup an lsa architecture. I cannot do sync-from from upper-nso to lower-nso. 

 

 

Steps that i executed :

 

- My setup is based on examples.ncs\getting-started\developing-with-ncs\22-layered-service-architecture. I have instantiated 2 NSOs on the same VM as instructed in example-22.

 

- erdem@ncs(config)# do show ncs-state ver    --> ncs-state version 5.3

 

- i have created a very simple service. yang file like this, tested and working from lower-nso : 

module lsa-rfs {

namespace "http://example.com/lsa-rfs";
prefix lsa-rfs;

import ietf-inet-types {
prefix inet;
}
import tailf-common {
prefix tailf;
}
import tailf-ncs {
prefix ncs;
}

description
"Bla bla...";

revision 2016-01-01 {
description
"Initial revision.";
}

container lsa-rfs {
presence "bla bla..";

uses ncs:service-data;
ncs:servicepoint lsa-rfs-servicepoint;

leaf device {
type string;
}
leaf hostname { type string; }
leaf ntp-server { type string; }
leaf logging-server { type string; }
}
}

 

- i have made necessary changes on ncs.conf of upper-nso and lower-nso

  <netconf-north-bound>
    <enabled>true</enabled>
    <transport>
      <ssh>
        <enabled>true</enabled>
        <ip>0.0.0.0</ip>
        <port>2022</port>
      </ssh>
    </transport>
  </netconf-north-bound> 

  <large-scale>
    <lsa>
      <enabled>true</enabled>
    </lsa>
  </large-scale>

 

- i have created the NED based on lower-nso service on upper-nso

ncs-make-package --no-netsim --no-java --lsa-netconf-ned ../../ncs-run/packages/lsa-rfs/src/yang --build rfs-ned

 

- i have created the lower-nso on upper-nso:

erdem@ncs(config)# show full-configuration devices device lowernso2
devices device lowernso2
address 127.0.0.1
port 2022
ssh host-key ssh-ed25519
key-data AAAAC3NzaC1lZDI1NTE5AAAAIGqH1yEq5utvymIinG8ln2O29c/mzCIXawwcrfsoVJfG
!
authgroup admin
device-type netconf ned-id lsa-netconf
state admin-state unlocked
!

 

- when i do sync-from, it is unsuccessful, and i see the following message :

erdem@ncs(config-device-lowernso2)# sync-from
result false
info Device lowernso2 does not advertise any known YANG modules
erdem@ncs(config-device-lowernso2)# *** ALARM connection-failure: Device lowernso2 does not advertise any known YANG modules

 

- when i add additional ned with command "erdem@ncs(config-device-lowernso2)# device-type lsa-additional-ned-id tailf-nso-nc-5.3", sync-from is successful, i can see capabilities and netsim devices from upper-nso, but i cannot configure the service on lower-nso from upper-nso. i think this is not relevant to lower-nso service which i created anyways.

 

- i have tried different versions also, with no success.

 

- i have tried same scenario, with differences on ncs-make-package command in nso-4.7 with successful result. i am suspecting a bug on nso-5.3, but example-22 is working, so it shouldn't be a bug.

 

Any idea or suggestion is appreciated.

 

Thanks in advance and regards ..

4 REPLIES 4
rogaglia
Cisco Employee

Without getting in all the details, be careful that: the "large-scale" config should only be on the CFS node. That is clear on the lsa guide.

Could you please check?

 

Thanks for replying.
I checked it and it is set only on cfs node.

Something else to check:

1- Did you compiled your packages and the RFS-NED? It was not in your steps. If not, do "make" and "package reload".

2- Can you check that both the CFS and the RFC have the simple service capabilities?

3- Verify the RFS NED

 

Some useful show commands for troubleshooting from the example:

 

admin@upper-nso> show packages package rfs-ned
packages package rfs-ned
package-version 1.0
description "Generated netconf package"
ncs-min-version [ 5.3 ]
directory ./state/packages-in-use/1/rfs-ned
component rfs-ned
ned netconf ned-id lsa-netconf
ned device vendor Acme
oper-status up
[ok][2020-08-05 23:45:00]
admin@upper-nso>

 

admin@upper-nso> show ncs-state loaded-data-models mount tailf-ncs-ned:lsa-netconf data-model
EXPORTED EXPORTED
NAME REVISION NAMESPACE PREFIX TO ALL TO
--------------------------------------------------------------------------------------------
device-action - http://example.com/device-actions da X -
drfs - http://com/tail-f/drfs drfs X -
rfs-vlan 2017-01-03 http://com/example/rfsvlan rfs-vlan X -

[ok][2020-08-05 23:46:04]
admin@upper-nso>

admin@upper-nso> request devices device lower-nso-1 check-yang-modules verbose
module {
name rfs-vlan
status supported
device-revision 2017-01-03
ncs-revision 2017-01-03
}

Roque hi, thanks for followup..

I did all the checks as you pointed.. everything seems to be in order.

I instantiated a new ncs as upper-nso. It worked.

I will not investigate further.

Many thanks.