cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
562
Views
0
Helpful
0
Replies

Configuration FAC ( Force Authorization Code) in CME

Hello, 

I try configure FAC in CME but not work very well.
When i call number, the lpcor not request PIN.
My configuration:


aaa new-model
!
!
aaa authentication login default local
aaa authentication login h323 local
aaa authorization exec h323 local 
aaa authorization network h323 local 
!
aaa session-id common
!
!        
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool Voip
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1 
 option 150 ip 10.10.10.1 
!
!
multilink bundle-name authenticated
!
!
cts logging verbose
voice-card 0
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 sip
  registrar server expires max 1200 min 60
!
voice class codec 1
 codec preference 1 g711alaw
!
!
!
!
voice register global
 mode  cme
 source-address 10.10.10.1 port 5060
 max-dn 900
 max-pool 365
 load 6941 SIP69xx.9-4-1-3
 load 3905 CP3905.9-4-1SR1-3
 authenticate register
 authenticate realm XXXXX.br
 timezone 17
 file text
 create profile sync 0004621361788905
!
voice register dn  1
 number 3001
 name Fabricio
 label Fabricio
!
voice register dn  2
 number 3002
 name Teste
 label Teste
!
voice register dn  3
 number 3003
 name Teste2
 label Teste2
!
voice register template  2
!
voice register pool  1
 lpcor type local
 lpcor incoming DDI
 lpcor outgoing DDI
 id mac C8F9.F9D6.D982
 type 3905
 number 1 dn 1
 dtmf-relay sip-notify
 username 3001 password 3001
 codec g711alaw
!
voice register pool  2
 lpcor type local
 lpcor incoming Local
 lpcor outgoing Local
 id mac C8F9.F9D6.DAFD
 type 3905
 number 1 dn 2
 cor outgoing INPE-PerfilDDD default
 dtmf-relay sip-notify
 username 3002 password 3002
 codec g711alaw
!
voice register pool  3
 lpcor type remote
 busy-trigger-per-button 1
 id mac 5478.1A6A.FA03
 type 6941
 number 1 dn 3
 dtmf-relay sip-notify
 username 3003 password 3003
 codec g711alaw
!
!
voice lpcor enable
voice lpcor custom
 group 1 Interno
 group 2 Local
 group 3 Cel_Local
 group 4 DDD
 group 5 Cel_DDD
 group 6 DDI
!
voice lpcor policy Interno
 service fac
 accept Interno fac
!         
voice lpcor policy Local
 service fac
 accept Interno fac
 accept Local fac
!
voice lpcor policy Cel_Local
 service fac
 accept Interno
 accept Local
 accept Cel_Local fac
!
voice lpcor policy DDD
 service fac
 accept Interno
 accept Local
 accept Cel_Local fac
 accept DDD fac
!
voice lpcor policy Cel_DDD
 service fac
 accept Interno
 accept Local
 accept Cel_Local fac
 accept DDD fac
 accept Cel_DDD fac
!
voice lpcor policy DDI
 service fac
 accept Interno
 accept Local
 accept Cel_Local fac
 accept DDD fac
 accept Cel_DDD fac
 accept DDI fac
!
voice lpcor ip-phone subnet outgoing

voice lpcor ip-phone subnet incoming
!
!
application
 package auth
  param passwd-prompt flash:en_bacd_welcome.au
  param term-digit #
  param passwd 12345
  param user-prompt flash:en_bacd_enter_dest.au
  param abort-digit *
  param max-digits 32
 !
!
!
username 123 password 7 075D731E1C5B
!
!
gw-accounting aaa
!
!
interface GigabitEthernet0/0.134
 encapsulation dot1Q 134
 ip address 10.10.10.1 255.255.255.0
!
ip forward-protocol nd
!
!
tftp-server flash:CP3905.9-4-1SR1-3.loads
tftp-server flash:APP3905.9-4-1SR1-3.zz
tftp-server flash:SIP69xx.9-4-1-3.loads
tftp-server flash:SIP69xx.9-4-1-3.zz.sgn
tftp-server flash:DSP69xx.12-4-122-02-121029.zz.sgn
tftp-server flash:BOOT69xx.0-0-0-14.zz.sgn
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
dial-peer voice 1 voip
 description **Interno**
 destination-pattern 70..
 lpcor outgoing Interno
 rtp payload-type cisco-codec-fax-ind 105
 session protocol sipv2
 session target ipv4:192.168.0.12
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 voice-class sip g729 annexb-all
 dtmf-relay rtp-nte
!
dial-peer voice 2 voip
 description **INPE-Ramais Internos**
 destination-pattern 0.0
 lpcor outgoing Interno
 rtp payload-type cisco-codec-fax-ind 105
 session protocol sipv2
 dtmf-relay rtp-nte
!
dial-peer voice 7 voip
 description **Lig. DDD Prefixo 2_3_4_5**
 destination-pattern ^00[1-9].[2-5].......
 lpcor outgoing DDD
 rtp payload-type cisco-codec-fax-ind 105
 session protocol sipv2
 session target ipv4:192.168.0.12
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 voice-class sip g729 annexb-all
 dtmf-relay rtp-nte
!
dial-peer voice 6 voip
 description Celular Local 9 digitos
 destination-pattern ^09........$
 lpcor outgoing Cel_Local
 rtp payload-type cisco-codec-fax-ind 105
 rtp payload-type nte-tone 96
 session protocol sipv2
 session target ipv4:192.168.0.12
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 voice-class sip g729 annexb-all
 dtmf-relay rtp-nte
!
dial-peer voice 5 voip
 description PABX - Celular Local
 destination-pattern ^0[6-9].......T
 lpcor outgoing Cel_Local
 rtp payload-type cisco-codec-fax-ind 105
 rtp payload-type nte-tone 96
 session protocol sipv2
 session target ipv4:192.168.0.12
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 voice-class sip g729 annexb-all
 dtmf-relay rtp-nte
!
dial-peer voice 4 voip
 description PABX - Fixo Local
 destination-pattern ^0[2-5].......$
 lpcor outgoing Local
 rtp payload-type cisco-codec-fax-ind 105
 rtp payload-type nte-tone 96
 session protocol sipv2
 session target ipv4:192.168.0.12
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 voice-class sip g729 annexb-all
 dtmf-relay rtp-nte
!
!
presence
 presence call-list
 max-subscription 900
!
sip-ua 
 presence enable
!
!
!
!
telephony-service
 max-ephones 365
 max-dn 900
 max-conferences 8 gain -6
 web admin system name admin password p@T0#F0o
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
scheduler allocate 20000 1000
!
end

0 Replies 0