05-15-2002 11:46 PM - edited 03-12-2019 06:50 PM
I have some problem at my voice network. I connect two 1750 with FXO and FXS at 64K Lease line. But there is some voice delay, echo and can¡¦t dial to branch side usually. I had done some QoS on it. Anyone can give me some advice? I attach the router config for reference.
Head Office router: (4 voice FXO interfaces)
================================
Building configuration...
Current configuration:
!
version 12.1
!
!
class-map voice
match access-group 100
!
!
policy-map llq
class voice
priority 45
!
memory-size iomem 25
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
!
voice-port 1/0
input gain 6
output attenuation 12
echo-cancel coverage 32
connection plar 8601
description connected to PABX no.082
!
voice-port 1/1
input gain 6
output attenuation 12
echo-cancel coverage 32
connection plar 8602
description connected to PABX no.084
!
voice-port 2/0
input gain 6
output attenuation 12
echo-cancel coverage 32
connection plar 8603
description connected to PABX no.081
!
voice-port 2/1
input gain 6
output attenuation 12
echo-cancel coverage 32
connection plar 8604
description connected to PABX no.035
!
!
dial-peer voice 85201 pots
destination-pattern 85201
port 1/0
!
dial-peer voice 85202 pots
destination-pattern 85202
port 1/1
!
dial-peer voice 85203 pots
destination-pattern 85203
port 2/0
!
dial-peer voice 85204 pots
destination-pattern 85204
port 2/1
!
dial-peer voice 8601 voip
destination-pattern 8601
ip precedence 5
session target ipv4:210.254.255.2
!
dial-peer voice 8602 voip
destination-pattern 8602
ip precedence 5
session target ipv4:210.254.255.2
!
dial-peer voice 8603 voip
destination-pattern 8603
ip precedence 5
session target ipv4:210.254.255.2
!
dial-peer voice 8604 voip
destination-pattern 8604
ip precedence 5
session target ipv4:210.254.255.2
!
!
interface Tunnel0
bandwidth 64
ip address 192.168.254.1 255.255.255.252
tunnel source 210.255.10.2
tunnel destination 210.254.255.2
!
interface Serial0
mtu 300
bandwidth 64
no ip address
encapsulation frame-relay
no ip mroute-cache
service-policy output llq
frame-relay lmi-type ansi
frame-relay ip tcp header-compression
frame-relay ip rtp header-compression
!
interface Serial0.133 point-to-point
bandwidth 64
ip address 210.255.10.2 255.255.255.252
no ip mroute-cache
service-policy output llq
frame-relay interface-dlci 133
frame-relay ip tcp header-compression
frame-relay ip rtp header-compression
!
interface FastEthernet0
ip address 192.168.1.253 255.255.255.0
speed 10
half-duplex
!
ip classless
ip route 210.254.0.0 255.255.255.0 Tunnel0
ip route 210.254.255.2 255.255.255.255 Serial0.133
ip route 192.168.19.0 255.255.255.0 Serial0.133
ip route 211.159.29.17 255.255.255.255 Serial0.133
no ip http server
!
!
no scheduler allocate
end
Branch Office router (4 voice FXS interfaces):
=================================
Building configuration...
Current configuration:
!
version 12.1
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
!
!
!
!
voice-port 1/0
input gain 4
output attenuation 6
echo-cancel coverage 32
description connected to ext.007
!
voice-port 1/1
input gain 4
output attenuation 6
echo-cancel coverage 32
description connected to ext.008
!
voice-port 2/0
input gain 4
output attenuation 6
echo-cancel coverage 32
description connected to ext.005
!
voice-port 2/1
input gain 4
output attenuation 6
echo-cancel coverage 32
description connected to ext.006
!
!
dial-peer voice 8601 pots
destination-pattern 8601
port 1/0
!
dial-peer voice 8602 pots
destination-pattern 8602
port 1/1
!
dial-peer voice 8603 pots
destination-pattern 8603
port 2/0
!
dial-peer voice 8604 pots
destination-pattern 8604
port 2/1
!
dial-peer voice 85201 voip
destination-pattern 85201
ip precedence 5
session target ipv4:210.255.10.2
!
dial-peer voice 85202 voip
destination-pattern 85202
ip precedence 5
session target ipv4:210.255.10.2
!
dial-peer voice 85203 voip
destination-pattern 85203
ip precedence 5
session target ipv4:210.255.10.2
!
dial-peer voice 85204 voip
destination-pattern 85204
ip precedence 5
session target ipv4:210.255.10.2
!
!
interface Tunnel0
bandwidth 64
ip address 192.168.254.2 255.255.255.252
tunnel source 210.254.255.2
tunnel destination 210.255.10.2
!
interface Serial0
mtu 300
ip address 210.254.255.2 255.255.255.252
ip tcp header-compression
no ip mroute-cache
traffic-shape rate 64000 1000 0 1000
ip rtp header-compression
ip rtp priority 16384 16383 45
!
interface FastEthernet0
ip address 210.254.0.1 255.255.255.0
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.254.255.1
ip route 210.254.0.0 255.255.255.0 Null0
ip route 192.168.1.0 255.255.255.0 Tunnel0
no ip http server
!
!
end
05-20-2002 10:05 AM
Looks l;ike frame relay traffic shaping is not configured correctly.
Please see: http://www.cisco.com/warp/public/788/voip/voip_fr_frts_frf12.htm
http://www.cisco.com/warp/public/788/voip/fr_traffic.html
http://www.cisco.com/warp/public/125/traffic_shaping_6151.html
http://www.cisco.com/warp/public/788/voice-qos/voip-ov-fr-qos.html
The main thing is getting fragmentation to work to avoid serialization delays.
05-21-2002 06:17 PM
FRF 12 support 2600 or 3600 series. How about this case which is 1750?
06-05-2002 12:34 AM
Try taking off header compression and also check what codec you are using. if you are using G711 on a 64k line then that would add some delay as it uses around 88k, try using G729a.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide