cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
411
Views
0
Helpful
3
Replies

LLQ Problems on Multilink

lwascher
Level 1
Level 1

I have a 7206 router that I am implementing QoS on. I create access lists, class-maps, and policy-maps to separate voice traffic and signaling. I have attached the policy map to a serial interface, and it is working great for VoIP. When I attach the policy map to a multilink interface, the router starts to bog down and eventually locks up. I have read every QoS, LLQ, Diffserv, and PQ documentation you have, and follow directions exactly. Any idea why this is not working? This is how I have it set up:

ip access-list extended ugw-traffic

permit udp any any eq 2427

permit udp any any eq 2727

permit udp any any range 3000 3590

permit udp any any range 16400 16990

!

class-map match-any voice-class

match access-group name ugw-traffic

!

!

policy-map LLQ

class voice-class

priority 400

class class-default

fair-queue

!

interface Multilink1

ip address xx.xx.xx.xx 255.255.255.252

ip ospf network point-to-point

ppp multilink

ppp multilink group 1

Service-policy output LLQ

!

interface Serial1/0/16:0

ip address xx.xx.xx.xx 255.255.255.252

service-policy output LLQ

ip ospf network point-to-point

encapsulation ppp

3 Replies 3

pbarman
Level 5
Level 5

Looks like the serial interface config is posted incomplete here. Does the serial interface participate in multilink?

Apply service-policy to only the multilink interface and not on the participating physical interfaces, and see if that makes a difference. That's how it should be.

What is the IOS version on the router? If config is good, it may be a bug, search for bugs!

Post the config of the multilink and participating interfaces here, please.

This is pretty much what I have. I actually tried applying it to the multilink first, and only the multilink, and it worked fine for about 1 minute, then it started dropping packets until it dropped my connection. The cpu utilization shot way up during this period. I tried implementing it on just one of the serial interfaces by itself, and it works great. I've tried a few different combinations of things, all which do not work on the Multilink interfaces. I've checked the log after this happens, and nothing appears in log either. I have also set up the class-maps with to priorize DSCP packets, and this failed also. This is the IOS Version:IOS (tm) 7200 Software (C7200-JS-M), Version 12.3(1), RELEASE SOFTWARE (fc3)

ip access-list extended ugw-traffic

permit udp any any eq 2427

permit udp any any eq 2727

permit udp any any range 3000 3590

permit udp any any range 16400 16990

!

class-map match-any voice-class

match access-group name ugw-traffic

!

!

policy-map LLQ

class voice-class

priority 400

class class-default

fair-queue

!

interface Multilink1

ip address xx.xx.xx.xx 255.255.255.252

ip ospf network point-to-point

ppp multilink

ppp multilink group 1

Service-policy output LLQ

!

interface Serial1/0/16:0

ip address xx.xx.xx.xx 255.255.255.252

service-policy output LLQ

ip ospf network point-to-point

encapsulation ppp

interface Serial1/0/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial1/0/2:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

d.albertson
Level 1
Level 1

I don't know that this will solve all of your issues but you need to configure the serial port that is using multilink to use a fifo queue. By default the serial interface applies a fair-queue which over-rides the LLQ policy. If the link is slower than 768Kbps you should also apply MLP LFI.

interface Serial1/0/16:0

no fair-queue

Dave