06-02-2005 04:57 AM - edited 03-13-2019 09:18 AM
Hello,
I have setup a terminal/comm server to catch ascii characters from a serial line
I make the configuration of the router as described on http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml
But every time I try a connection via telnet ip port will be blocked. (Connection refused)
Which debug commands are necessary to solve the problem.
I try the configuration on an older router ios (11.3) and is working.
why not at 12.3
06-02-2005 05:37 AM
Was it the same config on the same router with older IOS that worked? Or is there any possibility that there is some difference in configuration or difference in hardware that would explain why one worked and one did not?
When you try a connection and the connection is refused, if you do a clear line does the behavior change?
If you post the complete config of the terminal server perhaps we could find what is preventing the connections.
HTH
Rick
06-02-2005 06:26 AM
The test which I have tried is an other router 25xx with serial interfaces connected to modems.
This router has two serial interfaces and is connected to a terminalserver wich sends data.
Thank for looking for.
here is my config
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT01
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxxxxxxx
!
username cisco privilege 15 secret 5 $1xxxxxxxxxxxxxxxx
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
ip domain name yourdomain.com
ip host weather 2018 10.180.5.40
ip host atis 2019 10.180.5.40
no ftp-server write-enable
!
!
!
!
interface Loopback0
ip address 10.180.5.40 255.255.255.0
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 10.180.1.41 255.255.255.0
duplex auto
speed auto
standby ip 10.180.1.40
standby 2 priority 90
!
interface FastEthernet0/1
ip address 172.27.4.4 255.255.0.0
duplex auto
speed auto
standby ip 172.27.4.100
standby 1 priority 90
!
interface FastEthernet0/0/0
no ip address
shutdown
!
interface FastEthernet0/0/1
no ip address
shutdown
!
interface FastEthernet0/0/2
no ip address
shutdown
!
interface FastEthernet0/0/3
no ip address
shutdown
!
interface Serial0/1/0
physical-layer async
no ip address
async mode dedicated
!
interface Serial0/1/1
physical-layer async
no ip address
async mode dedicated
!
interface Vlan1
no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.27.1.1
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
logging 10.180.1.2
access-list 101 permit ip any 10.180.5.0 0.0.0.255
access-list 101 permit ip 10.180.5.0 0.0.0.255 any
!
control-plane
!
banner login
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "xxxxxxxx"
with the password "xxxxxxxxxx".
Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.
username
no username xxxxxxxxx
Replace
For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
!
line con 0
login local
line aux 0
speed 115200
line 0/1/0
exec-timeout 0 0
transport input telnet
databits 7
stopbits 1
speed 1200
line 0/1/1
transport input telnet
databits 7
speed 1200
flowcontrol software
line vty 0
exec-timeout 0 0
privilege level 15
password cisco
login local
transport input telnet
stopbits 1
flowcontrol software
line vty 1 4
exec-timeout 0 0
privilege level 15
password xxxxxxxxxxxxx
login local
transport input telnet
line vty 5 15
exec-timeout 0 0
privilege level 15
password cisco
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
06-02-2005 08:51 AM
I have looked at the config and have a couple of questions.
- the example in the link that you used has "no exec" on the async lines. Your config does not have this. If you add "no exec" on the async lines does the behavior change?
- your config has the two hosts on line 18 and 19. Are you sure that this is where the connections really are?
- it might be helpful if you post the output of show line from this router.
- what kind of connection is it between this router and the routers that you are trying to access?
HTH
Rick
06-02-2005 09:23 PM
HI Rick I have tried all what is described in the example the port 2019 and 2018 I get as below. (sh line)
An other question which I ask me is. In which feature set is terminal/comm included. The system image is c2800nm-ipbase-mz.123-8.T7
May be there ist the problem? Which debug should I use to determine an error?
We want connect serieal line to the router. On the cable are characters send from an other device. At our test environment a Xyplex Terminalserver. A telnet session to the serial port shall catch these characters and integrate them in an application.
Regards Robert
RT01#sh line
Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
0 0 CTY - - - - - 0 0 0/0 -
1 1 AUX 115200/115200- - - - - 0 0 0/0 -
A0/1/0 18 TTY 1200/1200 - - - - - 0 0 0/0 Se0/1/0
A0/1/1 19 TTY 1200/1200 - - - - - 0 0 0/0 Se0/1/1
* 322 322 VTY - - - - - 4 0 0/0 -
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide