cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
62055
Views
30
Helpful
49
Replies

ASK THE EXPERT - Nexus 5000 & 2000 series

ciscomoderator
Community Manager
Community Manager

with Lucien Avramov

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to learn how to troubleshoot Nexus 5000 & 2000 series with Lucien Avramov.  Lucien is a customer support engineer at the Cisco Technical  Assistance Center. He currently works in the data center switching team supporting customers on the Cisco Nexus 5000 and 2000. He was previously a technical leader within the network management team. Lucien holds a  bachelor's degree in general engineering and a master's degree in  computer science from Ecole des Mines d'Ales. He also holds the  following certifications: CCIE #19945 in Routing and Switching, CCDP,  DCNIS, and VCP #66183.

Remember to use the rating system to let Lucien know if you have received an adequate response.

Lucien might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the Security discussion forums shortly after the event. This event lasts through March 11, 2011. Visit this forum often to view responses to your questions and the questions of other community members.

49 Replies 49

wu.kristi
Beginner
Beginner

Lucien

I have a 2232 and I am not able to configure it. I am running NX-OS 4.1(3)N1(1). Can you help? Thanks.

I'm glad you asked.

The 2200 series (2232, 2248) need you to run NX-OS version 4.2 or later.

The actual version you are running on your Nexus 5000 is not capable to communicate with the 2232. Please consider an upgrade.

To decide on which version to go with, I recommend you to take a look at the release notes:

http://www.cisco.com/en/US/products/ps9670/prod_release_notes_list.html

Also here is the upgrade instructions, in the upgrade / downgrade guide:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/upgrade/421_n2_1/Cisco_Nexus_5000_Series_NX-OS_Software_Upgrade_and_Downgrade_Guide__Release_421_chapter1.html

dhingst
Beginner
Beginner

Hi Lucien,

I have a pair of new 5548's running 5.0(2)N2(1). I am trying to use Dell R810 servers with Qlogic QLE8150 CNA's. Under Windows 2008R2 I can't seem to pass a packet larger than 251 bytes through the switch from a 1Gb device to a 10Gb devices. Between 1Gb devices everything works fine. I have not tried between two 10G devices yet. From Windows a simple "ping 10.40.3.227 -l 251" works but using "-l 252" fails. This happens with multiple CNA's. The CNA itself appears to work since small pings work and the FC interface is up (but I haven't tried using any FC resources yet). Possibly related, Using the same model of server and CNA with VMware when the driver for the CNA is loaded the switch port will error out after 45 minutes or so with a "DCX-No ACK in 100 PDUs"  I'm scratching my head trying to figure out how to troubleshoot this so I can figure out if it is the switch, CNA, server or ??? Do you have any suggestions on things to look at before I call TAC? Since I don't have other cards I'm having a hard time pointing the finger at the right component. So far the 5548 makes a fine 1Gb switch but we haven't been able to do anything with 10Gb or FCoE.

What you observe is normal, the 5548 with the actual software revision actually does not support yet the speed 1 GB, even though you can configure it on the CLI. From version 5.0.3 that will be released in the next few days, the speed 1 GB will be supported and then I think your issue will go away. At this point you were able to configure 1 GB and have 1 GB to 1 GB work, however the issues start happening when you go from 1 GB to a 10 GB.

In the meantime, while you wait for 5.0.3 release, a  quick test for you to confirm this would be to remove the speed 1000 from each physical 5548 port and try 10 gb to 10 gb connection.

5.0(3)N1(1) just got released on cisco.com and supports 1 GB. Can you please upgrade? This should resolve your issue.

Hello Lucien,

I have a question about Nexus 5548P Switches and the 1GB ports. Once I upgrade the switches, to 5.0(3)N1(1) - will I be able to direct connect a Cisco switch (maybe a 2960G) to the 5548 via SFP? Please let me know.

Also, a doubt regarding the Layer 3 upgrade to the 5548P, using the daughter card - When I am performing the initial configuration on the 5K - can I upgrade them to the 5.0.3.N1.1 and then setup vPC etc - so that adding the daughter card can be done one switch at a time (so that there will be no downtime)?

Thanks in advance!!


1. Yes if you upgrade to 5.0(3)N1(1) you will be able to use any port on the 5548 as 1 GB speed and connect for example a 2960G.

2. You can configure your switches and then upgrade to 5.0(3)N1(1), or first upgrade and then configure vPC. Remember that in the 5548P, you will need to remove the power supplies in the back place the card and replace the power supplies. This upgrade can be done in rack, you dont need to open the chassis.

Let me know if you have any other questions.

Hi Lucien,

I am trying to upgrade the image on the 5548P to the 5.0(3)N1(1) code - I've downloaded the kickstart and system images, but when I run the "install all ...." command, I get an error - when I searches on some forums - it said the image could be bad. Any suggestions on why I am getting this?

NX5K-1#dir bootflash:

    4497974    Mar 08 16:03:46 2011  n5000-uk9-kickstart.5.0.3.N1.1.bin
  188747641    Mar 08 16:08:22 2011  n5000-uk9.5.0.3.N1.1.bin
NX5K-1(config)# install all kickstart bootflash:n5000-uk9-kickstart.5.0.3.N1.1.bin system bootflash:n5000-uk9.5.0.3.N1.1.bin
Verifying image bootflash:/n5000-uk9-kickstart.5.0.3.N1.1.bin for boot variable "kickstart".
[#                   ]   0% -- FAIL. Return code 0x40450009 (cannot read image info).
Pre-Upgrade check failed. Return code 0x40930011 (Image verification failed).
NX5K-1(config)# sh install all status
This is the log of last installation.
Verifying image bootflash:/n5000-uk9-kickstart.5.0.3.N1.1.bin for boot variable "kickstart".
FAIL. Return code 0x40450009 (cannot read image info).
Pre-Upgrade check failed. Return code 0x40930011 (Image verification failed).
Any help would be appreciated!

The size of your kickstart image does not seems right, it should be: 25148416 bytes, the MD5 checksum for it is: e5c733cdd70feac0ee746924d0372709

Your system image has the correct size.

I advise you to download again the kickstart from our website and compare the size, MD5 if need be and then run install all again.

Yes sir!

I downloaded the kickstart again from CCO - and it worked. Thanks for your help!

thorton.stevet
Beginner
Beginner

Hi Lucien,

I have 5020s and a 5548, can I use the ports with a speed of 1 GB? Thanks Steve.

Yes you can, here are the caveats:

1. On the 5520s, you can use the first 16 ports as a speed 1 GB (port e1/1 to e1/16).

2. On the 5548, you can use any port with a speed of 1 GB, however you need run the latest NX-OS version: 5.0(3)N1(1). That code was released yesterday on cisco.com, so you may download it.

Hi Lucien,

Thanks for being here with us for our help.

Nexus 5K can support only 12 N2K fiber extenders at a time. That is out of 20 ports, only 12 ports can be used to connect to N2Ks. Is this a true statement, if yes then whats the purpose of remaining 8 ports on N5k?

How many (and which) ports on 5520 can be used for VPC with N2K?

As per my understanding, VPC is configured on the downlink ports, plz confirm.

Nexus 2K fiber extender modules cuurently do not support link aggregation. Why do we have it like this, and is there any roadmap for availability fo this feature?

If it is required to dual-home the downstream switch to N2K, Flex Link feature should be used. This way spanning-tree can be avoided. Can N2K be used to connect the downstream switch in this way, and would there be more cons than the pros?

regards,

Mohsin

Great questions.

As you say, the 5000, can support up to 12 FEX, and the 5500 up to 16 as per:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration_limits/limits_503a/nexus5k_config_limits_503_chapter1.html

Keep in mind that the 2148,2248 have 4 10 GE ports, the 2232 have 8 10 GE ports and the 2224 2 10 GE ports, so depending on model and the bandwitdh you will allocate to the FEX you will use between 1 to 8 10 GE ports for each FEX.

The ports on the Nexus 5000 series can be used for multiple type of connections: connection to other switches (Nexus 7K, Catalyst switches etc..), connection to a FEX, connection to 10 GB servers.

The FEX do support LACP. There are two scenarios:

-2148 series: a port-channel with LACP accross 2 2148 works when you configure vPC. Port-channel within 2 physical ports on the same 2148 will not work.
-2200 series: LACP will work with either vPC or multiple connections on the same FEX.

The N2K can have a switch connected downstream, however you need to be very careful with not introducing a loop in your network since there is no spanning-tree running on the FEX ports. To get your link between a FEX and a switch to come up, you will have to enable spanning-tree bpdufilter, so the link doesnt error disable.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers