cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1520
Views
0
Helpful
6
Replies

LISP: difference platform ping each other UNREACHABLE.

dekang_wu
Beginner
Beginner

Problem Description:

I setup a LISP demonstration for VM vMotion across DCI. But I has some problems: Same platform (IOS) ping each other reachable, but difference platform ping each other UNREACHABLE. (Diagram and details as attachment.)

For example:

  1. AET12C-OCW03(N7K,NXOS, 50.50.50.50) --> NEC12C-OCW03(N7K,NXOS, 60.60.60.60) Reachable
  2. WAN-SW(C3560,IOS XE, 20.20.20.20 or 20.0.0.11) --> NEC12C-CSW01(C3560,IOS XE, 80.80.80.80) Reachable
  3. Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) --> Remote-Site2 (C1941,IOS, 40.40.40.40) Reachable
  4. Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) --> AET12C-OCW03(N7K,NXOS, 50.50.50.50) Unreachable
  5. NEC12C-CSW01(C3560,IOS XE, 80.80.80.80)--> AET12C-OCW03(N7K,NXOS, 50.50.50.50) Unreachable
  6. Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) -->NEC12C-CSW01(C3560,IOS XE, 80.80.80.80) Unreachable

 

Topology

 Topo2.jpg

 

Hardware & Software

Hostname

Hardware

Software

Configuration

4 vdc:

AET12C-OCW03

AET12C-OCW06

NEC12C-OCW03

NEC12C-OCW06

N7010+SUP1+M132XP

NXOS 6.2(2)

EPLD: 186.008

 

4 vdc:

AET12C-OCW01

AET12C-OCW02

NEC12C-OCW01

NEC12C-OCW02

N7010+SUP1+M108X2+M148GT

NXOS 6.2(16)

 

 

WAN-SW

WS-C3650-8X24PD-S

IOS XE 16.3.3

 

AET12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.6.3

 

NEC12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.3.3

 

Remote-Site1

CISCO1941/K9

IOS 15.4(3)M4

 

Remote-Site2

CISCO1941/K9

IOS 15.4(3)M4

 

Test

CISCO1941/K9

IOS 15.6(3)M4

 

 

 

Show & Debug

Problem 1:

  1. Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) --> AET12C-OCW03(N7K,NXOS, 50.50.50.50) Unreachable
  2. NEC12C-CSW01(C3560,IOS XE, 80.80.80.80) --> AET12C-OCW03(N7K,NXOS, 50.50.50.50) Unreachable

 p1.1.png

p1.2.png

p1.3.png

Remote-site1 hasn’t map-cache of 50.50.50.50. 


p1.4.png

Above is the debug log of AET12C-OCW03(N7K,NXOS, 50.50.50.50). It seems received “Map-request” and build a “Map-reply”. But Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) didn’t receive the Map-reply.

p1.5.png

 

If I add a static map-cache 50.50.50.50 at Remote-Site1, the Ping to AET12C-OCW03 is reachable.

Why Remote-Site1 can’t receive the map-reply?

 

 

Problem 2:

  1. Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) --> NEC12C-CSW01(C3560,IOS XE, 80.80.80.80) Unreachable

 Issue ping test on a PC(30.0.0.11) of Remote-site1

p2.1.png

Show ip lisp map-cache on Remote-Site1 router(C1941,IOS, 30.30.30.30)

 p2.2.png

Issue ping test on NEC12C-CSW01(C3560,IOS XE, 80.80.80.80) and show ip lisp map-cache.

p2.3.png

They all have completed map-cache, but can’t ping reachable each other.

 

I turn on DEBUG on Remote-Site1 (C1941,IOS, 30.30.30.30 or 30.0.0.11) and NEC12C-CSW01(C3560,IOS XE, 80.80.80.80).

Issue a ping from 30.0.0.11 --> 80.80.80.80.

 p2.4.png

p2.4.png

I found Remote-Site1 received ICMP-request, but other site NEC12C-CSW01 hasn’t any debug log

 

Issue a ping from 80.80.80.80 -à. 30.0.0.11. They all haven’t any debug log.

 p2.7.pngp2.8.png

 

Why??

6 Replies 6

Victor Acevedo
Cisco Employee
Cisco Employee

Hello Dekang_Wu,

 

Before we continue troubleshooting, we should address a few issues. It seems that you have unsupported software and hardware in your setup. With unsupported versions and modules, unexpected behaviors will occur. 

 

Hostname

Hardware

Software

Supported SW/HW

4 vdc:

AET12C-OCW03

AET12C-OCW06

NEC12C-OCW03

NEC12C-OCW06

N7010+SUP1+M132XP

NXOS 6.2(2)

EPLD: 186.008

 On N7k's only M132 linecards are supported and only on 6.2.(12) and above

4 vdc:

AET12C-OCW01

AET12C-OCW02

NEC12C-OCW01

NEC12C-OCW02

N7010+SUP1+M108X2+M148GT

NXOS 6.2(16)

 

On N7k's only M132 linecards  are supported and only on 6.2.(12) and above 

WAN-SW

WS-C3650-8X24PD-S

IOS XE 16.3.3

Should be ok  

AET12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.6.3

Should be ok  

NEC12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.3.3

Should be ok

Remote-Site1

CISCO1941/K9

IOS 15.4(3)M4

 On the ISR G2 platforms, LISP is only supported on 15.5(2) and above 

Remote-Site2

CISCO1941/K9

IOS 15.4(3)M4

  On the ISR G2 platforms, LISP is only supported on 15.5(2) and above 

Test

CISCO1941/K9

IOS 15.6(3)M4

  On the ISR G2 platforms, LISP is only supported on 15.5(2) and above 

 

Please make the needed upgrades in software and hardware in order to have LISP function properly. This information and more is documented in the following doc:

 

http://lisp.cisco.com/lisp_hwsw.html#HW

 

Vic

Hello Victor,

 

Thank you for your comment. That's true if it with unsupported versions and modules, unexpected behaviors will occur. I upgraded new firmware of G2 router and N7K, details as following.

 

Hostname

Hardware

Software

4 vdc:

AET12C-OCW03

AET12C-OCW06

NEC12C-OCW03

NEC12C-OCW06

N7010+SUP1+M132XP

NXOS 6.2(2)

EPLD: 186.008

 

Upgraded to

NXOS 6.2(20)

EPLD: 186.010

 

4 vdc:

AET12C-OCW01

AET12C-OCW02

NEC12C-OCW01

NEC12C-OCW02

N7010+SUP1+M108X2+M148GT

NXOS 6.2(16)

 

 

Upgraded to

NXOS 6.2(20)

 

WAN-SW

WS-C3650-8X24PD-S

IOS XE 16.3.3

AET12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.6.3

NEC12C-CSW01

WS-C3650-8X24PD-S

IOS XE 16.3.3

Remote-Site1

CISCO1941/K9

IOS 15.4(3)M4

Upgraded to

IOS 15.6(3)M4

Remote-Site2

CISCO1941/K9

IOS 15.4(3)M4

Upgraded to

IOS 15.6(3)M4

Test

CISCO1941/K9

IOS 15.6(3)M4

 

I have only one M132XP module in N7K-1,  so I use this N7K-1 to create 4 vdc(AET12C-OCW03 ; AET12C-OCW06; NEC12C-OCW03; NEC12C-OCW06) to art xTR role.

p3.PNG

 

After software upgraded, the problems remains unresolved.

Hello Dekang_Wu,

 

Thank you for taking this very important step. And lets see what is going on with your setup.

 

Let's tackle problem 1 first. I can see that the your MSMR may be missing the 50.50.50.50/32 entry. In the output you shared, we can only see the /24's (maybe ok if we are not using LISP for mobility). In order to confirm this, can you please share the outputs of "show lisp site name DC1 detail" from the MSMR. This should include more specific EID"s we have received from DC1. 

 

Also, from DC1 (AETI2C-OCW03), can you please share the following outputs:

  • show ip lisp database
  • show lisp dynamic-eid summary
  • show run  <<< I do not see your configs attached here even though they are referenced in the LISP issue docx file

 

From Remote Branch 1 can you just share your "show run".

 

Thx,

Vic 

Dear Victor,

 

Thank you for help. please find the log and configuration as attachment. thanks.

 

p4.PNGp4.1.PNG

 

Hey Dekang_Wu,

 

Thank you for sharing these configuration files. Are these the latest configuration files? I see that some of your N7k's are still showing running 6.2.(2) code instead of the code that supports LISP(6.2.12 and above). 

 

Also, I do see that your WAN-SW which is your MSMR has "encapsulation vxlan" for your LISP configs. Can we remove this and test again? 

 

Finally, can you send me a "show ip route" from the remote1 router? 

 

Thanks,

Vic

Dear Victor,

I'm very sorry for late reply.The latest configuration as attachment, the previously configuration attached was captured before the NXOS upgrade, but It should haven't any change after upgrade.

 

This "encapsulation vxlan" command is always been my confusion, there are few reference. I tried to remove it but no works.

p5.PNG

 

IOS router has this command , but unfortunately it's no works on my C1900 platform.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers