cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
286
Views
0
Helpful
2
Replies

(2) 2501s T-1 slow

pineapplebob
Level 1
Level 1

I have two 2501s each with IOS 12.2 and 16MB. They are linked with a DTE/DCE serail cable. One is linked to our T-1 and the other to our LAN. When going through the routers to the net, I get about 60k throughput. If I bypass the Ciscos, I get about 866k throughput. This is much too dramatic of a diff for my tastes.

Here is the output of `show run' for each router. The routers are simply named (obviously) WAN and LAN.

WAN#sh run

Building configuration...

Current configuration : 913 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WAN

!

logging rate-limit console 10 except errors

!

ip subnet-zero

no ip finger

ip name-server x.x.x.x

ip name-server x.x.x.x

!

no ip dhcp-client network-discovery

!

interface Ethernet0

ip address x.x.x.71 255.255.255.240

ip nat outside

!

interface Serial0

bandwidth 1000

ip address 10.1.1.1 255.255.255.0

ip nat inside

no ip mroute-cache

clockrate 64000

!

interface Serial1

no ip address

shutdown

!

ip kerberos source-interface any

ip nat inside source list 1 interface Serial0 overload

ip nat inside source static 10.1.1.2 x.x.x.71

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x (this is the router provided by the ISP)

ip route 192.168.1.0 255.255.255.0 10.1.1.2

no ip http server

!

line con 0

transport input none

line aux 0

line vty 0 4

login

!

end

Now the LAN Router:

LAN#sh run

Building configuration...

Current configuration : 838 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname LAN

!

logging rate-limit console 10 except errors

!

ip subnet-zero

no ip finger

ip name-server 192.168.1.7

!

no ip dhcp-client network-discovery

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Serial0

bandwidth 1000

ip address 10.1.1.2 255.255.255.0

ip nat outside

!

interface Serial1

no ip address

shutdown

!

ip kerberos source-interface any

ip nat pool overld 10.1.1.2 10.1.1.2 prefix-length 24

ip nat inside source list 7 pool overld overload

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

no ip http server

!

access-list 7 permit 192.168.1.32 0.0.0.199

!

!

line con 0

transport input none

line aux 0

line vty 0 4

login

!

end

I found that I had to run NAT on both routers to get a link. If there is a way to streamline these configs, I would appreciate it. I have also tinkered with the bandwidth settings up and down, currently at 1000 and it does not seem to have any effect. While I am at it, I'll say right now that I am a true newbie to Cisco IOS, but have been doing the best I can using Cisco's site and some books.

If I am posting in the wrong forum please point me to the correct one. Also apologies for the long post.

2 Replies 2

ramzi_kotob
Level 1
Level 1

The bandwidth setting has nothing to do with your throughput. your clockrate 64000 on your WAN router is setting your bps to 64k. Try changing your clockrate.

Ramzi.

Ramzi!

Thank you. That was it. I reset the clockrate to 1000000 and it flies at 886k typical. I did not set to full 1500000 as I do not require full `bandwidth' throughput from the T.

Again, thanks that really helped me.

Bob