cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
333
Views
0
Helpful
2
Replies

Callback on 2600s

g-davidson
Level 1
Level 1

I'm trying to get callback working on a 2611 router. Everything seems to work fine until the router tries to initiate the callback. The router times out trying to connect to a remote host, which i'm guessing is the modem. Here's the configuration I'm using:

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service compress-config

!

hostname distnet

!

enable secret ****************************

enable password ****************************

!

username dialin password 0 ***********

username derek callback-dialstring 24,61 callback-line 65 password 0 ************

memory-size iomem 10

clock timezone CDT -6

clock summer-time CDT recurring

ip subnet-zero

ip cef

!

!

ip host modem 2065 192.168.1.13

!

chat-script rstcnet "" "at&fs0=1s3=13&c1&d3&k3l=0m=0" "OK"

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script backup "" "atdt \T" TIMEOUT 30 "CONNECT" \c

call rsvp-sync

!

!

interface Ethernet0/0

ip address 192.168.1.13 255.255.255.0

load-interval 60

no keepalive

half-duplex

!

interface Async65

ip address 192.168.2.1 255.255.255.0

encapsulation ppp

dialer in-band

dialer map ip 192.168.2.5 name derek modem-script callback

dialer-group 1

async mode interactive

peer default ip address pool async

ppp callback accept

ppp authentication chap

!

ip local pool async 192.168.2.5

no ip classless

no ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

!

dial-peer cor custom

!

!

!

!

line con 0

password *********************

stopbits 1

line aux 0

exec-timeout 0 0

script dialer backup

script reset rstcnet

script callback callback

modem InOut

transport input all

autoselect ppp

stopbits 1

speed 38400

flowcontrol hardware

line vty 0 4

password *********************

login

line vty 5 15

password *********************

login

!

end

Any help or suggestions would be greatly appreciated.

Thanks,

George Davidson

1 Accepted Solution

Accepted Solutions

giedriusa
Level 1
Level 1

George,

it seems that You are missing a line

modem autoconfigure discovery

under line aux0 configuration, also try to add the following commands under line aux0:

no flush-at-activation

no exec

transport preferred none

transport output none

autohangup

I have this working exactly as You described

If that does not help, I will need output of command debug confmodem posted here

HTH

Rgds

Giedrius

View solution in original post

2 Replies 2

giedriusa
Level 1
Level 1

George,

it seems that You are missing a line

modem autoconfigure discovery

under line aux0 configuration, also try to add the following commands under line aux0:

no flush-at-activation

no exec

transport preferred none

transport output none

autohangup

I have this working exactly as You described

If that does not help, I will need output of command debug confmodem posted here

HTH

Rgds

Giedrius

tepatel
Cisco Employee
Cisco Employee

Here is the url which has sample config and troubleshooting for "Configuring MS Callback Between a Router and a Windows PC"

http://www.cisco.com/warp/public/793/access_dial/async_ppp.html

Pl. see if that helps.

For config change, add "login local" under the "line aux 0" and I would modify your all chat scripts for 60 secs for timeout as 30 secs it little short time. So callback chat will look like

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

You can send those debug here for review.

debug chat

debug modem

debug ppp nego

debug aaa authorization

debug callbcak

debug ppp cbcp