I am running a c2600-i-mz.122-5a.bin on this router and it is doing NAT as follows for both source and destination.
interface FastEthernet0/0
ip address 10.192.57.228 255.255.255.224
ip access-group 101 in
ip nat inside
speed auto
full-duplex
!
interface Serial0/0
ip address 10.0.254.1 255.255.255.0
ip nat outside
no fair-queue
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip nat pool abc 10.0.254.5 10.0.254.5 netmask 255.255.255.0
ip nat inside source list 63 pool abc overload
ip nat outside source static 170.224.102.198 10.192.57.230
ip nat outside source static 170.224.102.197 10.192.57.229
ip classless
ip route 10.0.0.0 255.0.0.0 10.192.57.225
ip route 170.224.102.197 255.255.255.255 10.0.254.2
ip route 170.224.102.198 255.255.255.255 10.0.254.2
access-list 63 deny 10.192.57.230
access-list 63 deny 10.192.57.229
access-list 63 permit 10.0.0.0 0.255.255.255 log
This all works fine, but
I need to enable ssh on this router, so I upgraded to the three codes,
c2600-ik9o3s-mz.122-26.bin
c2600-advsecurityk9-mz.124-1.bin
c2600-a3jk9s-mz.123-2.T9.bin
Router has 128M DRAM and 32M flash
and none work. The router stops Nat'ing as soon as the new code loads, and debug ip nat shows no Nat occurring for source on outbound. As a result, the connection fails. What IOS would enable this to occur, that is, allow both the NAT and SSH?
Thanks