03-08-2017 02:23 PM - edited 03-03-2019 08:29 AM
We are trying to connect a Cisco 3750-48 to a Brocade ICX6450 switch.
********************************************************************************************************************************
Cisco IOS Software, C3750 Software (C3750-IPBASEK9-M), Version 12.2(55)SE5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Thu 09-Feb-12 18:59 by prod_rel_team
Image text-base: 0x01000000, data-base: 0x02D00000
********************************************************************************************************************************
Copyright (c) 1996-2015 Brocade Communications Systems, Inc. All rights reserved.
UNIT 1: compiled on Aug 23 2015 at 21:57:32 labeled as ICX64R08030c
(9725016 bytes) from Primary ICX64R08030C.bin
SW: Version 08.0.30cT313
Boot-Monitor Image size = 776680, Version:07.4.01T310 (kxz07401)
HW: Stackable ICX6450-48
********************************************************************************************************************************
The Cisco switch port used is port 1/0/48
*********************************************************
!
interface FastEthernet1/0/48
switchport access vlan 7
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
!
**********************************************************
The Brocade switch port used is port 1/1/48
**********************************************************
!
interface FastEthernet1/0/48
switchport access vlan 7
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
!
**********************************************************
Communications worked for a while but are now not working. Both switches show port are up, but can't ping form either. Any ideas????
Solved! Go to Solution.
03-12-2017 05:35 PM
OK, so on the surface they seem to be OK.
Now we work on what the actual problem is.
Again, please define what 'a while' means. Let's have some logs showing what happens when the links actually come up and when the communications stop.
Where are you pinging from and to?
Show the output from the following commands (both from the Cisco and Brocade side) either side of the communications breaking:
show spanning-tree vlan 7
show spanning-tree int f1/0/48 (and eth 1/1/48)
show arp vlan 7 (or at least for the target IP address)
show mac address vlan 7
show mac address int f1/0/48 (and eth 1/1/48)
show int f1/0/48 switchport (and eth 1/1/48)
Let's see how we go with all of that
03-09-2017 04:32 PM
You're not giving us a lot to work with here.
Is this correct or a typo?
The Brocade switch port used is port 1/1/48
*********************************************************
!
interface FastEthernet1/0/48
switchport access vlan 7
Have you really posted the config from the Brocade or have you just copied the Cisco config twice?
When you say 'Communications worked for a while', can you please define this? A while might mean 2 seconds or it might mean 5 days.
Is it a spanning-tree issue? Are both systems using the same Spanning-tree method?
Are there any log entries that might help?
What IP addresses are you pinging between?
What interfaces are these on and where are the respective routers if this is relevant (i.e. not in the same subnet)?
Show interface f1/0/48 switchport may help. Make sure the Brocade shows similar output.
03-10-2017 03:04 PM
Sorry it has taken so long to respond. Tied up with other issues and priorities. I've attached the "show running" configurations for both switches.
Are both systems using the same Spanning-tree method?
This could be one of the issues. The Cisco Switch shows
spanning-tree mode pvst
spanning-tree extend system-id
The Brocade Switch shows
spanning-tree 802-1w
spanning-tree 802-1w priority 16384
system-max spanning-tree 64
03-12-2017 05:35 PM
OK, so on the surface they seem to be OK.
Now we work on what the actual problem is.
Again, please define what 'a while' means. Let's have some logs showing what happens when the links actually come up and when the communications stop.
Where are you pinging from and to?
Show the output from the following commands (both from the Cisco and Brocade side) either side of the communications breaking:
show spanning-tree vlan 7
show spanning-tree int f1/0/48 (and eth 1/1/48)
show arp vlan 7 (or at least for the target IP address)
show mac address vlan 7
show mac address int f1/0/48 (and eth 1/1/48)
show int f1/0/48 switchport (and eth 1/1/48)
Let's see how we go with all of that
03-13-2017 02:54 PM
Mismarked as correct answer. How do I uncheck that?
Here are the responses for the commands you listed.
03-14-2017 05:57 PM
So you have a problem with VLAN 7. All your interfaces seem to be configured for VLAN 7 but it doesn't exist, at least on the Cisco. And I think what you are saying is that the ping worked between the switches for 'a while' (you still haven't defined that) and then stopped. Did it stop when you deleted VLAN 7 somehow or somewhere?
Let's see "show interface VLAN 7". That will likely show as line protocol down.
Start by recreating VLAN 7 on the Cisco and on the Brocade. Ensure there is a spanning-tree instance for VLAN 7 and it appears on the trunk between them. Research and check the VTP configuration on the switch. If it is a client then you may have removed VLAN 7 elsewhere or you might have to create it on a different switch (a VTP server)
Recheck the 'show interface VLAN 7'. Once you recreate VLAN 7, this should show as line protocol up.
Where did FastEthernet 3/0/48 come from? it wasn't in your original configuration.
You haven't given me any command output from the Brocade so I am running blind there.
As an aside, you have switchport access and switchport trunk configurations on all your ports. Although this isn't necessarily a problem, pick one. I suggest you remove the 'switchport access vlan 7' from your trunk, and remove 'switchport trunk native vlan 7' from all interfaces.
03-15-2017 02:20 PM
The working for a while meant 15-20 minutes. We then tried to setup vty security and that broke it. We are now testing with a different Cisco switch connected to a different Brocade switch to start form scratch to get a working configuration. so far, nothing.
Not sure if these commands are equivalent:
Cisco Switch
********************************************
show interface VLAN 7
Vlan7 is up, line protocol is up
Hardware is EtherSVI, address is 001d.a263.06c1 (bia 001d.a263.06c1)
Internet address is 165.235.24.221/23
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 4d21h, output 1d22h, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
287 packets input, 294452 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
27 packets output, 1743 bytes, 0 underruns
0 output errors, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
********************************************
Brocade switch
********************************************
********************************************
On the Cisco switch I ran the command:
*************************************************************
show vlan
03-15-2017 05:07 PM
Now I don't actually know which switch the output in the previous posts is actually from, but working from your last post:
VLAN 7 is present on the switch but doesn't appear on F3/0/48. I'm now assuming this is the interface you have the Brocade connected into. Is that interface actually up?
Let's get the switches connected again and run the full suite of tests again. I'll show the Cisco commands but you should find the equivalent Brocade ones to also look at.
Layer 1
Are the switches actually connected and are there lights on the connected interfaces?
Do the physical interfaces show as up on both ends? (show int g3/0/48)
Are there any errors on the interface? Clear int counters, wait and then show int
Layer 2
Are there any MAC addresses visible (show mac add int g3/0/48)
Is the VLAN present on the switch (show vlan id 7)
Is the VLAN present on the interface. Show vlan id 7 - look for G3/0/48 & show spanning-tree int g3/0/48 - look for VLAN 7 presence
Are there any MAC addresses in VLAN 7? show mac address vlan 7
Layer 3
Is the Vlan 7 interface up (show int vlan 7)
Try to ping the other switch. Is there an ARP entry for it? Show ip arp
If so, check again for the MAC address (show mac address)
debug ip icmp might be useful
Once it is all working, you can try to configure VTY security. If it breaks again, take the configuration off and see if the pings work again. Make sure logging is enabled - ensure log console or log monitor is set to debug and if you are using telnet or ssh to connect to the switch, ensure you have typed 'term mon'.
If you still can't work it out, post what you tried to configure along with any generated logs
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide