04-23-2004 04:32 AM - edited 03-02-2019 03:12 PM
We have a isdn connection to another side. the application sends packets and the router will drop the first 3 or 4 packets untill the isdn connection has established.
The command to tell the router it should not drop the first packets is: dialer hold-queue [number of packet].
Here is the router configuration: (Cisco 1721, IOS 12.3.1a)
!
interface BRI0
description Verbidnung zu ISP - IBM
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
dialer idle-timeout 30
dialer string 0840840750
dialer hold-queue 100
dialer-group 1
no peer default ip address
isdn switch-type basic-net3
isdn calling-number 0522143178
no keepalive
no fair-queue
no cdp enable
ppp authentication chap callin
ppp chap hostname [hostname]
ppp chap password [password]
ppp pap sent-username [username] password [password]
!
Could you help me?
thx
04-23-2004 12:00 PM
See if setting up a timeout with hold-queue helps :
c2600(config-if)#dialer hold-queue 12 ?
timeout Specify length of time data is held while interface is connecting
By default, this timeout is 40 seconds so if your ISDN and PPP is taking longer than that, you should definitely set it longer.
You could try this one both the dialer and dialed router.
~Zulfi
04-26-2004 01:09 AM
hello Zulfi
thx for your feedback.
we have configured this but the problem is still there...
here is the router config:
Current configuration : 2540 bytes
!
! Last configuration change at 17:52:10 mest Sun Apr 25 2004
! NVRAM config last updated at 17:52:19 mest Sun Apr 25 2004
!
version 12.3
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname rtp2p-multi
!
enable secret xxxx
!
username xxxx password [password]
clock timezone MET 1
clock summer-time mest recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
no ip source-route
!
!
no ip domain lookup
!
ip cef
isdn switch-type basic-net3
!
!
!
!
interface BRI0
description Verbidnung zu ISP - IBM
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
dialer idle-timeout 30
dialer string 0840840750
dialer hold-queue 12 timeout 60
dialer-group 1
no peer default ip address
isdn switch-type basic-net3
isdn calling-number 0522143178
no keepalive
no fair-queue
no cdp enable
ppp authentication chap callin
ppp chap hostname [hostname]
ppp chap password [password]
ppp pap sent-username [username] password [password]
!
interface FastEthernet0
ip address y.y.y.y 255.255.255.0
no ip redirects
no ip proxy-arp
ip accounting output-packets
ip nat inside
speed auto
!
interface Serial0
bandwidth 64
ip address z.z.z.z 255.255.255.252
ip access-group 101 in
no ip unreachables
ip accounting output-packets
ip nat outside
encapsulation ppp
no fair-queue
ppp authentication chap
!
interface Serial1
no ip address
shutdown
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer in-band
dialer hold-queue 12
no cdp enable
!
ip nat inside source list 100 interface BRI0 overload
ip classless
ip route 153.46.226.0 255.255.255.0 Serial0
ip route 194.32.223.47 255.255.255.255 BRI0 permanent
no ip http server
!
access-list 100 remark *** Verbindung zu IBM ***
access-list 100 permit tcp any host 194.32.223.47 eq 3305
access-list 100 permit icmp any host 194.32.223.47
access-list 100 deny ip any any log
access-list 101 remark *** OFTP Telekurs Services ***
access-list 101 permit ip 153.46.226.0 0.0.0.255 host 194.209.120.40
access-list 101 permit ip 153.46.226.0 0.0.0.255 host 194.209.120.42
access-list 101 permit ip host 10.39.36.45 host 10.39.36.46
access-list 101 permit icmp any host 10.39.36.46
access-list 101 deny ip any any log
dialer-list 1 protocol ip permit
!
============================================
the router will drop the first 3 or 4 packets untill the isdn connection has established.
the isdn connection will be established in 4-5 seconds.
the customer has tested the same connection with a
3 Com Router --> the result was positive! the router has forwarded all packets correct..
do you have any other idea?? is there a ios problem?
thx
luigi
04-26-2004 03:44 PM
I am assuming this router rtp2p-multi is the dialing side which has the client application? It would be nice to see the config from the dialed/server side (if thats a Cisco router) . Did you try increasing the hold-q size from 12 to a larger value like 30 or 40?
~Zulfi
04-27-2004 04:41 AM
Yes, the rtp2p router is the dialing side...
we have increased the hold-q to 60.
The problem is still there - the same.
The ios of the router is:c1700-y-mz.123-1a (IP)
do you think that this can be a problem?
04-27-2004 01:43 PM
I did a quick bug search but did not find anything matching, but could still very well be an IOS issue. If its not too difficult for you, go ahead for the IOS upgrade. If that does not fix it, I would suggest opening up a TAC case.
~Zulfi
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide