cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
294
Views
0
Helpful
2
Replies

Dual Ethernet Router

admin_2
Level 3
Level 3

I have a 2514 router with two ethernet connections and no serial connections. The goal is to connect our R&D net to a network that has connections to the Internet and to other internal networks. The router on the LAN is a 2600 series and has the follwing config.

ip-subnet-zero

no ip source-route

no ip finger

no ip domain-llokup

no ip bootp server

Interface FastEther 0/0

description ethernet connection to port fa0/1 on the switch1

no ip address

no ip mroute-cache

speed 100

full-duplex

interface FastEthernet0/0.1

description Vlan 1 to switch1

encapsulation isl 1

ip address AAA.AAA.AA.1 255.255.255.0

no ip redirects

interface FastEthernet 0/0.2

description VLAN 2 to switch1

encapsulation isl 2

ip address AAA.AAA.BB.1

no ip redirects

interface serial0/0

description MCI Frame-Relay circuit

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

interace Serial0/0.256 point-to-point

description PVC to NO ciruit ID blablabla

bandwidth 1536

ip address AA.A.AAA.5 255.255.255.252

frame-relay interface-dlci 100

interface Serial0/1

description Frame Circuit

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type ansi

interface Serial0/1.255 point-to-point

description MCI frame relay PVC to NO circuit ID blablabla

bandwidth 1536

ip address AA.A.AAA.1 255.255.255.252

frame-relay interface-dlci 105

router eirgp 155

pasive-interface FastEthernet0/0

network DD.0.0.0

network AAA.AAA.0.0

no auto-summary

no eigrp log-neighbor-changes

ip classless

ip route 0.0.0.0 0.0.0.0 AAA.AAA.C.2 220

ip http server

access-list 10 permit AAA.AAA.0.0 0.0.255.255

My 2514 config is:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco2514

!

no logging console

enable secret xxxx

enable password xxxxx

!

ip subnet-zero

no ip domain-lookup

!

no ip bootp server

!

!

!

interface Ethernet0

description connected to EthernetLAN

ip address AAA.AAA.BB.253 255.255.255.0

no mop enabled

bridge-group 1

!

interface Ethernet1

description connected to EthernetLAN_1

ip address CC.CC.CC.1 255.255.255.128

no mop enabled

bridge-group 1

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

router rip

redistribute connected

network CC.0.0.0

network AAA.AAA.0.0

neighbor AAA.AAA.BB.1

!

router igrp 1

redistribute connected

network CC.0.0.0

network AAA.AAA.0.0

neighbor AAA.AAA.BB.1

!

ip classless

ip route 0.0.0.0 0.0.0.0 AAA.AAA.BB.1

ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

password xxxxx

login

line aux 0

line vty 0 4

password xxxxx

login

!

end

When I submit a ping from the router to anywhere I get a successful reply but when I specify the source of the ping as Interface E1 I get no reply. So it is using Interface E0 when issuing a simple ping from the router which is on the same segment as the 2600 which knows how to get to everywhere.

When tracing from a node on the CC.CC.CC.0 network I can trace to E0 address on the router but can not reach the default gateway of AAA.AAA.BB.1

Any thoughts?

2 Replies 2

mark-obrien
Level 4
Level 4

Two things -

1) If a node is on the CC.CC.CC.0 segment, its default gateway needs to be on that same segment, not on the AAA.AAA.BB.0 segment.

2) The reason pings do not succeed when using the address of E1 is that the 2600 router does not have a route to the CC.CC.CC.0 network. I see that the 2514 is running IGRP, but the 2600 is not. The only route that the 2600 has is the default over a serial link. Either give it a static route for CC.CC.CC.0 or turn on IGRP so that it can learn and share routes with the 2514.

HTH

Mark

why run rip and igrp on 2514 if running eigrp on 2600, why not run same protocol everywhere, and why redistribute connected.