cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2117
Views
5
Helpful
6
Replies

Error adding new device to Prime - IP address is not unique.

bberry
Beginner
Beginner

OK. I am having an issue adding a new devise to my Prime infrastructure that I cannot figure out. I am getting a message that says the following when I try to add a new router....

               Device Creation #.#.#.# failed. IP address is not unique. Address exists as an interface.

I have been looking through the system to see if this is left over from something that we would have removed. I have no other device with this IP address so not sure what else this could be. This is the WAN link on the device just like I used when I added all my other devices. Any thoughts?

 

Brent

6 Replies 6

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - The device managerial IP address should be different, from the one used on the WAN link; create a management IP address for the device.

 M.

All my devices in Prime use an interface from the device. In the case of my routers they all use the WAN interface. I have even tried adding a new switch into prime and it comes back with the same message. Is this something new or could I have accidentally checked a box that suddenly no longer allows this?  

 

Brent

 

 - For routers , accessible from the Intranet it would be advisable to use a local management interface for integration with Prime, modern devices have a separate management port, which can be configured with an IP address in a management vrf . this address can then be used for Prime-access.

 M.

Thomas Schmitt
Beginner
Beginner
Try to ask prime via rest api which device has that ip
https://d1nmyq4gcgsfi5.cloudfront.net/media/prime-infrastructure-api-reference-v3-1/192.168.115.187/webacs/api/v1/index7733.html?id=tutorials

If it is some kind of DB artifact, you can login as root on ncsDiag page and delete it with SQL query. Here you can find some more information https://community.cisco.com/t5/automation-and-analytics/db-variable-for-retrieving-an-interface-ip/td-p/3560850

olivares
Beginner
Beginner

HI bberry,

Were you able to solve the problem? I'm having the same issue with a switch and it seems to be something related to Prime, not on the target device.

Any suggestions will be welcomed.

Thanks!

Just in case is useful for anyone.

I tried what Thomas suggested (Thanks!) and although useful, it only showed that my Prime didn't have any other network device with the IP address that was causing the error.

Then I made a search in the "Application Search" field that is located on the top bar of Prime with the IP address that was causing the problem (let's say 192.168.1.1). Surprisingly to me, it showed an old device that had another IP address (192.168.1.200) but that used to have an interface in its configuration file with IP address 192.168.1.1.

Then the error message made sense to me. Prime wasn't able to add a device with the IP address 192.168.1.1 because it "was already in use" in another device, in an interface.

Since this old device was not in the network anymore, I deleted it from the Prime and then I was able to add the new switch with the IP address 192.168.1.1.

Apparently starting in Prime version 3.7, you can delete the configuration archive that is causing the problem, but I couldn't do it in the version 3.1. So, it is supposed that if you have this problem with an active device (not my case), you could erase the configuration archive that is preventing Prime to add the new device.

Maybe it is worth to note that the configuration archive that was showing the IP address 192.168.1.1 in the old device, was the last configuration file that Prime was able to fetch from such switch. I guess that if it is not the current configuration running in the device, Prime would allow to add a new device with that IP address, but I'm just guessing here.

Thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers