06-10-2004 12:07 PM - edited 03-02-2019 04:18 PM
I've got a 1721 with a DSL modem connected to the Ethernet interface, which is using PPPoE, for our primary WAN link. I send my default static routes thru that connection. I also have a v.90 card in that router, and have a dialup ISP connection confiugred, with a floating static route thru it for backup. When I disable the PPPoE connection, the router fails over to the Async connection just fine, but I have to actually "shutdown" the PPPoE Dialer interface. If I just unplug the DSL connection, the Dialer interface remains up (spoofing), and it never fails over to the Async connection. Is there any way to make the router detect when the PPPoE session is not working, and thus cause the Dialer interface to go down, so the Async can take over with the floating static route? Here's my config so far (it's a Lab config):
Router#sh run
Building configuration...
Current configuration : 2223 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
group 2
!
crypto isakmp peer address x.x.x.x
set aggressive-mode password *********************
set aggressive-mode client-endpoint user-fqdn *****
!
!
crypto ipsec transform-set XFORM esp-3des esp-md5-hmac
!
crypto map MyMap 1 ipsec-isakmp
set peer x.x.x.x
set transform-set XFORM
set pfs group2
match address 101
!
!
!
interface FastEthernet0
ip address a.a.a.1 255.255.255.0
ip nat inside
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer string 8175551212
dialer-group 1
async mode interactive
ppp chap hostname *****
ppp chap password 0 *****
crypto map MyMap
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username ***** password 0 *****
crypto map MyMap
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Async1 3
no ip http server
no ip http secure-server
ip nat inside source list 102 interface FastEthernet0 overload
!
!
!
access-list 101 permit ip a.a.a.0 0.0.0.255 m.m.m.0 0.0.0.255
access-list 101 permit ip a.a.a.0 0.0.0.255 n.n.n.0 0.0.0.255
access-list 101 permit ip a.a.a.0 0.0.0.255 p.0.0.0 0.255.255.255
access-list 101 deny ip any any
access-list 102 permit ip any m.m.m.0 0.0.0.255
access-list 102 permit ip any n.n.n.0 0.0.0.255
access-list 102 permit ip any p.0.0.0 0.255.255.255
access-list 102 deny ip any any
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
logging synchronous
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
login
!
!
end
Router#
Thanks!
06-10-2004 11:17 PM
Hello,
can you try and add the following to your dialer 1 configuration:
interface Dialer 1
--> backup interface Async 1
This should put Async 1 into spoofing mode, check what happens then when you disconnect the primary link.
Regards,
GP
06-11-2004 07:30 AM
That's not an option on the Dialer interface.
06-11-2004 07:35 AM
Dialer interface will remain up/up spoofin all the time because its a virtual interface.
Designing the backup for PPPoE DSL connection is little tricky. You can configure "backup interface" scheme under the ethernet interface but mostly eth. interface will not go down at all (because its connected to eth. switch) even though PPPoE went down.
So cisco came up with new feature called "Reliable Static Routing Backup Using Object Tracking" which will moniter PPPoE connection interface by continuous ping and if ping fails, it will activate backup method. Visit following link which explains how to configure and troubleshoot for PPPoE
06-11-2004 01:48 PM
That's exactly what I had in mind. Some sort of inverse keepalive thing (like a continuous ping) seems to be the only way this could work. I can't get to that page with my CCO login for some reason tho. I think it requires a higher level of service or something.
I'll see if I can find it somewhere...
Thanks!
06-11-2004 09:38 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide