cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
678
Views
0
Helpful
10
Replies

interVlan between Catalyst 2950 and Router 2600

danhduong
Level 1
Level 1

I have configured 3 vlans (vlan1, vlan2, and vlan3) on 2950 switch and also 3 vlans (vlan1, vlan2 and vlan3) on EtherSwitch Network module on 2600 router. The interface fe0/0 and fe0/1 on Cisco 2600 are already being used for other purpose. How do I configure interVlan between the two.

Cisco 2600 is runing IOS 12.2(11)T11

Catalyst 2950 is running IOS 12.1

Thanks

10 Replies 10

reynaldob
Level 1
Level 1

http://cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

That would guide you on how to use 1 ethernet port on the router connected to the 2950 sw. You would use subinterfaces on the router side to accomodate the different vlans.

hth

bobet

thanks for the reply. The reference shows configuration example on interVLAN on the switch. My question is how to configure interVlan between a switch and 16-port Network module installed on the router. Thanks.

Simply create a 802.1q trunk on the Switch port, and allow vlans 1,2 and 3. Providing the IOS on router supports 802.1q encapsulation, configure subinterfaces for each vlan on the FE port on the router. Remember to configure the native vlan, which is the default vlan for untagged frames (vlan 1 in the following example).

For example:

Switch port configuration:

interface fastethernet 0/1

switchport encapsulation dot1q

switchport trunk native vlan 1

swtichport trunk allowed vlan 1,2,3

switchport mode trunk

Router interface configuration:

interface fastethernet 0/0

speed 100

duplex full

interface fastethernet 0/0.1

encapsulation dot1q 1 native

ip address 192.168.1.0 255.255.255.0

interface fastethernet 0/0.2

encapsulation dot1q 2

ip address 192.168.2.0 255.255.255.0

interface fastethernet 0/0.3

encapsulation dot1q 3

ip address 192.168.3.0 255.255.255.0

dbellaze
Level 4
Level 4

You should be able to configure VLAN interfaces (SVI) to accomplish this.

interface vlan 1

ip address 192.168.1.1 255.255.255.0

no shut

!

interface vlan 2

ip address 192.168.2.1 255.255.255.0

no shut

!

interface vlan 3

ip address 192.168.3.1 255.255.255.0

no shut

!

Set your gateways on the PC's accordingly and you should be good to go.

Daniel

Iam sorry, I guest my question was not clear. I hope the following details will help:

Catalyst 2900 switch configuration:

interface FastEthernet0/1

switchport access vlan 2

no ip address

!

interface FastEthernet0/2

switchport access vlan 2

no ip address

!

interface FastEthernet0/3

switchport access vlan 2

no ip address

!

interface FastEthernet0/4

switchport access vlan 3

no ip address

!

interface FastEthernet0/5

switchport access vlan 3

no ip address

!

interface FastEthernet0/6

switchport access vlan 4

no ip address

!

interface FastEthernet0/7

switchport access vlan 4

no ip address

!

interface FastEthernet0/24

switchport mode trunk

no ip address

!

interface vlan 2

ip address 192.168.2.0 255.255.255.0

!

interface vlan 3

ip address 192.168.3.0 255.255.255.0

!

interface vlan 4

ip address 192.168.4.0 255.255.255.0

Cisco 2600 router (with 16-port EtherSwitch Network module) configuration:

interface FastEthernet1/0

no ip address

!

interface FastEthernet1/1

switchport access vlan 2

no ip address

!

interface FastEthernet1/2

switchport access vlan 2

no ip address

!

interface FastEthernet1/3

switchport access vlan 3

no ip address

!

interface FastEthernet1/4

switchport access vlan 3

no ip address

!

interface FastEthernet1/5

switchport access vlan 4

no ip address

!

interface FastEthernet1/15

switchport mode trunk

no ip address

!

interface vlan 2

ip address 192.168.2.1 255.255.255.0

!

interface vlan 3

ip address 192.168.3.1 255.255.255.0

!

interface vlan 4

ip address 192.168.4.1 255.255.255.0

I connect the port FE1/15 on router to the port FE0/24 on switch. I were not be able to ping from a workstation connect to vlan3 on the router to another workstation connect to vlan2 on the switch. Any idea!

I don't think its a native VLAN issue.

What did you set your default gateway to on the PCs? Make sure they have the IP of the router's VLAN interfacese.

You will also want to verify that the trunk port is up and trunking.

Daniel

allan.thomas
Level 8
Level 8

Ensure that you have configured the native vlan on both the switch and router to be the same. On the switch the default native VLAN is 1, therefore configure the trunk port native vlan on the router be VLAN 1 also.

I were be able to ping from a workstation connect to VLAN3 on the router to another workstation connect to VLAN3 on the switch. But I were NOT be able to ping a workstation connect to VLAN3 on the router to another workstation connect to VLAN2 on the switch.

Make sure that your default gateway on the PC is set to one of these depending on the VLAN. These are the IP's you configured on the router.

interface vlan 2

ip address 192.168.2.1 255.255.255.0

!

interface vlan 3

ip address 192.168.3.1 255.255.255.0

!

interface vlan 4

ip address 192.168.4.1 255.255.255.0

Daniel

Problem solved!

I set the default gateway on the PC connect to the switch to 192.168.2.0 which did not work. After I changed the default gateway to 192.168.2.1 which is the VLAN IP address on the router side and it worked!

Thanks everyone