cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
198
Views
0
Helpful
1
Replies

ISDN backup for relay

abuaqel
Level 1
Level 1

Dear all,

Hi.I have configured a cisco 3640 router to connect to seven 1721 remote routers at remote sites through frame relay and everything is working just fine. I configured the subinterfaces and everything is ok. My problem started when I had to configure a PRI E1 ISDN line to backup the frame relay in case of failure.. I know I should configure the remote router to call the main one but I don't know how to configure the main 3640 router. How do I setup the E1 controller and how should I divide it to subinterfaces? Is it something similar to frame relay DLCIs??! Here is my main router config

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

boot-start-marker

boot-end-marker

!

no network-clock-participate slot 1

no network-clock-participate slot 2

no network-clock-participate slot 3

no network-clock-participate slot 4

no network-clock-participate wic 0

no network-clock-participate wic 1

no network-clock-participate wic 2

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

controller E1 1/0

!

interface FastEthernet0/0

ip address 10.0.0.118 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

interface Serial2/0

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type q933a

!

interface Serial2/0.17 point-to-point

ip address 192.168.30.1 255.255.255.0

frame-relay interface-dlci 17

!

interface Serial2/0.18 point-to-point

ip address 192.168.50.1 255.255.255.0

frame-relay interface-dlci 18

!

interface Serial2/0.19 point-to-point

ip address 192.168.40.1 255.255.255.0

frame-relay interface-dlci 19

!

interface Serial2/0.20 point-to-point

ip address 192.168.20.1 255.255.255.0

frame-relay interface-dlci 20

!

interface Serial2/0.21 point-to-point

ip address 192.168.0.1 255.255.255.0

frame-relay interface-dlci 21

!

interface Serial2/0.22 point-to-point

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 22

!

interface Serial2/0.23 point-to-point

ip address 192.168.60.1 255.255.255.0

frame-relay interface-dlci 23

!

no ip http server

ip classless

ip route 192.168.0.0 255.255.0.0 Serial2/0

!

line con 0

transport preferred all

transport output all

Thanks in advance

1 Reply 1

Hello,

basically, you will need to define dialer interfaces and use those interfaces in the backup interface statement on your frame-relay subinterfaces. I have made a few additions to your configuration (additions are marked with -->) and added Dialer17, try if this works and then add the other dialer interfaces for the other remote sites accordingly:

Let me know if this works, if not, post the configuration again with the additions you have made so far, it might get easier then to see if anything is missing...

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

--> username Remote 17 password xxxx (the password has to be the same on your remote site, with the name of your 3640 router as the username)

!

boot-start-marker

boot-end-marker

!

no network-clock-participate slot 1

no network-clock-participate slot 2

no network-clock-participate slot 3

no network-clock-participate slot 4

no network-clock-participate wic 0

no network-clock-participate wic 1

no network-clock-participate wic 2

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

!

--> isdn switch-type primary-net5 (not sure if this is what is used in Jordan...)

!

controller E1 1/0

-->framing crc4

-->clock source line primary

-->linecode hdb3

-->pri-group timeslots 1-31

!

-->interface Serial0:15

--> no ip address

--> encapsulation ppp

--> dialer pool-member 1 max-link 4

--> dialer pool-member 2 max-link 4

--> dialer pool-member 3 max-link 4

--> dialer pool-member 4 max-link 4

--> dialer pool-member 5 max-link 4

--> dialer pool-member 6 max-link 4

--> dialer pool-member 7 max-link 4

--> isdn switch-type primary-net5

--> no cdp enable

--> ppp authentication chap

--> ppp multilink

!

-->interface Dialer17

--> description For Dialin ISDN Client - Remote1

--> ip unnumbered FastEthernet0/0

--> encapsulation ppp

--> dialer pool 1

--> dialer remote-name Remote1

--> dialer idle-timeout 300

--> dialer-group 1

--> no fair-queue

--> peer default ip address pool DIALIN

--> ppp authentication chap callin

--> ppp multilink

!

interface FastEthernet0/0

ip address 10.0.0.118 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

interface Serial2/0

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type q933a

!

interface Serial2/0.17 point-to-point

--> backup interface dialer 17

ip address 192.168.30.1 255.255.255.0

frame-relay interface-dlci 17

!

interface Serial2/0.18 point-to-point

ip address 192.168.50.1 255.255.255.0

frame-relay interface-dlci 18

!

interface Serial2/0.19 point-to-point

ip address 192.168.40.1 255.255.255.0

frame-relay interface-dlci 19

!

interface Serial2/0.20 point-to-point

ip address 192.168.20.1 255.255.255.0

frame-relay interface-dlci 20

!

interface Serial2/0.21 point-to-point

ip address 192.168.0.1 255.255.255.0

frame-relay interface-dlci 21

!

interface Serial2/0.22 point-to-point

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 22

!

interface Serial2/0.23 point-to-point

ip address 192.168.60.1 255.255.255.0

frame-relay interface-dlci 23

!

no ip http server

ip classless

ip route 192.168.0.0 255.255.0.0 Serial2/0

-->ip route 192.168.30.2 255.255.255.0 dialer 17 250 (this creates a floating static route to the Remote17 site, not sure if the IP address is correct, change it accordingly otherwise)

--> dialer-list 1 protocol ip permit

--> ip local pool DIALIN 10.0.0.150 10.0.0.166

!

line con 0

transport preferred all

transport output all

Regards,

Georg