cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
248
Views
0
Helpful
1
Replies

ISP Connection via analog modem connected to the aux port

daysleeper
Level 1
Level 1

Hi to all,

I have a 1751 and i want connect it to internet using a 56k faxmodem of us robotics, i have configured the router with the following config:

ip subnet-zero

no ip domain-lookup

ip routing

modemcap entry usr_sportster:FD=&F:AA=S0=1:CD=&C1:DTR=&D2:HFL=&H3&R2:SPD=&B0:BCP=&K0:NER=&M0:NEC=E0:NRS=Q1

!

interface Dialer 1

description connected to Internet

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer string ispnumber

dialer hold-queue 10

dialer-group 1

pulse-time 3

ppp authentication chap pap callin

ppp chap hostname username

ppp chap password password

ppp pap sent-username username password password

no cdp enable

!

interface FastEthernet 0/0

no shutdown

description connected to 192.168.0.0

ip address 192.168.0.1 255.255.255.0

keepalive 10

!

interface Async 5

no shutdown

description connected to Internet

no ip address

async mode dedicated

dialer rotary-group 1

!

interface Ethernet 0/0

no shutdown

description connected to 172.16.0.0

ip address 172.16.0.1 255.255.255.0

keepalive 10

!

! Dialer Control List 1

!

dialer-list 1 protocol ip permit

access-list 1

ip classless

!

! IP Static Routes

ip route 0.0.0.0 0.0.0.0 Dialer 1

no ip http server

!

line console 0

exec-timeout 0 0

password 31081974

login

!

line vty 0 4

password 31081974

login

!

line aux 0

autoselect ppp

modem InOut

modem autoconfigure type usr_sportster

transport input all

stopbits 1

speed 56000

flowcontrol hardware

!

end

The router establish connection when from the pc i open the browser but i don't see any packet routed by the router and on the console terminal appear this message:

00:08:35: %PPP-3-AUXFAST: Fast-switching to aux port, packet dropped.

Where is the problem? And how i can disable the modem speaker? i have found the at command but how i can apply this in the init string of the modem?

Thanks and Best Regards.

Carlo S.

1 Reply 1

makchitale
Level 6
Level 6

Fastswitching is not supported on slower interfaces like aux ports. Hence disabling fast switching using the command 'no ip route-cache' in the dialer

interface/ async 5 should solve this problem.

Thanks, Mak