Hello,
you do not need another subinterface, just define an access list with the addresses you want to have translated, and those that are not in the access list will not be translated. Here is an example in which you have assigned a public IP address yo your WAN interface, and you have two sets of clients, one set with addresses from the range 192.168.1.0/24, and the second set with public addresses from the range 212.136.1.0/29. You need to assign a secondary address to your LAN interface, in order to cover both ranges:
interface Ethernet0
ip address 212.136.1.1 255.255.255.248
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface dialer 1
ip address negotiated
or
ip address dhcp
!
ip nat outside
!
access-list 1 permit 192.168.0
!
ip nat inside source list 1 interface dialer 1 overload
Let me know if this is not working.
Regards,
Georg