01-09-2002 01:53 PM - edited 03-01-2019 07:58 PM
192.168.21.xxx
---E----
|
|
----ROUTER A-----S0
|(P to P)
|
----ROUTER B-----S1
|
|
---E----172.20.1.xxx
|
|
----ROUTER C----- (Do Not have access) 52.99.xxx.xxx
I need help in how to make 192 series to map to 172 series to route to "router c" (172 series have wide open access) and have access to 52 series server. I guess NATing has to be done in "router b" but how?
Appericate you help and time.
01-09-2002 02:21 PM
You could do:
interface serial 1
ip address ??.??.??.??
ip nat inside
!
interface ethernet 1
ip address 172.20.1.xxx 255.255.255.0
ip nat outside
!
ip nat inside source list 1 pool nat-pool
access-list 1 permit 192.168.0.0 0.0.255.255
ip nat pool nat-pool 172.20.1.128 172.20.1.254 netmask 255.255.255.0
I think I understood the problem correctly. Router B should NAT 192.168 addresses to 172.20.
Mick.
01-10-2002 06:00 AM
You got it buddy. Yup 100% right. Thats what I'm trying to achieve. I belive I should put the configuration in router B which I did but no use. I still can't ping to 52.99.xxx.xxx. When I do the trace route its going on to public route(s1) to my ISP(Interoffice T1).
What should I do now?
01-10-2002 06:23 AM
Do you have a route on router B to 52.99.x.x that has a next hop of Router C?
Mick.
01-10-2002 07:10 AM
I don't think so.
01-10-2002 07:16 AM
I don't think so.
do I need to add like this
ip route 52.99.xxx.xxx 255.255.255.255 FastEthernet0 172.20.1.254
01-10-2002 07:18 AM
close
ip route 52.99.0.0 255.255.0.0 172.20.1.254
Mick.
01-10-2002 07:44 AM
Getting RTO's now when i ping 52.99.xxx.xxx address from 192.168.21.xxx machine (hops to S1(router b) and then i get RTO's). Before we added ip route used to go to my ISP.
01-10-2002 07:49 AM
Does router B have a route back to 192.168?
Mick.
01-10-2002 07:59 AM
does this line make sense
ip route 192.168.21.0 255.255.255.0 s0(router A ISP ip address, interoffice)
01-10-2002 08:03 AM
Yes. After Router B NATs the packet back to 192.168, it needs to know where to send it.
Mick.
01-10-2002 08:16 AM
ip route for 192.168 already exsists but still i get this RTO's
Appericate your time and help. Thank you.
01-10-2002 08:18 AM
01-10-2002 08:23 AM
thanx a lot. thank you.
01-10-2002 03:12 PM
Problem sloved by adding below access-list to do reset of NATing
access-list 1 permit 172.22.0.0 0.0.255.255
(172.22.xxx.xxx interoffice point-to-point)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide