cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
817
Views
0
Helpful
4
Replies

Port Based Rate Limiting.

bmannella
Level 1
Level 1

Hi, i operate a colo center and i am using a 3550-EMI to aggregate customer switchs. But i need to be able to limit bandwidth in BOTH directions on the switch port. I have managed to get this to work on outgoing but i can't get it to work both ways at the same time. Any ideas?

Current configuration : 3523 bytes

!

! No configuration change since last restart

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname 3550

!

enable secret

enable password

!

clock timezone EST -5

ip subnet-zero

ip routing

!

ip domain-name g3tech.net

ip name-server 129.250.35.250

ip ssh time-out 120

ip ssh authentication-retries 3

mls qos

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

class-map match-all iptraffic

match access-group 101

!

!

policy-map ratemap1meg

class iptraffic

police 1000000 8192 exceed-action drop

!

!

!

Port Config

----------------

interface FastEthernet0/6

description Uplink to tblive

switchport mode dynamic desirable

speed 100

duplex full

service-policy input ratemap1meg

4 Replies 4

rfroom
Cisco Employee
Cisco Employee

Can you post the access-group 101 configuraton.

access-list 101 permit ip any any

b-hart
Level 1
Level 1

Have you tried using QOS to acheive this. The config below will prevent packets being dropped. They will instead be put into a lower priority Q. This is a bit more friendly.

hostname RATELIMIT_SWITCH

!

ip subnet-zero

ip routing

!

mls qos map policed-dscp 48 to 16

Modifies the policed DSCP QoS map, so the

traffic is marked down from IP precedence 6 to 2.

mls qos

Globally enables QoS.

!

class-map match-all ALL

match access-group 101

Defines the ACL to select traffic.

!

policy-map RATELIMIT

class ALL

set ip precedence 6

Marks all the class traffic with the IP precedence 6.

police 1000000 8000 exceed-action policed-dscp-transmit

Polices down to 1 Mbps and marks down according to the QoS map defined earlier

!

interface FastEthernet0/1

description ***** LINK TO SDP *****

no switchport

ip address 20.0.0.2 255.0.0.0

!

interface FastEthernet0/2

description ***** LINK TO 1Mbit LIMITED SITE *****

no switchport

ip address 40.0.0.2 255.0.0.0

mls qos monitor dscp 8 16 24 32

Turns on DSCP statistics for monitoring.

service-policy input RATELIMIT

Applies the QoS policy to an interface.

!

access-list 101 permit ip any any

Defines the traffic class.

!

will this alow me to police both input and output the same interface?

So will this work to limit the uploads and downloads?

interface FastEthernet0/2

description ***** LINK TO 1Mbit LIMITED SITE *****

no switchport

ip address 40.0.0.2 255.0.0.0

mls qos monitor dscp 8 16 24 32

Turns on DSCP statistics for monitoring.

service-policy input RATELIMIT

service-policy output RATELIMIT

Applies the QoS policy to an interface.