ATTENTION: We are currently working an issue with posting. Thank you for your patience while we work on a resolution.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
235
Views
0
Helpful
1
Replies

QoS question

julxu
Level 1
Level 1

for VoIP, we do:

class-map match-any EF

description Expedited Forwarding PHB

match access-group name PriorityPBX

class-map match-any Default

description Default no PBX traffic

match access-group name NotPBX

!

!

policy-map SETDSCP

class EF

set dscp ef

class Default

set dscp default

!interface vlan123

service-policy input SETDSCP

!

ip access-list extended PriorityPBX

permit ip 10.1.0.0 0.0.255.255 10.1.0.0 0.0.255.255

deny any any

ip access-list extended NotPBX

permit ip any any

question:

1. since my purpose is to make VoIP traffic at higher priority,so the class EF is nessiciry, but, do I need class Default?

2. if I do need class Default, and the access-list is permit ip any any, do I have any performance issue?

3. Could I make drop packets towards 0% when congestion on WAN? (or how can I tune the my sup720 to make sure only VoIP traffic go pass when there is WAN congestion occurred)

4. Do I need other thing be considered related to it (or if miss any important configure related to this)

Any comments will be appreciated

Thanks in advance

1 Accepted Solution

Accepted Solutions

thisisshanky
Level 11
Level 11

Is this configuration on the sup 720 ? If yes, your policy-map is only marking the packets with DSCP bits. You do not need to mark the default-class in the sup 720. You should also be marking VOIP control traffic with DSCP value AF31 (say if using H323, TCP port 1720 should be matched)

The marked packets will help other Cisco equipments (WAN routers or other switches) to prioritize voip over data.

On the WAN edge routers you should be prioritizing traffic as follows.

Policy-map Test

class VOIP-payload

priority 512

class VOIP-control

priority 64

class class-default

fair-queue 128

int s0/0

service-policy output Test

class VOIP-payload

match ip dscp ef

class VOIP-control

match ip dscp af31

Do not use WRED to tail drop traffic on VOIP traffic. YOu can definitely use WRED on data if your applications support retransmission.

In addition to this you can use WRR - weighted round robin on switch ports. Each switch port has 4 queues which can be used to prioritize outgoing packets on that port. Higher priority (DSCP) packets can be forwarded before lower priority (data packets). You can also do tail drop on data packets. WRR will ensure QOS within the LAN.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

View solution in original post

1 Reply 1

thisisshanky
Level 11
Level 11

Is this configuration on the sup 720 ? If yes, your policy-map is only marking the packets with DSCP bits. You do not need to mark the default-class in the sup 720. You should also be marking VOIP control traffic with DSCP value AF31 (say if using H323, TCP port 1720 should be matched)

The marked packets will help other Cisco equipments (WAN routers or other switches) to prioritize voip over data.

On the WAN edge routers you should be prioritizing traffic as follows.

Policy-map Test

class VOIP-payload

priority 512

class VOIP-control

priority 64

class class-default

fair-queue 128

int s0/0

service-policy output Test

class VOIP-payload

match ip dscp ef

class VOIP-control

match ip dscp af31

Do not use WRED to tail drop traffic on VOIP traffic. YOu can definitely use WRED on data if your applications support retransmission.

In addition to this you can use WRR - weighted round robin on switch ports. Each switch port has 4 queues which can be used to prioritize outgoing packets on that port. Higher priority (DSCP) packets can be forwarded before lower priority (data packets). You can also do tail drop on data packets. WRR will ensure QOS within the LAN.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Review Cisco Networking for a $25 gift card