cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
362
Views
5
Helpful
1
Replies

Rip V2 problem

acbennyma
Level 1
Level 1

I try to perform a Rip v2 lab, it seems success that 2620 can learn some network

of from 1720 fast ethernet0, but I don't know why only 10.0.0.0/24 can't be learned.

do you know what's the problem ?

Pc(192.168.0.1) -> 1720 -> 2620 -> Nat router(192.168.169.254)

1720#sh ru

!

ip subnet-zero

!

!interface FastEthernet0

ip address 192.168.0.80 255.255.255.0 secondary

ip address 172.0.0.5 255.255.255.252 secondary

ip address 10.0.0.1 255.255.255.0 secondary

ip address 172.0.0.193 255.255.255.192

speed auto

!

interface Serial0

ip address 172.0.0.2 255.255.255.252

ip rip triggered

!

router rip

version 2

timers basic 30 180 0 240

network 10.0.0.0

network 172.0.0.0

network 192.168.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

no ip http server

!

1720#sh ip route

172.0.0.0/16 is variably subnetted, 3 subnets, 2 masks

C 172.0.0.192/26 is directly connected, FastEthernet0

C 172.0.0.4/30 is directly connected, FastEthernet0

C 172.0.0.0/30 is directly connected, Serial0

10.0.0.0/24 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, FastEthernet0

C 192.168.0.0/24 is directly connected, FastEthernet0

R 192.168.169.0/24 [120/1] via 172.0.0.1, 00:47:26, Serial0

S* 0.0.0.0/0 is directly connected, Serial0

2620#sh ru

!ip subnet-zero

!

interface Ethernet0/0

ip address 192.168.169.252 255.255.255.0

ip nat outside

!

interface Serial0/0

description connect to RouterB

ip address 172.0.0.1 255.255.255.252

ip nat inside

ip rip triggered

no fair-queue

clockrate 4000000

!

router rip

version 2

timers basic 30 180 0 240

network 172.0.0.0

network 192.168.169.0

!

ip nat inside source list 1 interface Ethernet0/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.169.254

no ip http server

!

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 10.0.0.0 0.0.0.255

!a

line con

2620# sh ip route

172.0.0.0/16 is variably subnetted, 3 subnets, 2 masks

R 172.0.0.192/26 [120/1] via 172.0.0.2, 00:49:10, Serial0/0

R 172.0.0.4/30 [120/1] via 172.0.0.2, 00:49:10, Serial0/0

C 172.0.0.0/30 is directly connected, Serial0/0

R 192.168.0.0/24 [120/1] via 172.0.0.2, 00:49:10, Serial0/0

C 192.168.169.0/24 is directly connected, Ethernet0/0

S* 0.0.0.0/0 [1/0] via 192.168.169.254

1 Reply 1

Hello,

on your 1720 router, turn off auto-summary under the RIP process, this will allow the 10.0.0.0/24 subnet to be advertised as a non-classfull network:

1720#

router rip

version 2

timers basic 30 180 0 240

network 10.0.0.0

network 172.0.0.0

network 192.168.0.0

--> no auto-summary

Regards,

Georg

www.solutionfinders.nl