01-14-2005 12:11 AM - edited 03-02-2019 09:04 PM
I want to establish a VPN within another LAN. I have 2 routers for each end that I want to configure with different IP's than the network they will plug into. Eventually they will be configured for VPN.
They will attach to a nework 10.xx.xx.xx/24 but their LAN ports are 192.xx.xx.xx/24.
I have them configured like this:
RouterA-F0/1 10.1.1.5/30
routerA-F0/0 192.168.1.1/24
routerb-f0/1 10.1.1.6/30
routerb-f0/0 192.168.2.1/24
Can you configure the ethernet ports on a router to route between each other?
i set up a static route like this:
routerA- ip route 192.168.2.0 255.255.255.0 10.1.1.6
routerB- ip route 192.168.1.0 255.255.255.0 10.1.1.5
I have the routers set up on a test bench with a cross-over cable connecting them at the f0/1 interface on each.
I cannot ping thorugh the routers to the other side.
I hope this is clear. Its hard to explain for me.
I am trying to test if i can route over a network with routers that have a different IP scheme than the network.
At this point they are not even on the network just my test bench and i still cannot ping through.
Thanks for any help
01-14-2005 02:07 AM
Hi,
The routing looks fine. But lacking a bit on the details.
U mentioned that u can't ping through the routers. Are u referring to PCs connected to the LAN segment of the routers? Or u were referring to pinging executed on the routers?
Pls also provide the config for the both routers. A show run would be good.
01-14-2005 08:04 PM
I cannot ping either from inside the router or from a pc on the LAN segment. By LAN segment i mean the switch i have on my desk. Its all set up on my desk like this computer-->switch-->routerA--><--routerB-->switch-->computer.
the routers have a x-over cable connecting them in int f0/1 of each.
Here is the show run. On of the routers will not accept the static route. When I enter it, it seems to take it but when I sh IP route its not there.
Thanks for taking a look at my configs.
Is it even possible to have 2 networks on each FastE interface and route between them? or do I HAVE to use a serial int for a WAN?
ROUTERA
Current configuration : 1127 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname XXXXX1
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default none
enable secret xxxx
enable password XXXXXX
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description connected to XXXXX1
ip address 192.168.2.1 255.255.255.0
no keepalive
duplex auto
speed auto
no cdp enable
!
interface Serial0/0
no ip address
shutdown
no cdp enable
!
interface FastEthernet0/1
ip address 10.1.1.6 255.255.255.252
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
!
interface Serial0/2
no ip address
!
interface Serial0/3
no ip address
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.1.1.5 permanent
no ip http server
!
!
dial-peer cor custom
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.1.1.5 permanent
no ip http server
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
exec-timeout 15 0
password XXXXX1
logging synchronous
transport input none
line aux 0
line vty 0 4
password XXXXX1
logging synchronous
!
end
RouterB
Current configuration : 1144 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname XXXXX2
!
logging rate-limit console 10 except errors
enable password XXXXX2
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
!
!
call rsvp-sync
!
interface FastEthernet0/0
description connected to XXXXX2
ip address 192.168.1.1 255.255.255.0
no keepalive
duplex auto
speed auto
no cdp enable
!
interface Serial0/0
no ip address
shutdown
no cdp enable
!
interface FastEthernet0/1
ip address 10.1.1.5 255.255.255.252
duplex auto
speed auto
no cdp enable
!
interface Serial0/1
no ip address
shutdown
no cdp enable
!
interface Serial0/2
no ip address
shutdown
no cdp enable
!
interface Serial0/3
no ip address
shutdown
no cdp enable
!
ip classless
ip route 192.168.2.0 255.255.255.0 10.1.1.6 permanent
no ip http server
!
dial-peer cor custom
!
!
!
!
!
line con 0
exec-timeout 15 0
password XXXXX2
logging synchronous
login
transport input none
line aux 0
line vty 0 4
password XXXXX2
logging synchronous
login
!
no scheduler allocate
end
01-14-2005 08:17 PM
what does "show ip int brief" says?
is the fa port on the routers up?
If the router is not taking the static route chances are the interface assoctiate with the rout is not up....
from your computer behind router A, can you ping : 192.168.2.1? 10.1.1.5? 10.1.1.6? 192.168.1.1?
01-14-2005 09:54 PM
As rightly said by someone, check the interface status also the physical connectivity. Make sure that the interfaces are up and connections are proper and also check the default gateway on the PC.
01-14-2005 10:22 PM
all the interfaces are up.
from the PC on each LAN segment I can ping the router interface.
On the router that will not take the static route I cannot ping the other interface on the same router nor any interface on the other router.
note: when consoled into the router I cannot ping the other router.
01-14-2005 10:39 PM
Hello,
just a thought, but are you sure that your cross cable is indeed a cross cable (pins 1 & 3 and 2 & 6 reversed) ?
Also, you could try and set the speed and duplex settings on both Fa0/1 ports to fixed 100/Full, see if that makes a difference:
interface FastEthernet0/1
speed 100
duplex full
Regards,
GP
01-14-2005 11:53 PM
which router is the one that don't take the static route?
Also from your config it shows:
interface FastEthernet0/1
ip address 10.1.1.6 255.255.255.252
shutdown
duplex auto
speed auto
Looks like your 10.1.1.6 is still in a shutdown mode?
01-15-2005 02:20 AM
YOU'VE GOT TO BE KIDDING ME!!!!!
How did i miss that.
I know for a fact that was not the problem before. i think my routing was messed up and during my troublshooting of that I took down the interface.
When I sorted out the routing i forgot to bring the int back up.
Thanks for the sharp eye.
It works perfectly now.
01-15-2005 04:20 AM
it happens to me all the time..... :D
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide