cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
556
Views
1
Helpful
4
Replies

Secure Client Network adapter MTU set to 1?

anfare
Level 1
Level 1

I'm trying to track down why our users at our SD-Wan location are only getting 2-3Mbps file copy/iperf speeds from their Spoke to our hub. For testing, I'm VPN'ing into the spoke location and am seeing the same things. While troubleshooting, many mentions of MTU have come up and unfortunately none of the changes have helped. I did notice, though, strangely that when I connect the VPN and then look at the ipv4 (not using ipv6 at all) settings for the adapter, the MTU is set to 1 for some reason:

Screenshot 2024-04-26 151347.png

I've tried changing it to auto/1500/1300 with no help, but why would this be happening? The spoke is MX-68 and Hub MX-95 all running latest firmware. Secure Client is Version 5.1.2.42.

1 Accepted Solution

Accepted Solutions

pman
Spotlight
Spotlight

Hi,

Did you mean the value 1 under "Interface metric"?
If so, then it is not the MTU value.

and I apologize if I misunderstood you.
To edit the MTU value in Windows you can do it under the network settings.

cap.PNG

Here is an example:
https://answers.microsoft.com/en-us/windows/forum/all/how-to-change-mtu-settings-in-windows-10/5c36c250-a0e8-47ee-b01c-de22139dc297

View solution in original post

4 Replies 4

pman
Spotlight
Spotlight

Hi,

Did you mean the value 1 under "Interface metric"?
If so, then it is not the MTU value.

and I apologize if I misunderstood you.
To edit the MTU value in Windows you can do it under the network settings.

cap.PNG

Here is an example:
https://answers.microsoft.com/en-us/windows/forum/all/how-to-change-mtu-settings-in-windows-10/5c36c250-a0e8-47ee-b01c-de22139dc297

Thanks, I did not realize that was not setting the MTU. I see now how it is set thanks to your link. It comes up as 1 by default for the Secure Connect adapter which is higher than the highest setting the document, do either way, it doesn't look like this is the culprit. 

Thanks for sharing.

Hello,

I doubt that incorrect MTU settings are the problem, but either way, try a ping test with different packet sizes and check at which value you get a successful response:

C:\Users\>ping -l 1474 -f www.cisco.com

Pinging e2867.dsca.akamaiedge.net [23.200.188.102] with 1474 bytes of data:
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

Ping statistics for 23.200.188.102:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\>ping -l 1472 -f www.cisco.com

Pinging e2867.dsca.akamaiedge.net [23.200.188.102] with 1472 bytes of data:
Reply from 23.200.188.102: bytes=1472 time=10ms TTL=57
Reply from 23.200.188.102: bytes=1472 time=10ms TTL=57
Reply from 23.200.188.102: bytes=1472 time=9ms TTL=57
Reply from 23.200.188.102: bytes=1472 time=9ms TTL=57

Ping statistics for 23.200.188.102:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 9ms, Maximum = 10ms, Average = 9ms

Thanks, yes, I have run this test on all of the machines involved and everything is set correctly but I'm still only getting ~3Mbps file transfer/iperf speeds.