03-29-2005 05:30 AM - edited 03-02-2019 10:17 PM
I'm wondering if it's possible to configure a router to respond to all ICMP traceroute packets from the specified IP address, i.e. from its loopback interface.
The idea is to simplify network management and troubleshooting. A router should reply from the specified IP address, no matter what what interface ICMP traceroute packet is in or out.
03-29-2005 09:07 AM
Hello,
yes this is possible. Configure the following on your routers, this will cause the router to respond with the IP address of the Loopback 0 interface to traceroutes (obviously the addresses chosen are arbitrary):
interface Loopback0
ip address 160.12.1.1 255.255.255.0
ip nat outside
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip nat inside
ip policy route-map TRACEROUTE
!
route-map TRACE permit 10
match ip address 100
set interface Loopback1
!
route-map TRACEROUTE permit 10
set interface Loopback0
!
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any port-unreachable
!
ip nat inside source list 100 interface Loopback0 overload
!
ip local policy route-map TRACE
So basically you need to create an additional Loopback interface on your routers to serve as an inside NAT interface, the address of that Loopback interface is arbitrary.
HTH,
GP
03-29-2005 08:21 PM
Georg,
Thank you for the reply.
Are there any ways to accoplish this w/o using policy routing?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide