cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
422
Views
0
Helpful
2
Replies

VLAN Routing

patrick.hurley
Level 3
Level 3

Can anyone point me to a configuration example for ethernet subinterfaces off a 3600 series router to support multiple vlans from a number of 3548s?

2 Replies 2

vinodgupt
Level 1
Level 1

1) You have to have fast ethernet link

2) Don't assign any encapsulation and IP address

3) create subinterface with VLAN no.

4) assign encapsulation as ISL

5) make routing enable

zaushnyr
Level 1
Level 1

You'll need an FastEthernet Network Module and probably Enterprise feature set software. The router may only support ISL encapsulation as well...just make sure your switch is set to ISL. Here's an example from a Gigabit router anyway...hope it helps. Disregard the IRB.

interface Port-channel1

description ### Trunk Channel Interface ###

no ip address

no ip redirects

no ip directed-broadcast

no ip route-cache cef

no ip route-cache

no ip mroute-cache

hold-queue 300 in

!

interface Port-channel1.1

description ### VLAN 1 Virtual Router Interface ###

encapsulation dot1Q 1 native

no ip redirects

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

bridge-group 1

!

!

interface Port-channel1.2

description ### VLAN 2 Virtual Router Interface ###

encapsulation dot1Q 2

ip address 172.16.2.3 255.255.255.0

ip helper-address 192.168.1.63

no ip redirects

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

standby 2 priority 100 preempt

standby 2 ip 172.16.2.1

!

!

interface GigabitEthernet3

description *** Virtual Trunk Interface ***

no ip address

no ip directed-broadcast

no negotiation auto

channel-group 1

!

interface GigabitEthernet4

description *** Virtual Trunk Interface ***

no ip address

no ip directed-broadcast

no negotiation auto

channel-group 1

!

!

interface BVI1

ip address 192.168.1.2 255.255.255.0

no ip redirects

no ip directed-broadcast

ipx network 111

standby 1 priority 110 preempt

standby 1 ip 192.168.1.1

!

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 1 route ipx