cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
769
Views
0
Helpful
4
Replies

EtherChannel and Vlan trunk

yong.lee
Level 1
Level 1

I am trying to have 3 group of 4 GigE ports on the 3560G as a etherchannel and connect to 4 dells.

On gi0/7 - 10 the trunk config seems to work but I am not able to route between the switches. Here is the config ...

Can anyone take a look tell me what's missing? Much appreciated!

Building configuration...

Current configuration : 3422 bytes

!

! Last configuration change at 00:35:24 UTC Sat Jul 9 2005

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cisco_switch_b

!

enable secret xxxx

enable password xxx

!

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface Port-channel1

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/1

description To Internet Router

no switchport

ip address 10.1.1.2 255.255.255.0

ip helper-address 10.1.1.8

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

description To Dell_switch_1

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/11

description To Dell_switch_2

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/15

description To Dell_switch_3

switchport access vlan 7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/17

switchport access vlan 7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport access vlan 7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

no ip address

shutdown

!

interface Vlan5

ip address 10.1.5.1 255.255.255.0

!

interface Vlan6

ip address 10.1.6.1 x.x.255.0

ip helper-address 10.1.5.7

!

interface Vlan7

ip address 10.1.7.1 x.x.x.0

ip helper-address 10.1.5.7

!

ip default-gateway 10.1.1.1

ip classless

ip http server

!

access-list 100 permit ip host 0.0.0.0 host 255.255.255.255

access-list 100 permit udp host 10.1.5.1 host 10.1.5.7 eq bootps

access-list 100 permit udp host 10.1.5.1 host 10.1.5.7 eq bootpc

access-list 100 permit udp host 10.1.5.7 host 10.1.5.1 eq bootps

access-list 100 permit udp host 10.1.5.7 host 10.1.5.1 eq bootpc

access-list 100 permit ip host 0.0.0.0 host 255.255.255.0

!

control-plane

!

!

line con 0

exec-timeout 0 0

line vty 0 4

password xxx

no login

line vty 5 15

password xxx

no login

!

ntp server 10.1.5.7

end

4 Replies 4

ankurbhasin
Level 9
Level 9

Hi Yong,

Config seems to be ok. Can you please explain what exactly is your problem.

"You are not able to route between the switches"-- Please explain what you are trying to access and from where so that problem can be better analyse.

Also I see ip routing is been enabled so it should route between all the 3 vlans. Just check your "sh ip route" and you should be able to see all the 3 networks.

Regards,

Ankur

amit-singh
Level 8
Level 8

Hi Yong,

Please paste a N/W digram to get a more clear picture of the problem.

The possibilities here could be :

1. Access-list is stopping the traffic ( But I see that is not being applied anywhere )

2. Ip routing is not defined ( Configs teels that its being enabled.

3. Trunk or the access ports configuration is diffrent.

Also, just want to tell you that, Using the line " access-list 100 permit ip host 0.0.0.0 host 255.255.255.255 " I think you are trying to permit all the hosts to talk to any other host. But that's a wrong way for defining the ACL. I would suggest you to use the folliwng :

access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255

or

access-list 100 permit ip any any

or

ip access-list extended ABC

permit ip host 0.0.0.0 host 0.0.0.0

Please paste the digram and let us know that from which switch you are trying to ping the host on other switch.

regards,

-amit singh

michael_davis
Level 4
Level 4

It looks like you've got 'switch access vlan 5' to place untagged (native) frames from each Dell into Vlan 5 on the Catalyst.

Is this assumption correct? If so, that's the problem. 'access vlan' only comes into effect if port is _not_ trunking. Use 'switch trunk native vlan 5' instead.

If this assumption is wrong, 'access vlan' has no effect. Please describe the Dell configuration with regard to trunking, vlans, port vlan assignment.

Here is an example to configure EtherChannel:

Cisco Catalyst 3560 Switch Configuration

Set MDIX automatic – To enable cisco catalyst to accept cross cable and straight cable connection

# config t

# int range g0/1 – 28

# switchport mode access - Configure Cisco catalyst to normal switch port

# speed auto

# duplex auto

# mdix auto

# end

# show controllers Ethernet-controller

# copy running-config startup-config

Configure Etherchannels – support redundancy and network load balancing

# config t

# int range g0/23 – 24

# switchport mode access

# switchport mode vlan 1

# channel-group 5 mode active

# exit

Configure Etherchannels load balancing

# config t

# port-channel load-balance src-dst-mac

# exit

Configure IP Address:

# config t

# int vlan 1

# ip address 10.xx.xx.xx 255.255.252.0

# ip default-gateway 10.xx.xx.1

# config t

# int range g0/19-20

# channel-group 2 mode active

# config t

# int range g0/17-18

# channel-group 3 mode active

# channel-group mode 3 desirable

# int port-channel 3

# switchport mode access

# config t

# int range g0/15-16

# channel-group 4 mode active

# show etherchannel summary – to check Etherchannel port status

Regards,

Junhan

IT Specialist

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: