cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1168
Views
0
Helpful
5
Replies
mha_46
Beginner

Static route

Hello ,

in the topology below i need to creat 2 static routes

1-between BSC switch(L3) ->BTS1 L3 switch

2-BSC->BTS L3 switches

i need to pass Vlans from that switches , so the BSC switch outbound port need to be a trunk,

is it possible to have an ip address for a trunk switchport ?

how can i transmit the traffic in Vlan 100 to BTS1, and the traffic in Vlan200 to BTS2 ?

thanks in advance for your answers

BR

static route.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

here totaly config - undersand each section make test it :

 

BSC switch

Create VLAN 100

interface FastEthernet0/1(connected to BSC PC)
switchport
switchport mode access
switchport access vlan 300 ----------Create a New VLAN 192.168.100.0/24 IP addresss
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 0090.2b24.4001
ip address 192.168.3.1 255.255.255.0( i change it from your proposition cause the subnet already exist)
!
interface Vlan200
mac-address 0090.2b24.4002
ip address 192.168.2.1 255.255.255.0
!
interface Vlan300
mac-address 0090.2b24.XXXXX
ip address 192.168.100.1 255.255.255.0
ip classless

no ip route 192.168.1.0 255.255.255.252 192.168.3.2
no ip route 192.168.1.4 255.255.255.252 192.168.2.2

 

BTS1 switch
============

interface FastEthernet0/1(connected to BTS1 pc) ( Same config go all the device connect to PC )
switchport
switchport mode access
switchport access vlan 100
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 000c.cf6c.8d01
ip address 192.168.3.2 255.255.255.0
!
no interface Vlan200 ==================== ( you do not need this)

ip default-gateway 192.168.3.1
ip classless
no ip route 192.168.100.0 255.255.255.0 192.168.3.1 << not sure where this route - if this Layuer 2 you do not need this

 

BTS2 switch

interface FastEthernet0/1(connected to BTS2 PC) ==============This should be access port.
switchport
switchport mode access
switchport access vlan 200
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan200
mac-address 0001.648d.4501
ip address 192.168.2.2 255.255.255.0
!
ip default-gateway 192.168.2.1
ip classless
no ip route 192.168.100.0 255.255.255.0 192.168.2.1


=========================================

L2 switch

Create VLAN 100 and 200 here

interface FastEthernet0/1
switchport trunk allowed vlan 100,200
switchport mode trunk
!

========= Same config you need to do where otehr switches connected

interface FastEthernet0/X ---BTS1 connected
switchport trunk allowed vlan 100,200
switchport mode trunk
!
interface FastEthernet0/X ---BTS2 connected
switchport trunk allowed vlan 100,200
switchport mode trunk

 

interface Vlan1
no ip address
shutdown
!
no interface Vlan100
!
no interface Vlan200

 

===============

 

Post output still not working : ( from all device)

 

show run

show ip interface brief

show ip route

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

5 REPLIES 5
balaji.bandi
VIP Master

As per the Diagram your BSC work as Core having Layer 3 Interface for VLAN 100 and VLAN 200, so it take care of routing VLAN 100 and VLAN 200,

 

Other switches act as Just layer 2, so config Trunk port allow the VLAN.

 

high level config should work.


VLAN 100,200

ip routing

interface GigabitEthernet x/x -- change this port towards BTS1 and BTS2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 100,200
!
interface Vlan100
ip address 192.168.1.1 255.255.255.0
no shutdown
!
interface Vlan200
ip address 192.168.2.1 255.255.255.0
no shutdown


!

BTS1


VLAN 100

!
interface GigabitEthernet x/x
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 100
!
interface Vlan100
ip address 192.168.1.2 255.255.255.0 <-- only for manangement
no shutdown
!
!
ip default-gateway 192.168.1.1

BTS2


VLAN 200

!
interface GigabitEthernet x/x
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 200
!
!
interface Vlan200
ip address 192.168.2.2 255.255.255.0 <-- only for manangement
no shutdown
!
ip default-gateway 192.168.2.1

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

thanks very much for your feed back

 

do you mean i don't need to have static routes ? i want to avoid giving ip address to BTS cause i have 200 unit to add to the topology,is there another way to do it ?

ps:i tried with your proposition in packet tracer but the ping between BTS and bsc failed

 

BR

I am not PT user, if you can post all the devices show run (i can look and help you).

 

Also give information what interfaces connected between BTS to BSC switches.

 

as mentioned above show run also post below output from your devices.

 

show run

show ip interface brief

show ip route

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

thanks again for your precious help , the bsc switch is connected to the BTS switch via microwave , but it should be transparent

below the sh run devices:

 

BSC switch

interface FastEthernet0/1(connected to BSC PC)
no switchport
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 0090.2b24.4001
ip address 192.168.3.1 255.255.255.0( i change it from your proposition cause the subnet already exist)
!
interface Vlan200
mac-address 0090.2b24.4002
ip address 192.168.2.1 255.255.255.0
!
ip classless
ip route 192.168.1.0 255.255.255.252 192.168.3.2
ip route 192.168.1.4 255.255.255.252 192.168.2.2

 

BTS1 switch

interface FastEthernet0/1(connected to BTS1 pc)
no switchport
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 000c.cf6c.8d01
ip address 192.168.3.2 255.255.255.0
!
interface Vlan200
mac-address 000c.cf6c.8d02
no ip address
!
ip default-gateway 192.168.3.1
ip classless
ip route 192.168.100.0 255.255.255.0 192.168.3.1

 

BTS2 switch

interface FastEthernet0/1(connected to BTS2 PC)
no switchport
ip address 192.168.1.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan200
mac-address 0001.648d.4501
ip address 192.168.2.2 255.255.255.0
!
ip default-gateway 192.168.2.1
ip classless
ip route 192.168.100.0 255.255.255.0 192.168.2.1

 

L2 switch

interface FastEthernet0/1
switchport trunk allowed vlan 100,200
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 0002.1662.ab01
no ip address
!
interface Vlan200
mac-address 0002.1662.ab02
no ip address

 

 

BR

here totaly config - undersand each section make test it :

 

BSC switch

Create VLAN 100

interface FastEthernet0/1(connected to BSC PC)
switchport
switchport mode access
switchport access vlan 300 ----------Create a New VLAN 192.168.100.0/24 IP addresss
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100,200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 0090.2b24.4001
ip address 192.168.3.1 255.255.255.0( i change it from your proposition cause the subnet already exist)
!
interface Vlan200
mac-address 0090.2b24.4002
ip address 192.168.2.1 255.255.255.0
!
interface Vlan300
mac-address 0090.2b24.XXXXX
ip address 192.168.100.1 255.255.255.0
ip classless

no ip route 192.168.1.0 255.255.255.252 192.168.3.2
no ip route 192.168.1.4 255.255.255.252 192.168.2.2

 

BTS1 switch
============

interface FastEthernet0/1(connected to BTS1 pc) ( Same config go all the device connect to PC )
switchport
switchport mode access
switchport access vlan 100
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 000c.cf6c.8d01
ip address 192.168.3.2 255.255.255.0
!
no interface Vlan200 ==================== ( you do not need this)

ip default-gateway 192.168.3.1
ip classless
no ip route 192.168.100.0 255.255.255.0 192.168.3.1 << not sure where this route - if this Layuer 2 you do not need this

 

BTS2 switch

interface FastEthernet0/1(connected to BTS2 PC) ==============This should be access port.
switchport
switchport mode access
switchport access vlan 200
duplex auto
speed auto
!
interface FastEthernet0/2
switchport trunk allowed vlan 200
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan200
mac-address 0001.648d.4501
ip address 192.168.2.2 255.255.255.0
!
ip default-gateway 192.168.2.1
ip classless
no ip route 192.168.100.0 255.255.255.0 192.168.2.1


=========================================

L2 switch

Create VLAN 100 and 200 here

interface FastEthernet0/1
switchport trunk allowed vlan 100,200
switchport mode trunk
!

========= Same config you need to do where otehr switches connected

interface FastEthernet0/X ---BTS1 connected
switchport trunk allowed vlan 100,200
switchport mode trunk
!
interface FastEthernet0/X ---BTS2 connected
switchport trunk allowed vlan 100,200
switchport mode trunk

 

interface Vlan1
no ip address
shutdown
!
no interface Vlan100
!
no interface Vlan200

 

===============

 

Post output still not working : ( from all device)

 

show run

show ip interface brief

show ip route

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help