cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3284
Views
0
Helpful
1
Replies

PPPoE + FreeRadius server configuration not working

radu
Level 1
Level 1

Hello,

 

I have an ASR1001 that I want to use as PPPoE, I followed a lot of tutorials and howto's but still not working.

 

My actual configuration:

 

----------------------------------------------------------------------------------

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname PPPoE
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable secret 4 -HIDDEN-
enable password -HIDDEN-
!
aaa new-model
!
!
aaa group server radius PPPoE
server 172.17.0.236 auth-port 1812 acct-port 1813
!
aaa authentication ppp PPPoE group PPPoE
aaa authorization network PPPoE group PPPoE
aaa authorization subscriber-service default local
aaa accounting delay-start all
aaa accounting network PPPoE start-stop group PPPoE
!
!
!
!
aaa server radius dynamic-author
client 172.16.0.236 server-key secret123
server-key secret123
auth-type any
!
aaa session-id common
aaa policy interface-config allow-subinterface
!
!
!
no ip domain lookup
ip domain name localdomain
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
!
!
!
!
multilink bundle-name authenticated
vpdn enable
!
password encryption aes
!
!
!
!
!
!
!
!
redundancy
mode none
!
!
!
ip tftp source-interface GigabitEthernet0
ip ssh time-out 60
ip ssh authentication-retries 4
!
!
!
bba-group pppoe PPPoE
virtual-template 1
sessions per-mac limit 1
sessions auto cleanup
!
!
interface Loopback0
description copy here
ip address 10.20.0.1 255.255.255.255
!
interface GigabitEthernet0/0/0
description to INTERNET
ip address X.X.X.x 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/1
description to PPPoE Customers
no ip address
negotiation auto
pppoe enable group PPPoE
!
interface GigabitEthernet0/1/4
description to RADIUS
ip address 172.16.0.252 255.255.255.0
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 10.69.69.1 255.255.255.0
negotiation auto
!
interface Virtual-Template1
mtu 1492
no ip address
peer default ip address pool Publico
ppp authentication chap PPPoE
ppp authorization PPPoE
ppp accounting PPPoE
ppp ipcp dns 8.8.8.8 8.8.4.4
!
ip local pool Publico 10.10.10.100 10.10.10.200
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 5.1.32.1
!
access-list 20 permit X.X.X.x
!
snmp-server community public RO
!
!
radius server RadiusServer
address ipv4 172.16.0.236 auth-port 1812 acct-port 1813
key secret123
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
access-class 20 in
transport input ssh
line vty 5 15
access-class 20 in
!
!
end

-------------------------------------------------------------------

 

My "customer" is a Mikrotik router with username and password I have in radius table but if I scan for pppoe servers nothing is listed.

 

Anyone know if i need to change something or what?

 

Thanks

1 Reply 1

cpulgarin
Level 1
Level 1
Hi, share the contiguration in the table radgroupreply and logging of ASR.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: