cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
263
Views
5
Helpful
3
Replies
Mohideen Pitchai
Beginner

SR TE Policy with ISIS not coming up in IOS XR | IOS XE

Hi , I am trying to validate SR TE policy on 4 nodes where 2 IOS XR and 2 IOS XE based nodes . I am running ISIS across all the nodes ; With SR running, i am unable to bring up the SR-TE Policy with dynamic option. 

Looking forward for further support to move forward.

 

IOS XE - R2  17.3.1a

 

R2#sh segment-routing traffic-eng policy all

Name: SR_TE_R2_TO_R3 (Color: 23 End-point: 3.3.3.3)
Owners : CLI
Status:
Admin: up, Operational: down for 01:17:20 (since 06-28 22:07:33.345)
Candidate-paths:
Preference 23 (CLI):
Dynamic (inactive)
Inactive Reason: CSPF no path
Metric Type: IGP
Attributes:
Binding SID: 16
Allocation mode: dynamic
State: Programmed

 

 
R2#show segment-routing traffic-eng topology ipv4 | b 3.3.3.3
TE router ID: 3.3.3.3
Host name: R3
ISIS system ID: 0000.0000.0003 level-2 domain ID: 62 ASN: 0
Prefix SID:
Prefix 3.3.3.3, label 16003 (regular), domain ID 62, flags: N

 

Thanks

Mohideen.

3 REPLIES 3
Harold Ritter
Cisco Employee

Hi Mohideen,

 

It could be many things.

 

As this is not a PCE calculated path, did you configure "distribute link-state"?

 

Can you provide the isis configuration.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi @Harold Ritter  

 

Please find below.. I have similar issue in establishing SR-TE policy on IOS XR as well

 

R2 IOS XEXR2 - IOS XR

R2#sh run | s r isis
ip router isis SR_NEW
ip router isis SR_NEW
router isis SR_NEW
net 49.0001.0000.0000.0002.00
is-type level-2-only
metric-style wide
distribute link-state instance-id 62
segment-routing mpls
segment-routing prefix-sid-map advertise-local
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
router isis SR_NEW
is-type level-2-only
net 49.0001.0000.0000.0012.00
distribute link-state instance-id 212 level 2 throttle 10
address-family ipv4 unicast
metric-style wide
mpls traffic-eng level-2-only
mpls traffic-eng router-id Loopback0
router-id Loopback0
segment-routing mpls
!
interface Loopback0
address-family ipv4 unicast
prefix-sid index 12

Hi Mohideen,

 

Are the ISIS interfaces configured as point-to-point interfaces. You need to configure the ISIS interfaces as such for SRTE to work properly.

 

For example:

IOS-XE:

interface GigabitEthernet1

isis network point-to-point

 

XR:

router isis SR_NEW
interface GigabitEthernet0/0/0/0
point-to-point

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México