05-01-2015 11:49 AM - edited 03-05-2019 01:23 AM
Hi All,
I am looking for a redistribution wizard out there!
I am currently studying my CCNP and have built a two-way redistribution topology with dual transit/redistribution routers. I have successfully redistributed routes from OSPF into EIGRP and visa-versa. I can verify the routes are tagged with the show ip route <NETWORK> command
The issue I am facing is how do I verify routes that I am filtering; I am using a route-map to stop routes that have been redistributed into OSPF from EIGRP bleeding back into OSPF. I am confident from the configuration my route map is doing the job; however how can I verify this.
The show route-map <ROUTEMAPNAME> command counters will not increment as I believe these only come into play with PBR. So is thier a similar show command or even a debug I can use to verify this. For example if I walked into a production network and a route was not being seen how would I verify this. I hope this makes sence! Please see the topology and configurations below(If you are use/have used the CBT nuggets training, you may be familiar with this topology.
Topology(Diagram)
** Cisco forums does not like google-drive urls; so I have uploaded a screenshot of the topology **
relevant config snippets
R2
R2#sh run | s route-map
redistribute ospf 1 route-map OSPF_TO_EIGRP
redistribute eigrp 100 subnets route-map EIGRP_TO_OSPF
route-map EIGRP_TO_OSPF deny 5
match tag 40
route-map EIGRP_TO_OSPF permit 10
match ip address 1
set metric 100
set metric-type type-2
set tag 10
route-map EIGRP_TO_OSPF permit 20
match ip address 2
set metric 200
set metric-type type-2
set tag 20
route-map EIGRP_TO_OSPF deny 30
match ip address 3
route-map EIGRP_TO_OSPF permit 40
set metric 300
set metric-type type-2
set tag 30
route-map OSPF_TO_EIGRP deny 5
match tag 10 20 30
route-map OSPF_TO_EIGRP permit 10
set metric 400 20 255 1 1500
set tag 40
R2#sh run | s access-l
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
R2#
R2#sh run | s eigrp
router eigrp 100
redistribute ospf 1 route-map OSPF_TO_EIGRP
network 10.1.23.0 0.0.0.255
network 10.1.24.0 0.0.0.255
no auto-summary
redistribute eigrp 100 subnets route-map EIGRP_TO_OSPF
R2#sh run | s ospf
redistribute ospf 1 route-map OSPF_TO_EIGRP
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute eigrp 100 subnets route-map EIGRP_TO_OSPF
passive-interface default
no passive-interface Serial0/0
network 10.1.12.0 0.0.0.255 area 0
R3
Has exactly the same config as R2.
If you need any more info, let me know. :)
Cheers,
Liam
Solved! Go to Solution.