Showing results for 
Search instead for 
Did you mean: 

RV042 download datarate issue


Hi everyone,

We currently have RV042 configured as a default gateway. It is connected to another Motorola router provided by our ISP. ISP advertised download speed is 50 Mbps down and 5 Mbps up. When I plug in directly into the ISP router, the measured speed is very close to advertised. However, when I plug in RV042 and then do speed test within the private network, or directly connected to RV042 switch, download datarate is barely 15 Mbps, measured without any other network load. Upload datarate is fine.

I tried the firmware update but it seems that my model is not V3, therefore I had to stay at firmware version I did check settings for bandwidth trottling, and even added a rule to allow all services to work at 51200 Kbps, however that did not help.

Any ideas?

Best, Alex

12 Replies 12

Rising star
Rising star

Hi Alex,

Thank you for posting. Try disabling SPI (Stateful Packet Inspection) in the firewall. This should increase the bandwidth through the firewall.


Thanks for your quick response. Unfortunately, disabling SPI did not do anything to the data rate problem. I also failed to mention that I changed the link speed from autonegotiate to 100 Mbps full duplex for all ports. Currently, without any load, I get about 14-15 Mbps, should be close to 50 Mbps.



I asked around and someone mentioned that if you set the MTU to manual and set it to 1500 this can help the throughput. Apparently when set to Auto (1500) the actual value may vary, which can decrease your WAN bandwidth.

Hi mpyhala,

That did not work either. Not sure where to go from this point.


Do you think that I should open a trouble ticket with Cisco, or at least see if this router can be replaced because it is still under warranty?

Hi Alex,

Did you find a solution to your problem?

I recently bought a RV042 and have a similar problem. When I connect my router to the modem (ADLS 8Mb/s) I only get 3 Mb/s throughput. But if I connect another router, or a computer directly to the modem i get full speed. I also tried to connect the RV042 after another router (basically NAT in a NAT) and then I get full speed. So my conclusion is that there is something wrong between my RV042 and my Zyxel modem.

I have the latest FW, and I have tried all the suggested tricks mentioned in the is thread, but I still can't get full speed when connecting the RV042 to the modem. I have contacted the support department of the modem, but they didn't know any issues when using CISCO routers with their modems.

Hi Clas,

Yes, I did. And I am sorry for not posting back the solution here. The problem was in Port Management: Port Setup screen. I was told by our ISP to disable autonegotiation and put 100 Mbps on all ports. When I reactivated autonegotiation on each port, it all started working fine.

Here is a screnshoot of my setup. I hope this helps you as well.


Thanks for the quick response Alex,

I tried to change the autonegotiation settings, tried every possible combination of manual settings as well, restarted, changed back etc. However it didn't solve the problem, but I got a bit closer to the source of my problem. The best throughput was achieved when the settings was 10M at half duplex, then I got 5Mbit/s. Every time I enabled the autonegotiation the speed was terrible. And I cant see why 100M and/or full duplex should be a problem, since other routers use that settings if a connect them to my modem. So there is clearly an issue with how my RV042 is connecting to my modem.


Try using a new cat 5e or 6 cable

Regards Simon

Hi Simon,

Thank you for the tip, I'll try everything that might help :-). Unfortunatly it wasnt the cable. (I have a cat 6 cable which works perfectly with my other router).


What version of hardware are you on? V1, V2, V3? should say on the bottom.

What firmware are you on? Is it the most recent on the Cisco Site?

Cisco Small Business Support Center

Randy Manthey

CCNA, CCNA - Security

Hello Randy,

Its a brand new V3 (PID VID : RV042 V03)

with FW version: v4.1.1.01-sp (Dec 6 2011 20:03:18)

That is the same as the latest on the Cisco site (I double checked the MD5 sums)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers