cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
803
Views
10
Helpful
7
Replies

Still having problems with ISR931, any help would be appreciated.

AdmiralFrisky
Level 1
Level 1

Some quick back story so everyone can understand easier:

- I have two computers, a Netgear cm1200 modem, and a cisco isr931 switch for small business, I want both computers to be connected to the internet via ethernet

- One computer is older, and connected directly to the cm1200 modem and has internet access. I shall call this Old Computer

- The other computer is newer, and is connected to the Cisco ISR931 switch, and has no internet connection as of now, I shall call this New Computer

- I have absolutely zero experience with setting up ethernet, Cisco routers, the coding skills, and computer talk. It seems very fun and intriguing, but my lack of experience is my downfall

Now the back story is complete, now for the dilemma:

I have read the guides on the 900 series routers for software setup, and the applicable parts of the 800 series setup guide, see as the links in the 900 series guide bring me to the 800 series guide. I have PuTTY installed and setup on my computer, and I know to use the console port to connect the router to the computer via a RJ45 cable (I think that's what its called).

Some basic questions, do I plug the CM1200 Modem into the WAN or LAN port on the router? The google definitions of WAN and LAN are confusing to me. 

Now, on to the coding/setup dilemma.

I plugged the modem into the 931 with an ethernet cable into gigabitethernet port 4 (WAN). Now, in PuTTy, after the basic setup and router configuration, I can assign an IP address to that port. Should I be doing that, or is that wrong? Next, I plugged the New Computer into gigabitethernet port 1, and I cannot assign it an IP address as it says "IP addresses may not be configured with L2 links." Now, in Internet Settings on the New Computer, it recognizes the ethernet cable as "Public Ethernet Network", so something has to be working there.

I do not understand how to proceed, as my post on 11/22/22 (I believe that's the date) was apparently seen by 200+ people, but no one could venture a reply. Any help would be appreciated here, thanks.

7 Replies 7

AdmiralFrisky
Level 1
Level 1

Is there another program I need, or anything major I am missing? Or am I missing some small but critical detail that is making the router not work?

as per the information you have provided - i expect below connection for the config suggested to work, connect DSL Ethernet on Gi5 (this is called WAN) connect PC to G1-3 (called Lan ports)

if you like to change any config like IP for Lan feel free to change and change config accordingly to work.

PC need to setup as DHCP, so Router can provide the DHCP with Gateway and DNS.

 

ip dhcp excluded-address 192.168.10.1 192.168.10.20
!
ip dhcp pool BBPOOL
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
!
vlan 10
name PC-connection
!
service dhcp vlan10
!
interface GigabitEthernet0
Description CONNECTING-TO-PC
switchport
switchport mode access
switchport access vlan 10
no shutdown
!
interface GigabitEthernet1
Description CONNECTING-TO-PC
switchport
switchport mode access
switchport access vlan 10
no shutdown
!
interface GigabitEthernet2
Description CONNECTING-TO-PC
switchport
switchport mode access
switchport access vlan 10
no shutdown
!
interface GigabitEthernet3
Description CONNECTING-TO-PC
switchport
switchport mode access
switchport access vlan 10
no shutdown
!
interface GigabitEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet5
Description CONNECTING-TO-ISP
ip address dhcp
ip nat outside
duplex auto
speed auto
no shutdown
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip nat inside
no shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp
!
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
ip nat inside source list 100 interface GigabitEthernet5 overload
!
end
!
wr


Checkings and post below output still not working :

show run
show ip interface brief
show ip nat statistics
Show IP nat translation
Show ip route
show ip access-list

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you! I typed in this code, but I have some questions:

Are the ! marks just spaces, or do I type "exit" or "end" there?

Do I type "configure terminal" and then type all this code into Router(config) #?

When it comes to port the New Computer is connected to, Gigabitethernet1, 

interface GigabitEthernet1
Description CONNECTING-TO-PC
switchport
switchport mode access
switchport access vlan 10
no shutdown

I typed this, but it says "switchport" is an incomplete command. Does that change anything? Because it accepted "switchport mode access" and "switchport access vlan 10".

Finally, when I typed "show ip interface brief", I got this:

Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 unassigned YES unset down down
GigabitEthernet1 unassigned YES unset up up
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES manual administratively down down
GigabitEthernet5 unassigned YES manual down down
NVI0 unassigned YES unset up up
Vlan1 unassigned YES unset down down
Vlan10 192.168.10.1 YES manual up up

 

Why does GigabitEthernet1 IP-Address still say unassigned? And what does it mean when Method for GigabitEthernet1 is unset, Method for Vlan10 is manual?

(excuse vlan1 in the above chart, it was my attempt to follow the online guide)

Thank you.

 

 

as i mentioned before - it not working post below output :

Checkings and post below output still not working :

show run
show ip interface brief
show ip nat statistics
Show IP nat translation
Show ip route
show ip access-list

-

gig1 is in switchport vlan 10 this layer 2 port

When the device is connected to that port - the PC should get IP address from DHCP - its up, which means the PC/end device  is connected.

Does the PC set up DHCP - then what is the IP address PC got it ?

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Forgot to add in response, New Computer is on DHCP. Should I go to Command Prompt on New Computer and run "ipconfig" and show that response?

yes also along with BOLD output mentioned above.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Did you get my last reply with the output from those commands?