10-02-2012 01:34 PM - edited 03-04-2019 05:44 PM
I have a 2-person remote office that has Time Warner RoadRunner internet access for WAN connectivity (7Mb down, 768K up), we have a 1760 router (12.4(25d)) installed behind the cable modem and using it to build a VPN tunnel to our datacenter head end VPN router. Installed in the router is a 4-port ethernet switch WIC used to connect the users phones and PCs. I know this is not an ideal configuration for running VoIP traffic, but it's what I have to work with at the moment.
The problem I am having is with the service policy I believe, we mark the voice traffic at the phone "ef", so I am building a service policy based on that marking and allocating 140K of BW. Data connectivity seems to be fine, but when one of the users gets on a phone call everything slows to almost a halt on the data side, during the call the user can hear the conversation just fine but the other end of the call is cut out, garbled, etc. When running a PingPlotter trace to the public address of the router I see very high latency with numerous drops when the user is on the phone. When I take the service policy off of the Fa0/0 interface, the calls are still bad but data connectivity is not affected during a call.
Am I doing the wrong thing by trying to allocate BW for ef traffic? Or should I just trust the markings and have the router put them in the proper queues? Below is my config as it pertains to QoS/interfaces/etc.......any help would be greatly appreciated!
Thanks.
class-map match-all VoIP
match access-group name VoIP
!
!
policy-map Apply-QoS
class VoIP
priority 140
class class-default
bandwidth remaining percent 100
!
!
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
lifetime 36000
crypto isakmp identity hostname
crypto isakmp keepalive 120
!
crypto isakmp peer address ###.###.###.###
set aggressive-mode password &8UsdD$#aaYtTf6DI43LJ
set aggressive-mode client-endpoint ****.**********.com
!
crypto ipsec security-association lifetime seconds 36000
!
crypto ipsec transform-set GMACI-Trans2 esp-3des
!
crypto ipsec profile vpnprof1
set transform-set GMACI-Trans
!
!
crypto map GMACIMAP 100 ipsec-isakmp
description TunnelToWinston
set peer ###.###.###.###
set transform-set GMACI-Trans2
match address VPNACL
qos pre-classify
!
!
!
!
interface FastEthernet0/0
ip address dhcp
load-interval 30
speed auto
crypto map GMACIMAP
service-policy output Apply-QoS
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 2
!
interface FastEthernet0/4
switchport access vlan 2
!
interface Vlan1
no ip address
!
interface Vlan2
ip address 10.52.213.193 255.255.255.224
ip helper-address 10.32.100.6
ip forward-protocol nd
ip route 10.0.0.0 255.0.0.0 10.48.1.1
ip route ###.###.###.### 255.255.255.255 0.0.0.0
ip route ###.###.###.### 255.255.255.255 0.0.0.0
10-02-2012 06:20 PM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Try:
policy-map Apply-QoS
class VoIP
priority 140
class class-default
bandwidth remaining percent 100
fair-queue
policy-map Apply-QoS-shape
class class-default
shape average 768000
service-policy Apply-QoS
interface FastEthernet0/0
ip address dhcp
load-interval 30
speed auto
crypto map GMACIMAP
service-policy output Apply-QoS-shape
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide