cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2844
Views
0
Helpful
7
Replies

QoS - Help

Alcides Miguel
Level 1
Level 1

Hello,

I configuring QoS policing in a Cisco 2911 in a 128K/256/512 link, but when I apply the configuration in interface I receive the error below:


Configured Percent results in out of range kbps.Allowed range is 8-2000000.

The present CIR value is 6.

Current configuration : 191 bytes

!

interface GigabitEthernet0/1

description ***V-SAT***

bandwidth 128

ip address 10.150.11.50 255.255.255.252

duplex full

speed 100

max-reserved-bandwidth 100

end

!

!

!

class-map match-all VOICE

  description IP Phones mark Voice to EF

   match ip dscp ef

class-map match-all INTERACTIVE-VIDEO

   description Recommended markings for IP/VC

   match ip dscp af41 af42

class-map match-any CALL-SIGNALING

   description Future Call-Signaling marking

   match ip dscp cs3

   description Current Call-Signaling markin

   match ip dscp af31

class-map match-all ROUTING

    description Routers mark Routing traffic to CS6

match ip dscp cs6

class-map match-all NET-MGMT

    description Recommended marking for Network Management

match ip dscp cs2

class-map match-any MISSION-CRITICAL-DATA

    description Interim marking for Mission-Critical Data

match ip dscp 25

    match access-group name Production-Servers

class-map match-all TRANSACTIONAL-DATA

    description Recommended markings for Transactional Data

match ip dscp af21 af22

class-map match-all BULK-DATA

    description Recommended markings for Bulk Data

match ip dscp af11 af12

class-map match-all SCAVENGER

    description Recommended marking for Scavenger traffic

match ip dscp cs1

!

policy-map BRANCH-WAN-EDGE

class VOICE

  priority percent 25

class CALL-SIGNALING

  bandwidth percent 5

class ROUTING

  bandwidth percent 3

class NET-MGMT

  bandwidth percent 2

class MISSION-CRITICAL-DATA

  bandwidth percent 23

  random-detect

class TRANSACTIONAL-DATA

  bandwidth percent 12

  random-detect dscp-based

class BULK-DATA

  bandwidth percent 4

  random-detect dscp-based

class SCAVENGER

  bandwidth percent 1

class class-default

  bandwidth percent 25

  random-detect

!

policy-map SHAPE-WAN-128

class class-default

  shape average 128000

  service-policy BRANCH-WAN-EDGE

!

1 Accepted Solution

Accepted Solutions

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

So what should be your sugestion to correct this issue in my config?

Don't use a percertage less than 7%.

Besides that, I would imagine your 2911 is running a IOS version that supports HQF CBWFQ.  If so, you may not need the max-reserved-bandwidth 100.  Also if HQF, you could consider a 4 class model, with 1 LLQ and 3 classes using FQ.  Provision bandwidth requirement for LLQ and split remaining bandwidth in something like a 81:9:1 ratio.  The 81% class should have priority traffic that's not real-time, the 9% class is for most of your traffic, and the 1% class is for less than best effort.  (If 1% remaining doesn't take either, adjust to minimum acceptable value and adjust other class bandwidths, except LLQ's.)

View solution in original post

7 Replies 7

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

CBWFQ polices, I believe, have a bandwidth minimum setting of 8K, which would be 6.25% of 128 K.  So, any class percentage less than 7% might be a too small value.

Hi Joseph,

So what should be your sugestion to correct this issue in my config?

best regards,

Alcides Miguel

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

So what should be your sugestion to correct this issue in my config?

Don't use a percertage less than 7%.

Besides that, I would imagine your 2911 is running a IOS version that supports HQF CBWFQ.  If so, you may not need the max-reserved-bandwidth 100.  Also if HQF, you could consider a 4 class model, with 1 LLQ and 3 classes using FQ.  Provision bandwidth requirement for LLQ and split remaining bandwidth in something like a 81:9:1 ratio.  The 81% class should have priority traffic that's not real-time, the 9% class is for most of your traffic, and the 1% class is for less than best effort.  (If 1% remaining doesn't take either, adjust to minimum acceptable value and adjust other class bandwidths, except LLQ's.)

Hi Joseph,

I've applied the changed configuration and was successfully can please take a closer look at the script and suggest me modification. just to advice that I'm new to QoS area.

policy-map BRANCH-WAN-EDGE

class VOICE

  priority percent 20

class CALL-SIGNALING

  bandwidth percent 8

class ROUTING

  bandwidth percent 7

class NET-MGMT

  bandwidth percent 8

class MISSION-CRITICAL-DATA

  bandwidth percent 18

  random-detect

class TRANSACTIONAL-DATA

  bandwidth percent 10

  random-detect dscp-based

class BULK-DATA

  bandwidth percent 7

  random-detect dscp-based

class SCAVENGER

  bandwidth percent 7

class class-default

  bandwidth percent 15

  random-detect

!

!

policy-map SHAPE-WAN-256

class class-default

  shape average 256000

  service-policy BRANCH-WAN-EDGE

!

!

interface GigabitEthernet0/2

description ### BRANCH-2-HQ ###

bandwidth 256

ip address 176.26.60.254 255.255.255.254

duplex auto

speed auto

service-policy output SHAPE-WAN-256

end

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

class-map match-any VOICE

  description IP Phones mark Voice to EF

   match ip dscp ef

class-map match-any Foreground

   match ip precedence 2 3 4

   match ip precedence 6 7

class-map match-any Background

   match ip precedence 1

policy-map BRANCH-WAN-EDGE

class VOICE

  priority percent 30

class Foreground

  bandwidth remaining percent 81

  fair-queue

class Background

  bandwidth remaining percent 1

  fair-queue

class class-default

  bandwidth remaining percent 9

  fair-queue

In above, if percentages cause the error you've seen before, try 21:21:7 or 28:14:7, etc.

Also in above, "Normal" traffic isn't described in class-maps, so it goes into class-default.

I'm also matching using mainly IP Precedence, which encompasses the corresponding DSCP class, e.g. IP Prec 2 matches CS2, AF2x (this makes for a little faster matching on a software based router).

Normally I recommend against using WRED, unless you really know how to use it.  FQ in each class will divide bandwidth between flows within that class, fairly, and should first drop packets from flows filling the class's queues.

Hi Joseph,

many thanks for your help was very helpful.

but as you said traffic like mail and other corporate traffic will goes into class-default?

Also in above, "Normal" traffic isn't described in class-maps, so it goes into class-default.

best regards,

Alcides Miguel

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

but as you said traffic like mail and other corporate traffic will goes into class-default?

Basically, anything with a IP Precedence of zero.

Review Cisco Networking for a $25 gift card