02-28-2017 01:54 AM - edited 03-05-2019 08:07 AM
Hi I have two ISP:
ISP 1 - 10.11.12.1 255.255.255.240
ISP 2 - 20.21.22.1 255.255.255.248
I have LAN:
192.168.100.1 255.255.255.0
there are 3 server inside with static NAT address with ISP 1:
192.168.100.10 (10.11.12.4)
192.168.100.20 (10.11.12.5)
192.168.100.30 (10.11.12.6)
and the rest NAT is DHCP from 192.168.100.51 with overload IP with ISP 2:
20.21.22.5
Now I want to make it that all the server (static IP) go through ISP 1 and all DHCP clients go trought ISP 2.
Please help me with that.
Can i do it with "ip route" command?
I thought that it should be okay if I have two entries like that:
ip route 0.0.0.0 0.0.0.0 10.11.12.1
ip route 0.0.0.0 0.0.0.0 20.21.22.1
but this does not work. Everything goes trough 10.11.12.1.
02-28-2017 01:57 AM
03-02-2017 09:41 AM
Hello
As your router will have connected interfaces to these ISPs , You shouldn't have to use two default statics just the primary would be required with an addition of a PBR rule however please note applying statics in this way without any king of conditional rule would not give you any resiliency if the primary ISP became unavailable.
Note: the resiliency can be accomplished by utilising IP Sla and Object tracking (not shown)
Please review below..
ip nat inside source list 1 interface <ISP1> overload
ip nat inside source list 2 interface <ISP2> overload
ip nat inside source static 192.168.100.10 10.11.12.4
ip nat inside source static 192.168.100.20 10.11.12.5
ip nat inside source static 192.168.100.30 10.11.12.6
access-list 1 permit host192.168.100.10
access-list 1 permit host 192.168.100.20
access-list 1 permit host 192.168.100.30
access-list 2 deny host 192.168.100.10
access-list 2 deny host 192.168.100.20
access-list 2 deny host 192.168.100.30
access-list 2 permit 192.168.100.0 0.0.0.255
route-map STAN permit 20
match ip address 1
set ip next-hop 10.11.12.1
int xx
description Lan facing
ip nat inside
ip policy route-map STAN
int xx
description ISP1
ip nat outside
int xx
description ISP2
ip nat outside
ip route 0.0.0.0 0.0.0.0 <iinterface isp2) 20.21.22.1
res
Paul
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide