Showing results for 
Search instead for 
Did you mean: 

3825 IOS upgrade


Hello folks, just need a little guidance as to how to resolve my IOS upgrade issue on my 3825. I have the following statement on my running config.

"boot system flash c3825-advipservicesk9-mz.124-15.T6.bin"

I keep getting the following message when I try to boot to that image (Reload)

console by console.

%SYS-3-IMAGE_TOO_BIG: 'flash:c3825-advipservicesk9-mz.124-15.T6.bin' is too large for available memory (50954264 bytes).

%SYS-6-READ_BOOTFILE_FAIL: flash:c3825-advipservicesk9-mz.124-15.T6.bin File read failed -- Not enough space.

Attached is a copy of the show version & show flash.

TS1#sh flash

-#- --length-- -----date/time------ path

1 32658112 Apr 18 2007 20:45:34 -04:00 c3825-advipservicesk9-mz.124-3g.bin

2 1038 Aug 16 2007 22:11:20 -04:00 home.shtml

3 1826 Aug 16 2007 22:11:22 -04:00 sdmconfig-38xx.cfg

4 113152 Aug 16 2007 22:11:22 -04:00 home.tar

5 1475584 Aug 16 2007 22:11:24 -04:00 common.tar

6 6141952 Aug 16 2007 22:11:32 -04:00 sdm.tar

7 861184 Aug 16 2007 22:11:40 -04:00 es.tar

8 793739 Aug 16 2007 22:11:24 -04:00 256MB.sdf

9 1684577 Apr 18 2007 20:55:48 -04:00 securedesktop-ios-

10 398305 Apr 18 2007 20:56:08 -04:00 sslclient-win-

11 3873 Dec 19 2007 20:35:30 -05:00 pre_autosec.cfg

12 51491936 Dec 03 2008 23:08:10 -05:00 c3825-advipservicesk9-mz.124-15.T6.bin

32526336 bytes available (95653888 bytes used)


TS1#sh ver

Cisco IOS Software, 3800 Software (C3825-ADVIPSERVICESK9-M), Version 12.4(3g), RELEASE SOFTWARE (fc2)

Technical Support:

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Mon 06-Nov-06 05:10 by alnguyen

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

TS1 uptime is 2 hours, 33 minutes

System returned to ROM by power-on

System image file is "flash:c3825-advipservicesk9-mz.124-3g.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

Cisco 3825 (revision 1.1) with 747520K/38912K bytes of memory.

Processor board ID <Removed>

2 FastEthernet interfaces

2 Gigabit Ethernet interfaces

16 terminal lines

2 Channelized (E1 or T1)/PRI ports

1 Virtual Private Network (VPN) Module

4 Voice FXO interfaces

4 Voice FXS interfaces

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

125440K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2102


Thanks in advanced I appreciate your help.

16 Replies 16


The router is not able to allocate the required memory to load the image

Could you try removing the FXO/FXS interfaces from your router and try to see whether it boots up properly


Hi Narayan, do you know if that error is referring to my flash memory or my RAM?


u have 2 images in ur flash since new is already there can you delete the old one and see if that works


Do NOT delete the old image. The old image is what is running now. The new image will not load and run. If you delete the old image your router will boot into rommon and you will need to do a recovery.

The error message is almost certainly indicating that RAM is not sufficient for the new image.





From the error message decoder

1. %SYS-3-IMAGE_TOO_BIG: '[chars]' is too large for available memory ([dec] bytes).

The allocated memory for the image is too small to hold the image file.

Recommended Action: Increase the amount of memory available in the router by booting with a smaller image, disabling nonessential subsystems, or upgrading the installed memory.




I am a bit puzzled at what is going on. The error message seems to be saying that there is not enough memory. But I checked in the Feature Navigator on CCO and it indicates that the memory requirement for the new image is the same as the requirement for the old image. And the show version indicates that you have more than enough memory on the router. It is also very strange that the amount of memory indicated in the error message (50954264 bytes) does not match up with anything that I see in the show version.

Perhaps you could post the complete set of messages sent to the console during the boot process and we might find something there that could explain what is happening.

Or you might try downloading a different (perhaps slightly newer) version of the new image and see if there is something buggy in the particular image that you downloaded.





Hello folks, I was able to resolve the issue by doing the following.

Uploading the original IOS (ipbase) and booting to that & then removing the the (c3825-advipservicesk9-mz.124-3g.bin)

After that I uploaded the newer IOS and then I boot to that new IOS. I am now running on the new IOS. Its weird I've never seen that before.

Thanks for every ones help.

Richard Burts
VIP Community Legend VIP Community Legend
VIP Community Legend


I am glad that you got your problem resolved. Thank you for posting back to the thread and indicating that it was solved and how you solved it. It makes the forum more useful when people can read about a problem and can read how that problem was resolved.

It was a very strange problem and I am still somewhat puzzled by it. It would seem that Edison might be right that the image file was incomplete or corrupted. But I have never seen an incomplete or corrupted image start to boot and get far enough to output messages like these:

%SYS-3-IMAGE_TOO_BIG: 'flash:c3825-advipservicesk9-mz.124-15.T6.bin' is too large for available memory (50954264 bytes).

%SYS-6-READ_BOOTFILE_FAIL: flash:c3825-advipservicesk9-mz.124-15.T6.bin File read failed -- Not enough space.





Narayan, I have 768 MB of RAM only 4% is being used right now. The only thing that was mentioned on the down load site is that it will require 256 MB DRAM & 64 MB flash. I have 128 MB of flash with about 32 MB of available space (thats with both image loaded on flash already).

Thanks Rick, I appreciate it. I wasn't gonna delete my working IOS image anyway, unless I'm 100% sure that the new IOS will boot.

Edison Ortiz
Hall of Fame Mentor Hall of Fame Mentor
Hall of Fame Mentor

You have enough memory:

747520K/38912K bytes of memory.

and enough flash:

32526336 bytes available (95653888 bytes used)

But the image file size does not match:

51491936 Dec 03 2008 23:08:10 -05:00 c3825-advipservicesk9-mz.124-15.T6.bin

52MB - looks like a corrupted file. That image should be 64MB or more.

Download the image once again from CCO, delete this corrupted image and upload the new image.

A quick tip, when downloading the image, Cisco publishes the MD5 information for that image. Use that information and match this MD5 hash on the router with the verify /md5 command.




Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers